百特XM系列仪表

概述 硬件 连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

注意：百特公司仪表的控制软件在2003年初全部更新，开物2000的百特系列仪表驱动程序从4.0.0.3版开始全面支持新版本的仪表，如果您使用的是2003年前的仪表，请予我公司联系，获得特殊的驱动程序。

百特XM系列仪表概述

XM系列仪表由福州福光百特自动化设备有限公司出品。

开物2000使用您计算机中的串行口与一台或多台百特XM系列仪表的通讯口连接，实现数据通讯功能。

双方共同采用百特仪表通讯协议，目前开物2000支持的仪表类型如下(新的型号请咨询华富惠通公司)：

项目符号 | XMZ5000：XMZ5000/XMZ6000 系列智能数字显示仪表。
项目符号 | XMA5000：XMA5000系列通用专家自整定PID调节器。
项目符号 | XMC5000：24通道带现场指示高速通用数据采集器。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

百特XM系列仪表与计算机的连接

百特仪表与计算机的连接两种方式：

项目符号 | 通过RS232或RS485方式直接连接，开物2000支持此种方式。
项目符号 | 汇集到通讯控制器FCC5000后，由FCC5000与计算机连接。开物2000暂时不支持此种方式。

计算机采用RS-485通讯方式时，一个串口最多能254台百特XM系列仪表，其地址号范围是1-254。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘百特系列仪表’，或单击选中‘百特系列仪表’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个仪表)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建设备的方式：选中‘自动创建’后，单击‘下一步’按钮。

步骤4：显示自动搜索设备配置界面。在向导自动搜索到所有硬件设备后，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘百特仪表’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指仪表的表号，用于识别设备中的仪表。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表号。

项目符号

Ch指通道号。标签地址中省略Ch时，开物2000系统默认为是所连接的仪表的最小通道号。

项目符号 | 红色字表示格式中可变部分，十进制数表示，变化范围参见各种仪表的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
项目符号 | 标签地址配置成不存在类型或仪表表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

注释信息

PV ID:Ch

瞬时值

模拟量

只读

-32767～32767

MeterTypeID:

仪表类型

字符串量

只读

所有表型号描述

AlarmStatusAID:Ch

报警1状态

开关量

可读可写

true～false

AlarmStatusBID:Ch

报警2状态

开关量

可读可写

true～false

AlarmStatusCID:Ch

报警3状态

开关量

可读可写

true～false

AlarmStatusDID:Ch

报警4状态

开关量

可读可写

true～false

FlowSumID:Ch

流量积算值

模拟量

只读

0～9999999999

OPAID:Ch

DA1值(OP/输出值1)

模拟量

只读

0～100

OPBID:Ch

DA2值(OP/输出值2)

模拟量

只读

0～100

SPID:Ch

SP值

模拟量

只读

-32767～32767

OLTimeID:Ch

越限时间

字符串量

只读

0000:00:00-9999:99:99

InputTypeID:Ch

分度号

模拟量

可读可写

-32767～32767

MinRangeID:Ch

量程零点

模拟量

可读可写

-32767～32767

MaxRangeID:Ch

量程满度

模拟量

可读可写

-32767～32767

FilterID:Ch

小信号切除（滤波阀值）

模拟量

可读可写

-32767～32767

DAAModeID:Ch

DA1方式

模拟量

可读可写

-32767～32767

DABModeID:Ch

DA2方式

模拟量

可读可写

-32767～32767

AlarmLoopID:Ch

报警回差

模拟量

可读可写

-32767～32767

AlarmAID:Ch

报警一值

模拟量

可读可写

-32767～32767

AlarmBID:Ch

报警二值

模拟量

可读可写

-32767～32767

AlarmCID:Ch

报警三值

模拟量

可读可写

-32767～32767

AlarmDID:Ch

报警四值

模拟量

可读可写

-32767～32767

AlarmModeID:Ch

报警方式

模拟量

可读可写

0000～1111

参见信息一

VicScreenID:

付屏

模拟量

可读可写

0-4

DOLID:Ch

DO输出(低报状态)

开关量

可读可写

true～false

DOHID:Ch

DO输出(高报状态)

开关量

可读可写

true～false

PIDPID:Ch

PID P 值

模拟量

可读可写

0～10000

PIDIID:Ch

PID I 值

模拟量

可读可写

1～3600

PIDDID:Ch

PID D值

模拟量

可读可写

0～20

MaxPIDID:Ch

PID 上限幅

模拟量

可读可写

0～100

MinPIDID:Ch

PID 下限幅

模拟量

可读可写

0～100

PIDSLevelID:Ch

PID 安全阀位

模拟量

可读可写

-32767～32767

PIDChgRateID:Ch

PID 变化率

模拟量

可读可写

-32767～32767

PIDSPID:Ch

PID SP0值

模拟量

可读可写

-32767～32767

PWMID:Ch

PWM 周期

模拟量

可读可写

-32767～32767

SPXXID:Ch

程序起点工程量

模拟量

可读可写

-32767～32767

TXXID:Ch

程序时间分

模拟量

可读可写

-32767～32767

RunStopID:Ch

启停程序

开关量

可读可写

True（启动）～false(停止)

OPModeID:Ch

手自动切换

开关量

可读可写

True(自动)～false(手动)

FCCTimeID:Ch

读写FCC时钟

模拟量

可读可写

-32767～32767

AlarmMode数据值含义：

AlarmMode标签读写的标签值格式见下表：

报警1的方式 | 报警2的方式 | 报警3的方式 | 报警4的方式
X | X | X | X

注：表格中X只有两种 取值0和1，0代表低报警状态，1代表高报警状态。

下表是AlarmMode的所有取值：

AlarmMode标签值 | 含义
0 | 报警1是低报警方式，报警2是低报警方式，报警3是低报警方式，报警4是低报警方式。
1 | 报警1是低报警方式，报警2是低报警方式，报警3是低报警方式，报警4是高报警方式。
10 | 报警1是低报警方式，报警2是低报警方式，报警3是高报警方式，报警4是低报警方式。
11 | 报警1是低报警方式，报警2是低报警方式，报警3是高报警方式，报警4是高报警方式。
100 | 报警1是低报警方式，报警2是高报警方式，报警3是低报警方式，报警4是低报警方式。
101 | 报警1是低报警方式，报警2是高报警方式，报警3是低报警方式，报警4是高报警方式。
110 | 报警1是低报警方式，报警2是高报警方式，报警3是高报警方式，报警4是低报警方式。
111 | 报警1是低报警方式，报警2是高报警方式，报警3是高报警方式，报警4是高报警方式。
1000 | 报警1是高报警方式，报警2是低报警方式，报警3是低报警方式，报警4是低报警方式。
1001 | 报警1是高报警方式，报警2是低报警方式，报警3是低报警方式，报警4是高报警方式。
1010 | 报警1是高报警方式，报警2是低报警方式，报警3是高报警方式，报警4是低报警方式。
1011 | 报警1是高报警方式，报警2是低报警方式，报警3是高报警方式，报警4是高报警方式。
1100 | 报警1是高报警方式，报警2是高报警方式，报警3是低报警方式，报警4是低报警方式。
1101 | 报警1是高报警方式，报警2是高报警方式，报警3是低报警方式，报警4是高报警方式。
1110 | 报警1是高报警方式，报警2是高报警方式，报警3是高报警方式，报警4是低报警方式。
1111 | 报警1是高报警方式，报警2是高报警方式，报警3是高报警方式，报警4是高报警方式。

标签举例：

标签 ：PV
数据值类型：模拟量
描述 ：表示设备中仪表号最小的仪表的最小通道的瞬时值。

标签 ：PV2:12
数据值类型：模拟量
描述 ：表示开物设备中仪表号为2的仪表的第12通道的瞬时值。

标签 ：AlarmStatusA3:2
数据值类型：模拟量
描述 ：表示开物设备中仪表号为3的仪表的第2通道的报警1状态。


XMA5000系列通用专家自整定PID调节器

标签地址及范围 标签举例 在线升级驱动

 注意：百特公司仪表的控制软件在2003年初全部更新，开物2000的百特系列仪表驱动程序从4.0.0.3版开始全面支持新版本的仪表，如果您使用的是2003年前的仪表，请予我公司联系，获得特殊的驱动程序。

XMA5000系列仪表支持的标签列表

各种标签的合法的通道地址 ID:范围如下表 ，各种标签的详细解释请参见百特XM系列仪表综述：

说明：

项目符号

ID指仪表的表号，用于识别设备中的仪表。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表号。

标签地址 | 标签含义 | 注释信息
PV ID:Ch | 瞬时值 | Ch=1或2，为2表示室温值
MeterTypeID: | 仪表类型 |
AlarmStatusAID: | 报警1状态 |
AlarmStatusBID: | 报警2状态 |
OPAID: | DA1值(OP/输出值1) |
SPID: | DA2值(OP/输出值2) |
InputTypeID: | 分度号 |
MinRangeID: | 量程零点 |
MaxRangeID: | 量程满度 |
FilterID: | 小信号切除（滤波阀值） |
DAAModeID: | DA1方式 |
AlarmLoopID: | 报警回差 |
AlarmAID: | 低报警值 |
AlarmBID: | 高报警值 |
AlarmModeID: | 报警方式 | 详细说明参见信息 一
OPModeID: | 手自动切换 | 只读标签。
PIDPID: | PID P 值 |
PIDIID: | PID I 值 |
PIDDID: | PID D值 |
MaxPIDID: | PID 上限幅 |
MinPIDID: | PID 下限幅 |
PIDSLevelID: | PID 安全阀位 |
PIDID:gRateID: | PID 变化率 |
PIDSPID: | PID SP0值 |
PWMID: | PWM 周期 |
SPXXID: | 程序起点工程量 |
TXXID: | 程序时间分 |
RunStopID: | 启停程序 |
VicScreenID: | 付屏 | 详细说明参见信息二

AlarmMode数据值含义：

AlarmMode标签读写的标签值范围见下表：

说明：

项目符号

xx有四种组合：00、01、10、11，在百特的通讯协议中规定为报警3和报警4的工作方式，在XMA5000系列仪表中可不加考虑。

AlarmMode标签值 | 含义
00xx | 报警1的工作方式是低报警，报警2的工作方式是低报警。
01xx | 报警1的工作方式是低报警，报警2的工作方式是高报警。
10xx | 报警1的工作方式是高报警，报警2的工作方式是低报警。
11xx | 报警1的工作方式是高报警，报警2的工作方式是高报警。

VicScreen 数据值含义：

标签值 | 标签值含义
0 | 仪表付屏上显示给定值
1 | 仪表付屏上显示控制输出值
2 | 仪表付屏上显示室温值
3 | 仪表付屏上显示报警1设定值
4 | 仪表付屏上显示报警2设定值

XMA5000系列仪表标签举例：

标签 ：PV
数据值类型：模拟量
描述 ：表示设备中仪表号最小的仪表的通道1的瞬时值。

标签 ：PV2:
数据值类型：模拟量
描述 ：表示开物设备中仪表号为2的仪表的通道1的瞬时值。

标签 ：PIDP3:
数据值类型：模拟量
描述 ：表示开物设备中仪表号为3的仪表的通道1的PID P参数。

标签 ：MeterType4:
数据值类型：字符串量
描述 ：表示设备中仪表 号为4的仪表的仪表类型。


XMC5000系列24通道带现场指示高速通用数据采集器

标签地址及范围 标签举例 在线升级驱动

 注意：百特公司仪表的控制软件在2003年初全部更新，开物2000的百特系列仪表驱动程序从4.0.0.3版开始全面支持新版本的仪表，如果您使用的是2003年前的仪表，请予我公司联系，获得特殊的驱动程序。

XMC5000系列仪表支持的标签列表

各种标签的合法的通道地址 Ch 范围如下表 ，各种标签的详细解释请参见百特XM系列仪表综述：

说明：

项目符号

ID指仪表的表号，用于识别设备中的仪表。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表号。

项目符号

Ch指通道号。标签地址中省略Ch时，开物2000系统默认为是所连接的仪表的最小通道号。

标签地址 | 标签含义 | Ch范围 | 注释信息
PV ID:Ch | 瞬时值 | 1～24 |
MeterType ID: | 仪表类型 | 无需填写通道号 | 模拟量类型标签返回6，字符串类型标签返回'XMC5000'
AlarmStatusA ID:Ch | 低报警状态 | 1～24 |
AlarmStatusB ID:Ch | 高报警状态 | 1～24 |

XMC5000系列仪表标签举例：

标签 ：PV
数据值类型：模拟量
描述 ：表示设备中仪表号最小的仪表的最小通道的瞬时值。

标签 ：PV2:12
数据值类型：模拟量
描述 ：表示开物设备中仪表号为2的仪表的第12通道的瞬时值。

标签 ：AlarmStatusA3:2
数据值类型：模拟量
描述 ：表示开物设备中仪表号为3的仪表的第2通道的低报警状态。

标签 ：MeterType4:
数据值类型：字符串量
描述 ：表示设备中仪表 号为4的仪表的仪表类型。


XMZ5000/XMZ6000系列智能数字显示仪表

XMZ5000系列通用专家自整定PID调节器

标签地址及范围 标签举例 在线升级驱动

 注意：百特公司仪表的控制软件在2003年初全部更新，开物2000的百特系列仪表驱动程序从4.0.0.3版开始全面支持新版本的仪表，如果您使用的是2003年前的仪表，请予我公司联系，获得特殊的驱动程序。

XMZ5000系列仪表支持的标签列表

XMZ5000系列仪表支持的标如下表 ，各种标签的详细解释请参见百特XM系列仪表综述：

说明：

项目符号

ID指仪表的表号，用于识别设备中的仪表。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表号。

标签地址 | XMZ5000中标签含义
PV ID: | 瞬时值
MeterType ID: | 仪表类型
AlarmStatusA ID: | 报警1状态
AlarmStatusB ID: | 报警2状态

XMZ5000系列仪表标签举例：

标签 ：PV
数据值类型：模拟量
描述 ：表示设备中仪表号最小的仪表的通道1的瞬时值。

标签 ：PV2:
数据值类型：模拟量
描述 ：表示开物设备中仪表号为2的仪表的通道1的瞬时值。

标签 ：AlarmStatusA3:
数据值类型：模拟量
描述 ：表示开物设备中仪表号为3的仪表的通道1的报警 1 状态。

标签 ：MeterType4:
数据值类型：字符串量
描述 ：表示设备中仪表 号为4的仪表的仪表类型。


用户常见问题

注意：百特公司仪表的控制软件在2003年初全部更新，开物2000的百特系列仪表驱动程序从4.0.0.3版开始全面支持新版本的仪表，如果您使用的是2003年前的仪表，请予我公司联系，获得特殊的驱动程序。

 设备向导首页的“调试设置”按钮有什么用处

设备向导首页的“版本信息”按钮有什么用处

RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。
项目符号

显示最新的驱动程序帮助文件。

我编写了一个M寄存器控制Q寄存器的移位程序，从程序上来讲，应该是Q寄存器的状态变化比M寄存器滞后，（注：两者的扫描周期相同），为什么出现M寄存器的状态变化比Q寄存器滞后？

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。