理化REX-D系列 温度控制器

理化REX-D系列温度控制器 概述 创建设备 标签类型 在线升级驱动

理化REX-D系列温度调节器

1、 REX-D系列温度控制器D100、D400、D900三种类型。
2、 设备地址范围0～99，设备最大连接数32（包括主机）。

在开物2000开发环境中创建设备

第一步、运行开物2000，进入开发环境，双击工程中的硬件系统，选择（或创建计算机节点）。

第二步、点击右键弹 出菜单选择“新建”，弹出窗体如下：

第三步、在目录树中展开节点“智能仪表”，选择“日本理化REX-D系列温度调节器”，在左边设备名一栏中输入设备名称（自己定义即可），定义后如下图所示：

第四步、点击“选择”按钮，进入设备操作方式选择界面，如下图所示： 选择新建设备，点击下一步。

第五步、选择“新建设备”，点击“下一步”按钮进入设备连接方式选择界面，如下图所示。

第六步、在设备的连接方式上根据需要进行选择，这里以485方式为例连接，点击“下一步”按钮，进入设备类型选择界面，点击添加按钮如下图所示。

第七步、根据需要选择设备的型号，设备号设置为仪表的地址号，选择D100，地址设为0，点击"下一步"按钮进入仪表参数设置界面，如下所示。

第八步、在这里根据实际连接情况设置串行口、波特率、数据位、停止位、校验方式(校验方式选择空校验)等几个参数，根据需要选择高级参数设置，然后点击按钮“下一步”进入 高级参数设置界面，如下图所示。

第九步、根据现场实际情况设置通讯超时时间，点击“下一步”进入确认按钮，进入确认界面，点击”完成“按钮，创建设备结束。

理化REX-D系列温度控制器支持的标签类型

说明：
项目符号

标签类型建立方式： NameID:CH

项目符号

Name 表示标签名称

项目符号

ID表示设备地址号(开物2000设备向导中的表号)，取值范围是0-99。

项目符号

下表中CH表示仪表的通道号，具体定义参见下表。

项目符号

兰色、红色字表示格式中可变部分。

例1：

计算机欲访问硬件表号为2、通道号为2的CD401回路调节仪的PV值，查通道号表得到通道号为1，则标签定义为 ReadF2：1，其中‘ReadF’指明标签类型是只读Float型数据，‘2’对应设备地址号，‘1’表示的是通道号，冒号是规则要求，以区分表号和 通道号。

标签名称

CH

CH含义

长度

数据类型

标签值范围

备注

ReadF

1

PV

6

Float

Winthin input range

M1

2

Current Transformer input 1

6

Float

0-100A

M2

3

Current transformer input 2

6

Float

0-100A

M3

4

Manipulated output 1 Heating-side

6

Float

-5.0～105%

O1

5

Manipulated output 2 Cooling-side

6

Float

-5.0～105%

02

6

Sv

6

Float

MS

7

Error code

6

Float

0-255

ER

ReadB

8

Alarm 1 Status

6

boolean

AA

9

Alarm 2 Status

6

boolean

AB

10

Heater break alarm output1

6

boolean

AC

11

Heater break alarm output 2

6

boolean

AD

12

Control loop break alarm

6

boolean

AE

13

burnout

6

boolean

B1

RWF

14

SV

6

Float

Within input range

S1

15

MV

6

Float

ON

16

SV2

6

Float

S2

17

Alarm 1 setting

6

Float

-1999-9999

A1

18

Alarm 2 setting

6

Float

-1999-9999

A2

19

Header break alarm1 setting

6

Float

0-100

A3

20

Header break alarm2 setting

6

Float

0-100

A4

21

PV bias

6

Float

-1999-9999

PB

22

SV change rate limit

6

Float

0～9999

HH

23

Frist alarm differential gap

6

Float

0～100

HA

24

Second alarm differential gap setting

6

Float

0～100

HB

25

Heat-side proportional band

6

Float

0.1-9999

P1

26

Anti-reset windup

6

Float

1～100

W1

27

Cool-side proportional band

6

Float

1～1000

P2

28

Deadband

6

Float

-10～10

V1

29

ON/OFF action differential gap

6

Float

0～50

MH

30

Manual reset

6

Float

-50.0～50.0%

MR

31

Output limit(high-limit)

6

Float

low～105.0

OH

32

Output limit(low-limit)

6

Float

-5.0～high

OL

33

Output limit[high-limit](out2)

6

Float

0～105.0%

OI

34

Analog output specification

6

Float

0～4

LA

35

High limit analog output range

6

Float

HV

36

Low limit analog output range

6

Float

HW

37

Scaling high-limit

6

Float

LOW～9999

XV

38

Scaling low-limit

6

Float

-1999～HIGH

XW

RWB

39

AUTO/MAN Transfer

6

Boolean

J1

40

RUN/STOP

6

Boolean

SR

41

Auto tuning transfer

6

Boolean

G1

42

Fazzy

6

Boolean

XP

43

Direct/reverse action selection

6

Boolean

XE

44

AUTO/MAN function selection

6

Boolean

PQ

45

Control RUN/STOP display selection

6

Boolean

DH

RWI

46

First alarm action selection

6

integer

0～14

XA

47

First alarm timer setting

6

integer

0～600

TD

48

Control loop break alarm setting

6

integer

0-7200

A5

49

LBA Deadband

6

integer

0～9999

V3

50

Second alarm action selection

6

integer

0～14

XB

51

Second alarm timer setting

6

integer

0～600

TG

52

HBA delay timer

6

integer

0～600

TH

53

Integral time

6

integer

1～3600

I1

54

Derivative time

6

integer

1～3600

D1

55

Heat-side proportioning cycle

6

integer

1～100

T0

56

Cool-side proportioning cycle

6

integer

1～100

T1

57

Input type selection

6

integer

0～37

XI

58

Decimal-point positioin selection

6

integer

0～1

XU

59

Current transformer type selection

6

integer

0～1

XR

60

Air cooling/water cooling selection

6

integer

0～1

XQ

61

Auto-tuning(AT) differential gap

6

integer

0～3600

GH

62

Action selection at input abnormality

6

integer

0～12

WH

63

Universal output selection

6

integer

0～12

X0

标签举例：（地址为0）

ReadF0:1 只读pv值。

ReadB0:8 报警1状态。

RWF0:14 读写sv值。

RWB0:40 读写布尔值 设备的启动停止。

RWI0:53 读写整型值 Interval time。

说明：1、在备注一栏中括号里面的数据代表的是该标签支持的类型。

2、其中CH号为3、20只适用于REX-D100。