理化CD系列回路调节仪

理化CD系列回路调节仪 概述 创建设备 标签类型 在线升级驱动

理化CD系列回路调节仪

1、 理化CD系列回路调节仪包括CD401、CD901两个型号。
2、 设备地址范围0～99，设备最大连接数32（包括主机）。
3、 波特率设置：
参数名称 | 设置范围 | 厂商设置
bps | 0：2400 bps | 2
1：4800 bps
2：9600 bps
3：19200 bps

4、数据位设置（参数名 bit ，厂商设置 0）
设置 | 数据位 | 校验方式 | 停止位
0 | 8 | None | 1
1 | 8 | None | 2
2 | 7 | Even | 1
3 | 7 | Even | 2
4 | 7 | Odd | 1
5 | 7 | Odd | 2

5、Interval time 设置范围 0～150， 厂商设置 5。 Interval time ＝ Interval time set value × 1.666 ms。

在开物2000开发环境中创建设备

第一步、运行开物2000，进入开发环境，双击工程中的硬件系统，选择（或创建计算机节点）。

第二步、点击右键弹 出菜单选择“新建”，弹出窗体如下：

第三步、在目录树中展开节点“智能仪表”，选择“理化CD系列回路调节仪”，在左边设备名一栏中输入设备名称（自己定义即可），定义后如下图所示：

第四步、点击“选择”按钮，进入设备操作方式选择界面，如下图所示： 选择新建设备，点击下一步。

第五步、选择“新建设备”，点击“下一步”按钮进入设备连接方式选择界面，如下图所示。

第六步、在设备的连接方式上根据需要进行选择，这里以485方式为例连接，点击“下一步”按钮，进入设备类型选择界面，点击添加按钮如下图所示。

第七步、根据需要选择无纸记录仪的型号，设备号设置为仪表的地址号，选择CD401，地址设为2，点击"下一步"按钮进入仪表参数设置界面，如下所示。

第八步、在这里根据实际连接情况设置串行口、波特率、数据位、停止位、校验方式(校验方式选择空校验)等几个参数，根据需要选择高级参数设置，然后点击按钮“下一步”进入 高级参数设置界面，如下图所示。

第九步、根据现场实际情况设置通讯超时时间，点击“下一步”进入确认按钮，进入确认界面，点击”完成“按钮，创建设备结束。

理化CD系列回路调节仪支持的标签类型

说明：
项目符号

标签类型建立方式： NameID:CH

项目符号

Name 表示标签名称

项目符号

ID表示设备地址号(开物2000设备向导中的表号)，取值范围是0-99。

项目符号

下表中CH表示仪表的通道号，具体定义参见下表。

项目符号

兰色、红色字表示格式中可变部分。

例1：

计算机欲访问硬件表号为2、通道号为2的CD401回路调节仪的PV值，查通道号表得到通道号为1，则标签定义为 ReadF2：1，其中‘ReadF’指明标签类型是只读Float型数据，‘2’对应设备地址号，‘1’表示的是通道号，冒号是规则要求，以区分表号和 通道号。

标签名称 | CH | CH含义 | 长度 | 数据类型 | 标签值范围 | 备注
ReadF | 1 | PV | 6 | Float | Winthin input range | M1
2 | Current Transformer input 1 | 6 | Float | 0～100A | M2
3 | Current transformer input 2 | 6 | Float | 0～100A | M3
ReadB | 4 | Alarm 1 Status | 6 | boolean | AA
5 | Alarm 2 Status | 6 | boolean | AB
6 | burnout | 6 | boolean | B1
ReadI | 7 | Error code | 6 | integer | 0～255 | ER
RWF | 8 | SV | 6 | Float | Within input range | S1
9 | Alarm 1 setting | 6 | Float | -1999～9999 | A1
10 | Alarm 2 setting | 6 | Float | -1999～9999 | A2
11 | Header break alarm1 setting | 6 | Float | 0～100 | A3
12 | Header break alarm2 setting | 6 | Float | 0～100 | A4
13 | Control loop break alarm setting | 6 | Float | 0.1～200 | A5
14 | LBA deadband | 6 | Float | 0～9999 | A6
15 | Heat-side proportional band | 6 | Float | 0.1～9999 | P1
16 | PV bias | 6 | Float | -1999～9999 | PB
RWB | 17 | RUN/STOP | 6 | boolean | SR
18 | Autotuning | 6 | boolean | G1
19 | Self-tuning | 6 | boolean | G2
RWI | 20 | Integral time | 6 | integer | 1～3600 | I1
21 | Derivative time | 6 | integer | 1～3600 | D1
22 | Anti-reset windup | 6 | integer | 1～100 | W1
23 | Heat-side proportioning cycle | 6 | integer | 1～100 | T0
24 | Cool-side proportional band | 6 | integer | 1～1000 | P2
25 | Deadband | 6 | integer | -10～10 | V1
26 | Cool-side proportioning cycle | 6 | integer | 1～100 | T1
27 | Set data lock function | 6 | integer | 0～7 | LK

标签举例：（地址为2）

ReadB2:4 只读布尔值 报警器1的状态。

ReadI2:7 只读整型值 错误码。

RWF2:8 读写浮点数值 sv。

RWB2:17 读写布尔值 设备的启动停止。

RWI2:20 读写整型值 Interval time。