浙大中控R无纸记录仪

浙大中控R无纸记录仪 概述 创建设备 标签类型 在线升级驱动

浙大中控R无纸记录仪概述

1、R系列无纸记录仪包括R1000、R2000、R3000、R4000、R5000五种类型。
2、因为该系列仪表采用相同的协议，所以此驱动程序是面向该系列开发的，具体型号的功能请根据操作说明书选择。
3、驱动程序实现的主要是10H、12H、13H、14H、15H五个命令。涉及到的功能有：读、读、写、读、写累积数据。
4、实时I/O数据的读取。
5、回路实时数据的读取。
6、回路实时数据的写入。
5、累积数据的读取。
8、累积数据的写入。

在开物2000开发环境中创建设备

第一步、运行开物2000，进入开发环境，双击工程中的硬件系统，选择（或创建计算机节点）。

第二步、点击右键弹 出菜单选择“新建”，弹出窗体如下：

第三步、在目录树中展开节点“智能仪表”，选择“中控R无纸记录仪”，在左边设备名一栏中输入设备名称（自己定义即可），定义后如下图所示：

第四步、点击“选择”按钮，进入设备操作方式选择界面，如下图所示： （在下面的界面中点击“调试设置”按钮，进入报文设置的界面，选择里面三个选项，删除下面文本框中的数据，点击”保存修改“按钮，退出即可。在测试结束后在到该界面把报文保存出来即可）

第五步、选择“新建设备”，点击“下一步”按钮进入设备连接方式选择界面，如下图所示。

第六步、在设备的连接方式上根据需要进行选择，这里我们选择232方式连接，点击“下一步”按钮，进入设备类型选择界面，如下图所示。

第七步、根据需要选择R系列无纸记录仪的型号，这里我们选择“R2000”，设备号设置为仪表的地址号，点击"下一步"按钮进入仪表参数设置界面，如下所示。

第八步、在这里根据实际连接情况设置串行口、波特率、数据位、停止位、校验方式等几个参数，然后点击按钮“下一步”进入设备创建确认界面，如下图所示。

第九步、点击”完成“按钮，创建设备结束。

浙大中控无纸记录仪支持的标签类型

说明：浙大

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的表号)，取值范围是0-100。

项目符号

下表中CH表示仪表的通道号，即无纸记录仪的回路号。

项目符号

兰色、红色字表示格式中可变部分，十进制数表示。

例1：

计算机欲访问硬件表号为5、2号回路的无纸记录仪的的给定值，则在设备标签的定义中该标签的主地址应定义为‘SV5:2’，其中‘SV’指明访问的参数是给定值，‘5’对应开物2000中的设备表号 ，‘2’表示的是回路号，冒号是规则要求，以区分表号和段号。

标签地址

         CH含义

对应的参数含义

标签值类型

标签值范围
NAIID:CH | R系列无纸记录仪是多通道设备，标签中的CH号表示的就是设备的通道号，取值范围根据设备的通道数量而定。 | AI数量 | 模拟量 | 0-32
AIID:CH | AI值 | 模拟量 | 0-(-30000-30000) 1-(0-65535)

NAO ID:CH

AO数量

模拟量

0-8

AO ID:CH | AO值 | 模拟量 | 0-(-30000-30000) 1-(0-65535)

NDI ID:CH

DI数量

模拟量

0-32

DIID:CH

DI值

开关量

0-1

NDOID:CH

DO数量

模拟量

0-32

DOID:CH

DO值

开关量

0-1

NLOPID:CH

回路数量

模拟量

0-8

PVID:CH

输入值PV

模拟量

0-(-30000-30000) 1-(0-65535)

RALID:CH

偏差报警

开关量 0-1

AUTOID:CH

手自动

开关量

0-1

SVID:CH

给定值SV

模拟量

0-(-30000-30000) 1-(0-65535)
MVID:CH

阀位值MV

模拟量

0-(-30000-30000) 1-(0-65535)

NSUMID:CH

累积数据总数量

模拟量

0-

VSUMID:CH

累积数据累积值

模拟量

-2147483647-2147483647

说明：通道号从1开始，如果标签数据没有通道号，则输入0，如：NSUM表示累积数据总数量，并没有通道号，则标签的建立方式为NSUMID：0，ID为仪表的地址号。


Microsoft HTML Help Compiler 4.74.8702

Compiling e:\驱动\中控仪表\HELP_RESOURCE\浙大中控R无纸记录仪.CHM

Compile time: 0 minutes, 1 second
3	Topics
5	Local links
2	Internet links
10	Graphics

Created e:\驱动\中控仪表\HELP_RESOURCE\浙大中控R无纸记录仪.CHM, 191,452 bytes
Compression decreased file by 73,816 bytes.