欧陆2604仪表

概述 硬件连接和设置 创建设备 标签的创建 标签的地址 配置规则 标签举例 在线升级

欧陆2604仪表概述

欧陆2604 是一种高精度、高稳定性的温度/过程控制器，它适用于单回路，双回路或三回路模式。它具有双 7 段 LCD 面板显示，用以显示过程变量和设定值等信息和用户定义信息。

当 2604 被设置为编程器时，它将提供下列先进 的编程功能：

· 可存储多达 50 个程序

· 每个程序最多可定义三个变量

· 每个程序最多可有 16 路事件输出。

欧陆2604驱动支持12中标签 PV,SP,SL,PAR,AlarmA,AlarmB,AlarmC,AlarmD,Manual,Sensor,Loop,Heater。虽然只有12种标签但可以通过PAR访问任何地址的寄存器。

现在说明一下该表面板上的一些设置如下:

硬件连接和设置

该系列模块和上位机的连接有RS232、RS485和RS422三种方式,其连接方式如下:

图中的连线采用双绞线，详细的连线方法，包括线路匹配电阻的安装，请参见欧陆2000系列控制器的通信手册，HA026230和EMC安装指导HA025464手册。

注意：TX＋接422转换模块上的RX－，TX－接422转换模块上的RX＋，

RX＋接422转换模块上的TX－，RX－接422转换模块上的TX＋。

创建设备

首先进行硬件配置向导

在智能模块中选择“欧陆仪表2000系列”，然后单击“选择”按钮就可以进行下一步。

2．接下来进行欧陆仪表的创建向导，选择“新建设备”就可以了。单击“下一步”

3．用户如果选择的是连接多台设备，那么在下一个界面中要选择“多设备创建”

4．在最后一步中进行串口参数设置

主控制器通訊地址： 缺省为1 范围为1 ~ 255

串口通讯参数：本系列仪表缺省值为

波特率

9600

数据位

8位

停止位

2位

校验位

无校验

标签的创建

使用设备向导创建完成2604仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签地址 | 对应的参数含义 | 标签值类型 | 读写类型 | 地址Ch范围 | 标签值范围
PVID: | 过程变量 | 模拟量 | 可读 | 无 | 0~65535
SPID: | 当前设定值 | 模拟量 | 可读 | 无 | 0~65535
SL ID: | 目标设定值（手动状态下） | 模拟量 | 可读/可写 | 无 | 0~65535
AlarmA ID: | 报警1状态 | 开关量 | 可读 | 无 | 1=有报警 0=无报警
AlarmB ID: | 报警2状态 | 开关量 | 可读 | 无 | 1=有报警 0=无报警
AlarmC ID: | 报警3状态 | 开关量 | 可读 | 无 | 1=有报警 0=无报警
AlarmD ID: | 报警4状态 | 开关量 | 可读 | 无 | 1=有报警 0=无报警
Manual ID: | 手自动状态 | 开关量 | 可读 | 无 | 1=手动 0=自动
Sensor ID: | 传感器连接状态 | 开关量 | 可读 | 无 | 1=传感器故障 0=连接正常
Loop ID: | 回路连接状态 | 开关量 | 可读 | 无 | 1=回路断开 0=连接正常
Heater ID: | 加热器状态 | 开关量 | 可读 | 无 | 1=加热器故障 0=加热器正常
PAR ID:Ch | 具体见标签参数对照表 | 模拟量 | 可读/可写 | 1~65535 | -32767~32767

注释：

ID 指主控制器通讯地址，取值范围 1-255。Ch是仪表内部寄存器的地址，取值范围 1~ 65535 。2604的内部寄存器地址很多，每个寄存器的作用和类型不能一一列举

所以用了PAR这种标签，用户可以通过这种标签访问任何地址的寄存器 ，PAR是有符号参数。

标签举例：

标签 ：PV
数据值类型：模拟量
描述 ：表示开物设备中主控制器通讯地址为默认 值的仪表的过程变量，对应的内部寄存器地址为 1 。

标签 ：PV2:
数据值类型：模拟量
描述 ：表示开物设备中主控制器通讯地址为2的仪表的过程变量。

标签 ：AlarmA
数据值类型：模拟量
描述 ：表示开物设备中主控制器通讯地址为默认 值的仪表的报警1状态。

标签 ：AlarmD
数据值类型：模拟量
描述 ：表示开物设备中主控制器通讯地址为默认 值的仪表的报警4状态。

标签 ：PAR7
 数据值类型：模拟量
 描述 ：表示开物设备中默认的 主控制器通讯地址地址为7的寄存器，取值范围-32768~32767。

标签 ：PAR4:9
 数据值类型：模拟量
 描述 ：表示开物设备中 主控制器通讯地址为4地址为9的寄存器，取值范围-32768~32767。


标签参数对照表

欧陆2000系列仪表

欧陆2604 仪表

PAR[ID:]Ch 标签 含义具体说明 。

ID是仪表的主控制器通讯地址，Ch是仪表内部寄存器的地址，取值范围 1~ 65535 ，地址和寄存器的对应关系见下面的图表。

表格中的Modbus一列就是Ch的值。


用户常见问题

设备向导首页的“调试设置”按钮有什么用处
设备向导首页的“下载最新驱动”按钮有什么用处
设备向导首页的“帮助信息”按钮有什么用处
RS485网络应用提示
协议设置

设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

设备向导首页的“下载最新驱动”按钮有什么用处

通过点击“下载最新驱动”按钮，可以从我公司下在该设备的最新驱动程序。

设备向导首页的“帮助信息”按钮有什么用处?

通过点击“帮助信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。

协议设置

2604支持两种协议:Modbus和DeviceNet，我们的采用Modbus协议，协议的设置可以通过2604的面板设置，也可以通过软件iTools设置，下面介绍

两种设置方法：

1、面板设置：进入Access页，把Access Level设置为Config，然后输入密码（系统默认的密码是 4 ），通过验证后进入组态级别（参考2604控制器手册 4.1）。

然后按 [image] 页按钮，切换到COMMS页面，按 [image] 递减按钮选中 H Module Page，再按 [image] 滚动按钮，进入协议设置界面，按递减按钮切换协议。

再按滚动按钮可以设置波特率、奇偶检验、仪表地址、分辨率、接收超时等等。

2、iTools设置：运行iTools，点击 [image] 按钮扫描连接的仪表，如果扫描到在窗口的下部会自动添加一个图标，然后在左边的树形目录中选择

COMMS - H_Module，双击Protcl，弹出一个对话框

选择 Modbus[1]后点击[Apply]按钮，如果协议设置成功在窗口的状态条中将显示New Value Written OK。

依照上面的方法可以设置串口或其它的一些参数。

如果采集不到数据，可能是2604的协议和串口的参数不正确，2604的驱动只支持Modbus协议，请把2604的协议设置为Modbus。

串口的参数：

波特率

9600

数据位

8位

停止位

2位

校验位

无校验

波特率可以改，但需要上下一致，开物中的设置的波特率和2604中设置的波特率一致。

如果不是上面的问题，请仔细察看线路的接线是否符合帮助或2604的用户手册的接线方法。

设备向导首页的“调试设置”按钮有什么用处
设备向导首页的“下载最新驱动”按钮有什么用处
设备向导首页的“帮助信息”按钮有什么用处
RS485网络应用提示
协议设置