横河无纸记录仪

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

该仪表与开物2000通讯采用的是modbus协议，首先应该在仪表的通讯设置中将通讯方式设定为Modbus方式通讯，以及通讯参数和设备地址的

的设置，硬件的连线方式是二线制。实际接线如下图所示:

主机（RS232/485转换器） AX的RS422/485接口

默认通讯参数如下：

波特率 | 19200bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3： 显示单个或者多个仪表的创建，单击‘下一步’按钮。

步骤4：选择所连接的设备的型号及站号的配置，单击“下一步”。

步骤5：设定连接设备的串行口参数，单击“下一步”。

步骤6：显示设备的设定参数，单击“完成”。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指仪表的仪表地址，用于识别设备中的仪表， 仪表地址以十进制表示，地址设定范围为00 ～ 31 。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表地址。

项目符号

Ch指通道号。范围根据标签类型所决定。十进制表示。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

tag_chID:Ch

测量值

模拟量

只读

0---65535

caldataID:Ch

运算数据值

模拟量

只读

0---4294901760

alarm 1ID:Ch

运算数据的报警状态1

模拟量

只读

0---1

alarm 2ID:Ch

运算数据的报警状态2

模拟量

只读

0---1

alarm 3ID:Ch

运算数据的报警状态3

模拟量

只读

0---1

alarm 4ID:Ch

运算数据的报警状态4

模拟量

只读

0---1

calalarm 1ID:Ch

运算数据的报警状态1

模拟量

只读

0---1

calalarm 2ID:Ch

运算数据的报警状态2

模拟量

只读

0---1

calalarm 3ID:Ch

运算数据的报警状态3

模拟量

只读

0---1

calalarm 4ID:Ch

运算数据的报警状态4

模拟量

只读

0---1

dateID:Ch

日期表示

模拟量

只读

年、月、日等

readcomdataID:Ch.

读通信输入数据

模拟量

只读

0---65535

writecomdataID:Ch

写通信输入数据

模拟量

只写

0---65535

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

标签举例

标签 ：tag_ch1:1
数据值类型：模拟量
描述 ：表示设备配置示例中1号 设备1通道的传感器的测量值

标签 ：alarm1 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备CH01测量数据的报警状态1

标签 ：caldata 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中1号 设备CH31的运算数据

标签 ：calalarm1 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备CH31运算数据的报警状态1

标签 ：readcomdata 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中读取1号设备C01的通信输入数据

标签 ：writecomdata 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中写入1号设备C01的通信输入数据

标签 ：date 1:1
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的日期中的年（四位数字）

标签 ：DeviceLink 3:
数据值类型：模拟量
描述 ：表示设备配置示例中3号设备最新通讯状态

MODBUS协议寄存器分配关系

设定设备的站号为1。

设备地址 | 开物地址 | 标签含义 | MODBUS地址范围
0001 | tag_ch1：1 | CH1的测量数据 | 1----10
1001 | alarm11:1 | CH1的测量数据 的报警状态 | 1001---2010
2001 | caldata1:1 | CH31的运算数据 | 2001---2010
3001 | calalarm1:1 | CH31的运算数据的报警状态 | 3001----3010
9001 | date1:1 | 年 | 9001----9008
0001 | readcomdata1:1 | C01的通信输入数据 | 1----10（C01--C10）
0001 | writecomdata1:1 | C01的通信输入数据 | 1----10（C01--C10）

注：1、该仪表在读取运算数据（caldata）时做了一定的修改。例如：caldata1则读取是CH31的运算数据值，caldata2则读取

的是CH32的运算数据值。所以这里的范围与说明书上提供的地址范围有改动。

即AX102/AX104的通道地址范围是（1--4）， AX106/AX110的通道地址范围是（1--10）。

2、由于协议中读取的数据没有小数点位置的信息，所以用户使用的时候需要在建立标签的时候对相应的标签的工程值进行

一定的比例转换。例如：tag_ch1即CH01测量数据，无纸记录仪中的显示值为23.5，而开物2000中读取得数据则为235，

所以需要用户使用该标签的时候将工程值的范围改为6553.5。