神王TM200系列仪表

杭州家和HWPLM2-3仪表

概述 设备连接 创建设备 标签创建 标签类型和地址配置 标签举例 在线驱动升级

概述

HWPLM2-3仪表由 杭州家和公司出品。产品适用于工业装置控制领域。

开物2000使用计算机中的串行口与一台或多台HWPLM2-3仪表的通讯口连接，实现数据通讯功能。

设备连接

HWPLM2-3仪表与计算机之间采用RS485方式连接，开物2000支持此种方式。

在计算机的一个RS-232串口连接的485网络上最多能挂接32台HWPLM2-3仪表。

如果修改了仪表通讯参数，需要重新通电。

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘杭州家和HWPLM2_3仪表’，或单击选中‘杭州家和HWPLM2_3仪表’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个仪表)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建设备的方式：选中‘多个智能仪表创建’后，单击‘下一步’按钮。

步骤4：显示创建多个仪表界面。在添加完所有仪表后，单击‘下一步’按钮。

步骤5：显示串口通讯参数配置窗口，按照实际连接情况，更改完串口后，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

标签类型和地址配置规则

标签类型：WORD, BYTE, BIT

标签地址配置： WORDID:Ch BYTEID:CH.0/1 BITID:CH.B

说明：

项目符号

ID指仪表的表号（也叫机器地址），用于识别设备中的仪表。ID的取值范围1-32。

项目符号 | 红色字表示格式中可变部分，十进制数表示 。CH为寄存器号(0-127)，B为位号(0-15),BYTE中的0表示低字节，1表示高字节。
项目符号 | 标签地址配置成不存在类型或仪表表号错误或参数号超出有效范围时，标签将不被承认，读不上数据。

标签举例：

标签 ：WORD1:0
数据值类型：模拟量
描述 ：表示设备中仪表号 为1的仪表的0号寄存器。

标签 ：BYTE1:1.0
数据值类型：模拟量
描述 ：表示仪表号为11的仪表的1号寄存器的低字节

标签 ：BIT1:2.5
数据值类型：开关量
描述 ：表示仪表号为1的仪表的2号寄存器的 第6位。