朝阳XSH仪表

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

朝阳仪表由北京朝阳仪表厂出品。产品适用于工业装置、测量仪器、石油化工、冶金、机械等行业

的过程控制领域。

开物2000使用计算机中的串行口与一台或多台朝阳XSH系列仪表的通讯口连接，实现数据通讯功能。

开物2000还支持其它多种设备，详情请与华富惠通公司联系。

硬件连接

~ 仪表与计算机接线时，必须在断电条件下进行。否则有可能损坏仪表及计算机接口。

XSH仪表可以采用RS232接口或RS485接口为端子与计算机相连。开物2000同时支持这两种方式。

1.当采用RS232接口时，接线方式如下图。

2.当采用 RS485接口时，接线方式如下图。

图中Rt为终端电阻一般用120 W

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置模块类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用XSH设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面创建的设备。选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：模块地址使用10进制 。Read,Set两种标签通道地址使用16进制，参数值所对应的通道号可参见

仪表手册。
项目符号

标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址，朝阳XSH模块的站号为0～99。
项目符号

Ch指通道号。十进制表示。对于AI，SO，RO四种命令，通道号不存在；对于DI，DO，SAlarm三种

标签通道号的取值范围为0~7；对于Alarm标签通道号的取值范围为0~3；对于Read和Set两种标签通道号范

围为0~$4D(这种标签的通道号用十六进制表示)。
项目符号 | 标签分为读标签和写标签两种类型，其中以字母S开始的三种标签为写标签，其余标签为读标签。
项目符号 | 在进行写标签操作前，需先通过开物的Read标签将仪表的oA置为1111。
项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

         CH(通道)范围

读写类型

标签值范围

Main ID:

测量/反馈输入

模拟量

对于定时器类型仪表，其通道号为0，1，2，分别代表当前记录时间的小时、分钟和秒种，对于其它类型仪表，其通道号需配置为3，在使用过程中需要注意。

只读

－1999～9999

AIID:

调节通道输入

模拟量

无

只读

－1999～9999

DIID:Ch

开关量输入

开关量

0～7

只读

true=开关闭合

false=开关断开

DO ID:Ch

开关量输出

开关量

0～7

只读

true=开关闭合

false=开关断开

ReadID:Ch

读仪表参数

模拟量

0～4D

只读

－65535～65535

Set ID:Ch

设置仪表参数

模拟量

0～4D

写

－65535～65535

SO ID:

控制操作输出

模拟量

无

写

－63～1063

Alarm ID:Ch

报警状态

开关量

0～3

只读

true,false

SAlarm ID:Ch

控制报警输出

开关量

0～7

写

true,false

ROID:Ch

读当前操作输出量

模拟量

无

只读

－63～1063

标签举例

标签 ：Main1:0
数据值类型：模拟量
描述 ：假如为定时器类型仪表，则为表示设备配置示例中1号模块的小时数。

标签 ：Main1:3
数据值类型：模拟量
描述 ：假如为其它类型仪表，则为表示设备配置示例中1号模块的测量值。

标签 ：AI3:
数据值类型：模拟量
描述 ：表示设备配置示例中3号模块的调节通道输入值。

标签 ：DI1:0
数据值类型：开关量
描述 ：表示设备配置示例中1号模块第一点开关量状态。

标签 ：DO2:2
数据值类型：开关量
描述 ：表示设备配置示例中2号模块第三点开关量状态。

标签 ：Read1:10
数据值类型：模拟量
描述 ：表示设备配置示例中1号模块参数中的密码值。

标签 ：SO1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号模块的控制操作输出。

标签 ：Alarm1:0
数据值类型：开关量
描述 ：表示设备配置示例中1号模块的第一通道告警状态。

标签 ：RO1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号模块的当前操作输出量。