朝阳XMT系列仪表

朝阳XMT300/400系列仪表综述

仪表概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

朝阳XMT300/400系列仪表概述

朝阳XMT系列仪表由北京朝阳仪表厂出品。 主要用于测量仪器、石油化工、冶金、机械等行业的过程控制领域。开物2000使用计算机中的串行口与一台或多台朝阳XMT300/400系列仪表通讯，实现数据 读取功能。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

朝阳XMT300/400系列仪表的硬件设置

朝阳XMT300/400系列仪表支持 RS 232/485，其中RS485最多支持64块仪表连接；

波特率为 600、1200、2400、4800、9600、19200baud；

数据位8位，2个停止位，无检验；

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 仪表。以便于开物2000识别和使用。

步骤1：选择”智能仪表“设备类型。双击“朝阳XMT系列仪表”，或单击选中“朝阳XMT系列仪表”，这里可以查看“驱动版本号”，更改设备名称， 如“XMT” ，然后单击“选择”按钮。

步骤2：在”朝阳XMT系列仪表向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对 仪表的配置进行修改或者选择“察看设备”浏览已经设置好的仪表配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期时间的方式命名，如XMT2004-04-19-13-33-54.LOG。

步骤3：在"朝阳XMT系列仪表向导"中选择创建设备的方式——包括“单个 设备创建”和“多个设备创建”。其中：

单个智能仪表创建：指在一个设备中创建一块 设备；

多个智能仪表创建：指在一个设备中创建多个子设备，当然您也可以建立多个设备从而实现多块设备的连接。

步骤4：在”朝阳XMT系列仪表向导“中选择 设备类型， 设置仪表设备号，若连接多块仪表可以选择“添加”，若需要修改仪表的参数，可以先选中“设备配置图”中的设备，然后更改仪表类型和设备号，最后点击“修改”；若需要删除多余的或错误的智能仪表，可以选择“删除”。 其中：

设备号：朝阳XMT300/400系列仪表的设备地址。

设备类型：指用户使用的设备型号，通过下拉菜单选择；

步骤5：设置计算机的串口参数，主要包括串口号、波特率、数据位、停止位、校验方式等。其中波特率、数据位、停止位、校验方式等，其中除串口号外其它参数一定与下位机完全相同。

步骤6：察看您建立的设备，没有问题，请点击“完成”按钮，如果有问题，可以点击“上一步”进行必要的修改。至此，整个设备建立完成。

标签的创建

使用“朝阳XMT系列仪表向导”完成仪表的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的‘XMT'，选择并填写‘主设备地址’，修改标签名。

朝阳XMT300/400系列仪表驱动程序包含厂商提供协议中实现的主要功能。实现的主要功能包括：

（1）PV值的读取；

（2）其它参数值的读写控制；

标签的配置规则为：标签+设备号+‘:’+通道号，如PV1:0；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为仪表当前量程的上限值；

测量值最小值：设定为仪表当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：仪表的量程为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：在使用过程中需要根据外界信号的情况进行上面测量值和工程值的设定。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch ，其中CH范围 见下表。

说明：

项目符号

ID指设备号，用于识别同一设备中的不同子设备， 设备号设定范围为 1 ～ 64，十进制表示。

项目符号

Ch指通道号，范围根据 仪表类型不同，十六进制表示。

项目符号 | 红色字表示格式中的可变部分 。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个仪表创建”时可省略。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

PVID:CH

仪表测量值

模拟量

只读

0

-9999～30000

PARMID:CH

读取|设定仪表参数值

模拟量

读/写

0～63H(16进制)

-9999～30000

参数表：

参数代号(16进制) | 参数名 | 含义 | 参数代号 | 参数名 | 含义
00H | SV | 给定值 | 0DH | DIL | 输入下限显示值
01H | HIAL | 上限报警 | 0EH | DIH | 输入上限显示值
02H | LOAL | 下限报警 | 0FH | ALP | 报警输出定义
03H | DHAL | 正偏差报警 | 10H | SC | 传感器修正
04H | DLAL | 负偏差报警 | 11H | OP1 | 输出方式
05H | DF | 回差 | 12H | OPL | 输出下限
06H | CTRL | 控制方式 | 13H | OPH | 输出上限
07H | M5 | 保持参数 | 14H | CF | 正/反作用
08H | P | 速率参数 | 16H | MV | 输出值
09H | T | 滞后参数 | 17H | DL | 数字滤波
0AH | CTL | 控制周期 | 18H | RUN | 运行参数
0BH | SN | 输入规格 | 19H | LOC | 参数封锁
0CH | DIP | 小数点位置 |  |  |

对XMT-420还有101个参数[51个温度和50个时间]，其参数代号为：

Cn=1AH+2*(n-1)；Tn=1BH+2*(n-1)；

标签举例：(标签中不需要包括仪表号)

标签 ：PV1:0
数据值类型：模拟量
描述 ：表示1号仪表的PV值。

标签 ：PARM1:1
数据值类型：模拟量
描述 ：表示读取/设置1号仪表的上限报警值。

标签 ：PARM1:1A
数据值类型：模拟量
描述 ：表示读取/设置1号仪表的第一个温度值。

标签 ：PARM1:1B
数据值类型：模拟量
描述 ：表示读取/设置1号仪表的第一个时间值。