日本八洲TM200系列仪表

概述 硬件连接 仪表通讯设定 创建设备 创建标签 标签的地址规则 参数地址对照表 标签举例 在线升级驱动

八洲TM200系列仪表概述

TM200仪表由日本八洲公司出品。产品适用于工业装置、测量仪器、石油化工、冶金、机械等行业的过程控制领域。

开物2000使用计算机中的串行口与一台或多台八洲TM200系列仪表的通讯口连接，实现数据通讯功能。

双方共同采用八洲仪表通讯协议，目前开物2000支持的仪表类型如下(新的型号请咨询华富惠通公司)：

  • TM204：外形尺寸为 96（宽）×96（高）mm。
  • TM205：外形尺寸为 48（宽）×96（高）mm。
  • TM207：外形尺寸为 72（宽）×72（高）mm
  • TM209：外形尺寸为 96（宽）×96（高）mm。

以上各种型号仪表除外形尺寸外没有太大差别，在开物2000中是通用的，可相互代替。

在产品选型时，请选择带有CNN标记（RS485通信功能）的型号。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

八洲TM200系列仪表与计算机的连接

八洲仪表与计算机之间采用RS485方式连接，开物2000支持此种方式。

在计算机的一个RS-232串口连接的485网络上最多能挂接31台八洲TM200系列仪表，通讯距离限制在500米内。

注意：要保证可靠的通讯，在RS485网络的两端务必并联一只100欧左右的终端电阻，以防止信号反射。

八洲TM200系列仪表的通讯设定

为实现八洲TM200系列仪表与开物2000系统的通讯，需对仪表的机器地址进行设定。其他参数不必修改，采用仪表出厂默认值即可。修改完毕后，需要重新通电。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘八洲TM200系列仪表’，或单击选中‘八洲TM200系列仪表’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个仪表)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建设备的方式：选中‘多个仪表创建’后，单击‘下一步’按钮。

步骤4：显示创建多个仪表界面。在添加完所有仪表后，单击‘下一步’按钮。

步骤5：显示串口通讯参数配置窗口，按照实际连接情况，更改完串口后，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘TM205’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指仪表的表号（也叫机器地址），用于识别设备中的仪表。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表号。ID的取值范围0-127。

  • Ch指参数号。标签地址中省略Ch时，开物2000系统默认为是0。

  • 红色字表示格式中可变部分，十进制数表示，变化范围参见各种仪表的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
  • 标签地址配置成不存在类型或仪表表号错误或参数号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

注释信息

BOOLC ID:Ch

开关量控制

开关量

根据参数号Ch

true～false

根据Ch的取值代表不同参数，参见参数表

ANALCID:Ch

模拟量控制

模拟量

根据参数号Ch

-65535～65535

根据Ch的取值代表不同参数，参见参数表

参数地址对照表：

标签地址 代码

含义

数据类型

读写类型

标签值范围

ANALC ID:0

PV

测量值

模拟量

只读

根据输入方式取值

ANALC ID:1

0-1

主控制输出

模拟量

只读

0.0～100.0

ANALC ID:2

0-2

副控制输出

模拟量

只读

0.0～100.0

ANALC ID:3

Ct1

加热器电流值

模拟量

只读

0.0～100.0

ANALC ID:4

Ct2

加热器电流值

模拟量

只读

0.0～100.0

ANALC ID:5

Dc

变送器电流值

模拟量

只读

-10.0～110.0

ANALC ID:10

AL-1

报警1

模拟量

只读

0002=上限报警

0004=下限报警
0008=待机+上限报警
0010=待机+下限报警
0020=上下限范围报警

ANALCID:11

AL-2

报警2

模拟量

只读

0040=上下限报警

0080=上限待机+上下限报警
0100=下限待机+上下限报警
0200=待机+上下限报警
0400=上限绝对值报警
0800=下限绝对值报警
1000=待机+上限绝对值报警
2000=待机+下限绝对值报警

BOOLCID:20

Esw

外给定开关

开关量

只读

true=开关闭

false=开关开

BOOLCID:50

Run

运行

开关量

可读可写

true=运行
false=停止

ANALCID:100

Sv1

主控制设定值

模拟量

可读可写

设定范围的下限值、上限值

ANALCID:101

Sv2

副控制设定值

模拟量

可读可写

设定范围的下限值、上限值
ANALCID:120 | Loc | 设定值闭锁 | 模拟量 | 可读可写 | 0=全部可以设定
1=仅SV和报警可以设定
2=仅报警不可以设定
3=仅SV可以设定
4=仅SV不可以设定
5=仅报警可以设定
6=仅SV和报警不可以设定
7=全部不可以设定
ANALCID:200 | P--1 | 主控制比例度 | 模拟量 | 可读可写 | dp:1/0.1 0.0--999.9
dp:0.01 0.01--99.99
ANALCID:201 | i | 积分时间 | 模拟量 | 可读可写 | 0--36000秒,0时积分不动作
ANALCID:202 | d | 微分时间 | 模拟量 | 可读可写 | 0--36000秒,0时微分不动作
ANALCID:203 | t--1 | 主控制比例周期 | 模拟量 | 可读可写 | 1--120秒
ANALCID:204 | Ar | 上升时间 | 模拟量 | 可读可写 | 主控制比例度的0.0--100.0%,0.0时微分不动作
ANALCID:205 | A | 手动复位 | 模拟量 | 可读可写 | 在主控制积分时间是0时表示: 设定范围: 0.0--100.0%
ANALCID:206 | Atu | 自整定 | 模拟量 | 可读可写 | 0:自整定终了/终止
1:自整定开始
ANALCID:207 | Stu | 自适应 | 模拟量 | 可读可写 | 0:无自适应功能; 1:有自适应功能
ANALCID:208 | dF--1 | 主控制灵敏度 | 模拟量 | 可读可写 | dp:1/0.1 0.1--100.0
dp:0.01 0.01--10.00
ANALCID:209 | P--2 | 副控制比例度 | 模拟量 | 可读可写 | 主控制比例度的1--1000%,不可设定0
ANALCID:210 | t--2 | 副控制比例周期 | 模拟量 | 可读可写 | 1--120秒
ANALCID:211 | dF--2 | 副控制灵敏度 | 模拟量 | 可读可写 | dp:1/0.1 0.1--100.0
dp:0.01 0.01--10.00
ANALCID:212 | In--s | 输入补正值 | 模拟量 | 可读可写 | dp:1/0.1 -199.9--999.9
dp:0.01 -19.99--99.99
ANALCID:213 dp 死区 模拟量 可读可写 主控制比例度和副控制比例度的控制不灵敏区 dp:1/0.1 -100.0--100.0

dp:0.01 -10.00--10.00

ANALCID:214 | AL--1 | 第一动作报警点 | 模拟量 | 可读可写 | 绝对值报警:设定范围的下限值--上限值
ANALCID:215 | 模拟量 | 可读可写 | 偏差报警:0--表示范围的上限值
ANALCID:216 | AL--2 | 第二动作报警点 | 模拟量 | 可读可写 | 绝对值报警:设定范围的下限值--上限值
ANALCID:217 | AL--2 | 第二动作报警点 | 模拟量 | 可读可写 | 偏差报警:0--表示范围的上限值
ANALCID:218 | SFt1 | 主控制设定值更换 | 模拟量 | 可读可写 | 下限值dp:1/0.1/0.01 -199/-199.9/-19.99
上限值:表示范围的上限值
ANALCID:219 | SFt2 | 副控制设定值更换 | 模拟量 | 可读可写 | 下限值dp:1/0.1/0.01 -199/-199.9/-19.99
上限值:表示范围的上限值
ANALCID:220 | Hb | 加热器短线报警 | 模拟量 | 可读可写 | 0--100A
ANALCID:221 | LbA | 回路短线报警 | 模拟量 | 可读可写 | 设定范围:0--7200秒,0时无此功能
ANALCID:222 | Ldb | 回路短线死区 | 模拟量 | 可读可写 | 设定范围:0--表示范围的上限
ANALCID:223 | bot | 短线输出量 | 模拟量 | 可读可写 | 设定范围:0~100%
ANALCID:300 | inp | 输入的选择 | 模拟量 | 可读可写 | 0=K;1=J;2=T;3=E;4=R;5=S;6=Pt;7=JPt; 8=A--1;9=A--2
ANALCID:301 | C---F | 温度单位选择 | 模拟量 | 可读可写 | 0=C ; 1=F
ANALCID:302 | dp | 表示分辨率的选择 | 模拟量 | 可读可写 | 0=0;0.1=0.1;0.01=0.01
ANALCID:303 | SL--U | 输入下限值(A--1/A--2) | 模拟量 | 可读可写 | 表示范围下限~SL--F--1:dp=1
表示范围下限~SL--F--0.1:dp=0.1
表示范围下限~SL--F--0.01:dp=0.01
ANALCID:304 | SL--F | 输入上限值(A--1/A--2) | 模拟量 | 可读可写 | SL--U+1~表示范围上限:dp=1
SL--U+0.1~表示范围上限:dp=0.1
SL--U+0.01~表示范围上限:dp=0.01
ANALCID:305 | SL--L | 设定范围下限 | 模拟量 | 可读可写 | 表示范围下限--SV--H--50:A--1/A--2以外
SL--U~SV--H--1: dp=1
SL--U~SV--H--0.1: dp=0.1
SL--U~SV--H--0.01: dp=0.01
ANALCID:306 | SL--H | 设定范围上限 | 模拟量 | 可读可写 | SV--L+50--表示范围上限:A--1/A--2以下
SV--L+1--SL--F:dp=1
SV--L+0.1--SL--F:dp=0.1 A--1/A--2
SV--L+0.01--SL--F:dp=0.01
ANALCID:307 | SVb | 副控制 | 开关量 | 可读可写 | 0:无控制; 1:有控制
ANALCID:308 | SVm | 控制种类 | 模拟量 | 可读可写 | 1:1设定动作(仅限SV1)
2:2设定动作(SV1 SV2)
ANALCID:309 | Out1 | 主控制输出动作 | 模拟量 | 可读可写 | 0=n2; 1=r2; 2=np; 3=rp
ANALCID:310 | Out2 | 副控制输出动作 | 模拟量 | 可读可写 | 0=n2; 1=r2; 2=np(仅限于OUT1=np时); 3=rp(仅限于OUT2=rp时);
ANALCID:311 | AL1C | 第一报警动作 | 模拟量 | 可读可写 | 1=H; 2=L; 3=WH; 4=WL; 5=H--L; 6=HL;7=WHL; 8=WLH; 9=WHWL; A=AH; B=AL;C=WAH; D=WAL
ANALCID:312 | AL2C | 第二报警动作 | 模拟量 | 可读可写
ANALCID:313 | A1db | 第一报警动作灵敏度 | 模拟量 | 可读可写 | dp:1, 0.1/0.01
0.1--100.0/0.01--10.00
ANALCID:314 | A2db | 第二报警动作灵敏度 | 模拟量 | 可读可写 | dp:1, 0.1/0.01
0.1--100.0/0.01--10.00
ANALCID:315 | AL10 | 第一报警输出端子 | 模拟量 | 可读可写 | 1=AL1
ANALCID:316 | AL20 | 第二报警输出端子 | 模拟量 | 可读可写 | 1=AL1; 2=AL2; 3=OUT2
ANALCID:317 | ALL0 | 回路短线报警输出端子 | 模拟量 | 可读可写
ANALCID:318 | ALH0 | 加热器短线报警 | 模拟量 | 可读可写
ANALCID:319 | A0 | 传送输出 | 模拟量 | 可读可写 | 1=PV; 2=SV1; 3=0--1; 4=0--2
ANALCID:320 | EVt | 事件功能 | 模拟量 | 可读可写 | 1=SPt; 2=no; 3=Nc
ANALCID:321 | bos | 短线输出量 | 开关量 | 可读可写 | 0:无功能; 1:有功能
ANALCID:322 | Atm | 安定判断系数 | 模拟量 | 可读可写 | 0--100
ANALCID:323 | Atp | 比例度系数 | 模拟量 | 可读可写 | 0--100
ANALCID:324 | At | 积分系数 | 模拟量 | 可读可写 | 0--100
ANALCID:325 | mAn | 手动功能 | 开关量 | 可读可写 | 0:无功能; 1:有功能
ANALCID:326 | dFt | 数字滤波(秒) | 模拟量 | 可读可写 | 0--100
0:无滤波
ANALCID:327 | ComU | 通讯功能选择 | 开关量 | 可读可写 | 0:无功能; 1:有功能

标签举例：

标签 ：ANALC0
数据值类型：模拟量
描述 ：表示设备中仪表号最小的仪表的瞬时值。

标签 ：ANALC17:0
数据值类型：模拟量
描述 ：表示开物设备中仪表号为17的仪表的瞬时值。

标签 ：ANALC10:100
数据值类型：模拟量
描述 ：表示开物设备中仪表号为10的仪表的设定值。