Index

Navigation Created by FAR HTML


Search

Add your Search HTML here

Navigation Created by FAR HTML


Title Text

This page uses frames, but your browser doesn't support them.


Contents

Navigation Created by FAR HTML


版本及状态信息

版本号 增加功能 纠正错误
4.2.0.0 α版 　 模拟量标签跳零现象
标签值连续输出时写入值错误
4.1.0.0版

4.2.0.0版

当前状态: α版

修改日期: 2003年3月12日

问题1:

项目符号

模拟量标签跳零现象

修改者: 李庆军

验证者:

相关用户:

分析:

项目符号

串口基类DLLObj.pas中function TCustomDLLObject.CommAnalyze对数据进行拆包时存在编码错误：当数据报文异常时，默认的赋值是0，而不是当前值。

项目符号

DLLBaseDef单元中增加一种新的类型定义：TValueArray.

项目符号

DLLObjDef单元中TCommand记录增加新的成员域wValueArray。

项目符号

DLLBase单元function TBaseDLLObject.WriteExecute函数生成pWriteCommand后，为pWriteCommand的wValueArray赋值。

项目符号

DLLBase单元function TBaseDLLObject.FinalCommand函数在pWriteCommand正确，执行后，将pWriteCommand中寄存的wValueArray值回写给Tag。

项目符号

DLLBase单元procedure TBaseDLLObject.SyncTagValue过程将与pWriteCommand相关标签的连锁新值赋值给pWriteCommand的wValueArray。

解决方案:

项目符号

修改串口基类DLLObj.pas中function TCustomDLLObject.CommAnalyze对数据进行拆包的语句：当数据报文异常时，默认的赋值是标签当前值。
项目符号

在TCommand结构中增加新的成员域wValueArray保存对IndexArray对应标签的命令写入值，当wCommand得到正确执行,Tag.Value:= TCommand.WValueArray[],从而实现命令级的写入值缓存.

问题2:

项目符号

标签值连续输出时写入值错误

修改者: 李庆军

验证者:

相关用户:

分析:

4.1.0.0版

当前状态 : α版

修改日期 : 2002 年12月13日


测试问题及用户反馈

 3.10.0.0版

IO标签值连续输出时写入值错误

模拟量标签跳零现象

3.10.0.0版

IO标签值连续输出时写入值错误

项目符号

在驱动的标签写入请求缓存队列中存在对同一标签的不同写入请求时,由于Tag的WriteValue只能保存一个值(目前的实现保存最新写入值)。当第一个写操作正确执行后,向Tag的Value域中回写的值实际是最新请求的值,这样硬件中的实际值和驱动返回给iCore的不是相同值，产生错误。

模拟量标签跳零现象

项目符号

相当多的串口类设备在现场运行时出现跳零现象，即：某一模拟量标签值突然变成0，后立刻正常。


产品资料


常见问题

RS485 网络应用提示

项目符号 | 当 RS485 网络中，或通讯距离增长（<1200m），或波特率提高时，应在网络的最后一个节点处的 com+，com-间并接一只 130 Ω左右的线路匹配电阻，以保障网络的可靠运行。LTM8000 系列模块均留有此电阻的安装位置，可方便地安装。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485 设备，做为 485 网络中的一个节点其在网络中的安装应有所重视。网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线，在布线时 ，以避免与动力线系统电源线靠近且平行布置，尽量与其距离远一些布置


厂商用户信息


开发与修改需求

项目符号 | 建议：增加测试向导，测试向导支持标签的导出。
项目符号 | 建议：在驱动程序向导界面中提供下载的热连接。
项目符号 | 宇光表驱动程序：Log日志中需要正确显示处理非ASCII字符。
项目符号 | 基类自动支持自动搜索功能。
项目符号 | 相当多的串口类设备在现场运行时出现跳零现象
项目符号 | 原因：串口基类DLLObj.pas中function TCustomDLLObject.CommAnalyze对数据进行拆包时存在编码错误：当数据报文异常时，默认的赋值是0，而不是当前值即：某一模拟量标签值突然变成0，后立刻正常。


开发者使用手册


开物2000驱动程序版本控制规范

开物2000驱动程序使用说明书编写规范

一、编写工具和输出文件格式。

驱动程序使用说明书的编写工具采用Microsoft FrontPage，保存为htm格式。 嵌入的图片单独保存为JPG或GIF格式。

二、使用说明书的组成。

每个驱动程序需要编写一个htm说明书（下面称作驱动说明书），驱动程序支持的每种设备也需要编写一个htm的说明书（下面称作设备说明书）。两种说明书之间有超链接相互引用。

驱动说明书中考虑添加的内容包括：

l 驱动程序概述（必要内容）

l 支持的设备列表（必要内容）

l 使用前的必要的硬件设置/软件设置

l 开物2000驱动程序的参数配置方法（必要内容）

l 必要的注意事项

l 常见问题解答

设备说明书的内容包括：

l 设备概述（必要内容）

l 使用前的特殊的硬件设置/软件设置

l 开物2000驱动程序中的特殊参数配置方法

l 标签的设备地址列表（必要内容）

l 标签地址的举例（必要内容）

l 必要的注意事项

l 常见问题解答

三、编写注意事项。

l 采用的名词概念要符合开物2000系统的约定

l 如无必要，不要提及其他软硬件厂商

四、驱动说明书示例。

艾讯Ax系列板卡综述

概述 板卡参数设置 华富惠通公司

概述

艾讯Ax系列板卡是台湾艾讯公司出品的PC-AT总线数据系列采集板卡。提供12位或16位的A/D、D/A、DI、DO、 温度测量、计数器/定时器功能。

开物2000支持的Ax系列板卡有：

AX5008 | 8 通道电磁激励隔离DI板
AX5032A | 16 通道电磁激励光电隔离DI板
AX5032IO | 32 通道光电隔离DI/DO板
AX5064I | 64 通道DI光电隔离板
AX5064O | 64 通道光电隔离DO板
AX5210H | 16 通道AD板
AX5210H+ | 16 通道AD & 2通道DA板
AX5213 | 2 通道隔离DA板
AX5214H | 48 位 DI/O 板
AX5215H | 96 位 DI/O 板
AX5220HA/B | 32 位 DI/O & 3 通道定时器/计数器板
AX5224H | 24 位 DI/O & 3 通道定时器/计数器板
AX5232 | 32 通道隔离温度/电压测量板
AX5244H | 144
AX5411H | 多功能板
AX5412H | 高速多功能板
AX5621H+ | 16位 多功能板

板卡参数设置

1、板卡硬件地址设置方法：（SW1）

板基地址选择范围200H ~ 3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
板基地址计算公式如下:板基地址 = 所有有效位之和
例：如上图所示:板基地址 = 200H + 100H = 300H

2、在Windows 9X下安装as59020\v4_3提供的Driver for Windows 9x。在Windows NT/2000下安装as59040\v4_3提供的Driver for Windows NT。

3、执行完上面的安装后，运行devmgr32.exe，并根据应用需要，在devmgr32.exe添加板卡和配置板卡的使用参数。此信息写入到配置文件中(诸如 axdrv.ini)。

4、用户使用开物2000的配置向导，输入艾讯板卡配置文件名。

5、在板卡配置图中点击选中某块板卡，转到其他参数页，配置板卡的特殊功能参数（例如：测温板的热电偶类型和温度测量单位）

注：一台计算机上最多可使用29块艾讯板卡。

概述 板卡参数设置 华富惠通公司

参见

开物2000支持的硬件设备

五、设备驱动说明书示例。

艾讯Ax5232卡

概述 参数设置 数据类型 华富惠通公司

Ax5232概述
Ax5232是32通道隔离型温度/电压测量板。具有32路温度/电压测量功能，12位转换率。温度测量支持J, K, S, T, E, R, B, N型热电偶。电压输入范围-5伏至+5伏。放大增益可选：1, 100, 200, 250, 500, 831, 1000,或自定义。Ax5232同时提供8路数字量IO功能

Ax5232参数设置
1、板卡地址设置方法：（SW1）

板基地址选择范围200H ~ 3FFH。当开关置ON位时，该位无效；开关置OFF位时，该位有效。
板基地址计算公式如下:板基地址 = 所有有效位之和
例：如上图所示:板基地址 = 200H + 100H = 300H

2、在Windows 9X下安装as59020\v4_3提供的Driver for Windows 9x。在Windows NT/2000下安装as59040\v4_3提供的Driver for Windows NT。

3、执行完上面的安装后，运行devmgr32.exe，并根据应用需要，在devmgr32.exe添加板卡和配置板卡的使用参数。对于Ax5232卡可选择第8项。此信息写入到配置文件中(诸如 axdrv.ini)。

4、用户使用开物2000的配置向导，输入艾讯板卡配置文件名。

5、配置板卡的型号的热电偶类型和温度测量单位。

Ax5232标签类型

功能描述 | 标签地址 | 标签通道（chl）范围 | 标签值类型 | 标签值范围
模拟量输入 | ADst:chl | 0至31 | 模拟量 | -5至+5
热电偶测量 | TEMPst:chl | 0至31 | 模拟量 | -100至+2000
数字量输入 | DIst:chl | 0至7 | 数字量 | true或false
数字量输出 | DOst:chl | 0至7 | 数字量 | true或false

其中：st为站号（即板卡号），范围0至28；

chl为通道号，范围见上表。

举例：

标签值类型： 模拟量
标签值：Temp1：10
说明：表示板卡号为1，通道号为10(第11路)的模拟量输入，。

概述 参数设置 数据类型 华富惠通公司

参见

艾讯Ax系列板卡


概要设计


详细设计说明书

日期 ：2002年8月10日

修改人：

引言

编写目的

本说明书用于指导开发后期的编码、调试、测试、文档编写工作。记录《长英LTM8000系列模块通讯驱动程序》的整体设计方案，编码和调试时的重点与难点，内容涵盖所有与设计有关的原始资料。详细叙述各重要功能的实现方案，要求在产品开发组内进行审核，已确定该具体实现方案的可行性和适用性、资料完整性。本文件也是未来维护工作的指导性文件。

本文件使用和查阅对象主要是自动化产品部产品开发组成员。

项目背景

该项目是应公司要求，由自动化产品部市场组提出项目建议。第一个需求用户是。

定义

标签地址类型 ：开物2000系统为硬件寄存器的命名，不同的寄存器对应不同的标签地址。

设备参数 ：为了使硬件系统与开物2000系统能够通讯，双方所设定的通讯链路层参数。

模块号 ：LTM8000系列模块在应用中系统架构一般包含三层：模块层、通道层、传感器层。一个开物设备允许连接一个RS485网络，一个RS485网络可以挂接多个LTM8000系列模块，每个模块（无论是何种型号）都要通过模块号来区别。模块号的地址取值为：0-127。请参见下图。

通道号 ：LTM8000系列模块在应用中系统架构一般包含三层：模块层、通道层、传感器层。一个模块可以包含多个通道（目前最多可以有8个），模块中的通道都要通过通道号区别，模块号的取值范围：0-7。请参见下图。

传感器号 ：LTM8000系列模块在应用中系统架构一般包含三层：模块层、通道层、传感器层。传感器号是传感器层区别一个通道中每一个传感器的顺序号，此顺序号从0开始编号。下图中的1号模块7号通道包含两个传感器，顺序号分别为0（ID号为0）、1（ID号是2）。传感器号的取值范围一般为：0-63。

1.4、参考资料

2、总体设计

2.1、功能需求

2.2、软件结构

采用《串口通讯模板版本3.3.1.0(for OPC)》

2.3、模块参数设计

2.4、标签类型设计

3 详细设计

3.1、标签读值:

3.2、标签写值:

3.8、通讯过程中的异常处理。

4 备注：


北京华富惠通技术有限公司

欢迎使用开物2000的帮助系统

北京华富惠通技术有限公司

地址：北京市海淀区万泉河路68号紫金大厦10层
电话：（010）82657662/3/4/5/8
传真：（010）82657662/3/4/5/8转1016
邮政编码：100086
E-mail:office@huafugroup.com


施耐德PM500功率表

施耐德PM500功率表综述

概述 硬件接线图 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

开物2000使用您计算机中的串行口与一台或多台施耐德PM500功率表的通讯口连接，实现数据通讯功能。

双方共同采用Modbus RTU协议，开物2000作为主站。

施耐德PM500功率表与系统的连接及设置(MODBUS)

设备的缺省设置：
RTU通讯模式：
设置项 设置值
波特率： 9600bps
数据位： 8位
校验位： 1位（偶校验）
停止位： 1位
可在编程软件中对以上参数进行配置。
RTU与ASCII方式切换：通过PLC上的设定开关选择是ASCII模式还是RTU模式。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

  • ID指仪表的站号，用于识别设备中的仪表，请参见设备向导中步骤4。

  • Ch指寄存器地址。

  • 红色字表示格式中可变部分，十进制数表示，变化范围参见各种仪表的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
  • 标签地址配置成不存在类型或设备表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。

  • 开关量寄存器的数据类型配置成模拟量时，表示对应的位寄存器所在8位开关量组成的字节的字节值。

即：如果两个模拟量型开关量寄存器的Ch-寄存器地质不同，但是在相同的字节内时，那么表示的是相同的字节。

标签地址 | 含义 | 数据类型 | 读写类型 | 标签值范围
00 ID:Ch | 输出线圈 | 开关量 | 可读可写 | true-false
10 ID:Ch | 输入线圈 | 开关量 | 只读 | true-false
30 ID:Ch | 输入寄存器 | 模拟量 | 只读 | 0~65535
40 ID:Ch | 输出保存寄存器 | 模拟量 | 可读可写 | 0~65535
DW40 ID:Ch | 双字输出保存寄存器 | 模拟量 | 只读 | 0~4294967295

数据类型举例：

寄存器： 00017
数据类型： BIT
注释：离散输入（或线圈）

寄存器： 10012
数据类型： BIT
注释：离散输出

寄存器： 30001
数据类型： UINT
注释：输入寄存器

寄存器： 40002
数据类型： UINT
注释：输出（保持）寄存器

寄存器： DW40002
数据类型： UINT
注释：输出（双字保持）寄存器