托利多T600.05配料控制器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述
T600.05是梅特勒--托利多公司的一种智能配料控制器，T600.05型配料控制器是一种单物料配料控制器。该配料控制器可采用键盘操作,同时也可采用串口通过PC机来操作。T600.00提供3种通讯协议，拖利多通讯协议、MODBUS 通讯协议、兼容式CB920通讯协议。本驱动为了提高工作效率采用了MODBUS通讯协议。

目前本驱动支持：

1、物料目标值、快速加料点到目标重量的差值、物料的提前量的下写；

2、实时配料数据(包括当前毛重值和当前净重值)的读取、最终实际配料值的读取；

3、皮重的设置、读取及置皮，零位范围的读取与设定；

4、物料自动喂料、快速喂料、慢速喂料的开启；

5、配料的停止、放料、置皮、清皮、清零；

6、各种物料快加料状态、慢加料状态的读取；

7、下在配料运行状态、正在配料暂停状态、正在放料状态、喂料完毕等待放料操作状态的读取。

硬件连线示意图：

在使用本驱动之前，请将T600配料控制器的通讯方式设定为MODBUS模式。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘托利多T600.05配料控制器’，或单击选中‘托利多T600.05配料控制器’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示设备创建方式配置界面。在向导中选择T600创建，单击‘下一步’按钮。

步骤4：显示设备 配置向导，在此向导中添加相应的设备，并确定其单元号，单击“下一步”按钮。

步骤5：显示串口参数配置向导，在向导中配置好各参数，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘托利多T600配料控制器’，选择并填写‘主设备地址’，修改标签名

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch.SensorNum.BitNum

说明：

  • ID指模块的模块地址，用于识别设备中的模块， 模块地址以十六进制表示，地址设定范围为00 ～ FF 。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。

  • Ch指通道号。范围通常为 0～7。十进制表示。

  • SensorNum指传感器的序号。范围通常为 0～63。十进制表示。

  • ITUNum指ITU的序号。十进制表示。

  • BitNum指开关量标签在ITU中的位序号。范围通常为 0～7。十进制表示。

  • 红色字表示格式中可变部分，变化范围参见各种模块的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个模块时可省略。
  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。
功能描述 | 标签地址 | 读写类型 | 变量类型 | 变量的取值范围 | st(控制器地址号)的取值范围 | ch（通道号）的取值范围 | bit(位号)取值范围
当前毛重值 | Read_RS st:ch | 只读 | 模拟量 | 0--65535 | 1--16 | 0 | 不支持位操作
当前净重值 | Read_NT st:ch | 只读 | 模拟量 | 0--65535 | 1--16 | 0 | 不支持位操作
物料的慢加料状态 | R_PARAM st:ch.bit | 只读 | 开关量 | true或false | 1--16 | 2 | 0
物料的快加料状态 | R_PARAMst:ch.bit | 只读 | 开关量 | true或false | 1--16 | 2 | 1
正在补料 | R_PARAMst:ch.bit | 只读 | 开关量 | true或false | 1--16 | 2 | 2
读取各物料是否正在加料状态 | R_PARAMst:ch.bit | 只读 | 开关量 | true或false | 1--16 | 2 | 4-----9 (对应1--6号物料的加料状态)
读取物料的配料控制状态 | COMB_STATUSst:ch. | 只读 | 模拟量 | 0---7 (0：停止状态 1：配料结束 2：错误3：零允差 4：放料 5：快喂料6：慢喂料 7：超差 ) | 1--16 | 0 | 不支持位操作
读取重量分度值 | PRECISIOst:ch | 只读 | 模拟量 | 0---12 | 1--16 | 0 | 不支持位操作
实际（最终）配料值 | ENQst:ch | 只读 | 模拟量 | 0--65535 | 1--16 | 0 --5 | 不支持位操作
皮重值读取/设定 | RW_Tare st:ch | 只读 | 模拟量 | 0--65535 | 1--16 | 0 | 不支持位操作
零位范围的读取/设定 | RW_Zero st:ch | 只读 | 模拟量 | 0--65535 | 1--16 | 0 | 不支持位操作
物料目标值设定 | M_Final st:ch | 可读写 | 模拟量 | 0--65535 | 1--16 | 0--5 | 不支持位操作
快加料点到目标重量的差值设定 | M_Coarse st:ch | 可读写 | 模拟量 | 0--65535 | 1--16 | 0--5 | 不支持位操作
提前量设定值 | M_Fine st:ch | 可读写 | 模拟量 | 0--65535 | 1--16 | 0--5 | 不支持位操作
启动某一物料喂料 | Set_Rlyst:ch | 只写 | 开关量 | true或false | 1--16 | 0--5 | 不支持位操作
停止配料 | Turn_off st:ch | 只写 | 开关量 | true或false | 1--16 | 0 | 不支持位操作
放料 | Unload st:ch | 只写 | 开关量 | true或false | 1--16 | 0 | 不支持位操作
置皮 | Set_Tare st:ch | 只写 | 开关量 | true或false | 1--16 | 0 | 不支持位操作
清皮 | Clr_ Tarest:ch | 只写 | 开关量 | true或false | 1--16 | 0 | 不支持位操作
清零 | CLR_Zero st:ch | 只写 | 开关量 | true或false | 1--16 | 0 | 不支持位操作
秤标定 | Chk_Balance st:ch | 只写 | 模拟量 | 0--65535 | 1--16 | 0 | 不支持位操作
读取寄存器中的某一参数 | R_Param st:ch.bit | 只读 | 开关量或模拟量 | false 或true或0--65535 | 1--16 | 0--103 | 0--15
写取寄存器中的某一参数 | R_Param st:ch | 只写 | 开关量或模拟量 | false 或true或0--65535 | 1--16 | 0--103 | 不支持位操作
读写取寄存器中的某一参数 | WR_Param st:ch.bit | 读写 | 开关量或模拟量 | false 或true或0--65535 | 1--16 | 0--103 | 0--15

标签举例：

寄存器： Read _GS2:0
注释： 读取2号配料控制器的毛重值。

寄存器： Read_NT 2:1
注释： 读取2号配料控制器的净重值。

寄存器： COMB_STATUS2:0
注释： 读取2号配料控制器的物料配料控制状态。

寄存器： R_Param 1:2.1
注释： 读取1号配料控制器的慢加料状态。

寄存器： W_ Param1:35
注释： 设置1号配料控制器的延时补料提示控制时间。

寄存器： RW_ Param1:35
注释： 读取设置1号配料控制器的延时补料提示控制时间。

寄存器： ENQ 3:0
注释： 读取3号配料控制器的实际配料值。

寄存器： RW_Tare 1:0
注释： 读写1号配料控制器的皮重值。

寄存器： M_Final 3:0
注释： 设定3号配料控制器物料的目标值。

寄存器： M_Coasre 3:0
注释： 设定3号配料控制器的快加料点到目标重量的差值。

寄存器： Fine 3:0
注释： 设定3号配料控制器的提前量。

寄存器： RW_Zero 3:0
注释： 读 写3号配料控制器的零位范围。

寄存器： Set_Rly3:0
注释： 启动3号配料控制器的1号喂料。

寄存器： Trun_Off 3:0
注释： 停止3号配料控制器。

寄存器： Set_Tare 3:0
注释： 3号配料控制器置皮。

寄存器： Clr_Tare 3:0
注释： 3号配料控制器清皮。

寄存器： Clr_Zero 3:0
注释： 3号配料控制器清零。

寄存器： Chk_Balance 3:0
注释： 标定3号配料控制器。