志美PT650称重显示器

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供对志美PT650称重显示器的支持，PT650C称重显示器是一种多用途称重显示器，PT650适用于一般工业及商业用途的台秤、地秤、容器秤及汽车衡，也可用于吊秤等。

仪表通讯参数

通讯格式为：1 位启始位，7位数据位，1 位停止位， 偶校验方式；

通讯采用RS232/485标准，采用指令方式通讯,非连续方式，请注意；

波特率：2400,4800,9600,19200可选 ；

地址：可选范围为1～255，十进制；255为广播地址。

注意：本驱动程序默认采用RS232通讯方式进行通讯，当您的仪表采用RS232方式通讯或者采用RS485方式通讯且设备号设顶为0时，请使用默认通讯方式；假如您的仪表选用RS485方式通讯且设备号不为0，则请在建立设备过程中的[高级参数]中将通讯方式选择框中的内容修改为485。建议：对于采用RS485通讯方式来说，假如是一台仪表，最好将设备号设定为0，同时选择默认的通讯方式，即高级参数中将通讯方式选择框中的内容修改为232。

标签说明

  • 下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。

  • 红色字表示格式中设备号，十进制数表示 ，蓝色部分表示地址号，10进制方式。

  • 注:此处仪表中的通信地址以10进制表示。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

WEIGHT ID:CH

读取仪表重量值[单位[kg]

模拟量

只读

0

-99999999-99999999

TARE_PARM ID:CH

读取|设置仪表皮重值

模拟量

读写

0

-999999-999999

TARE_ON ID:CH

控制仪表除皮

开关量

只写

0

0/1[true/false]，当为true时故障复位；false时不动作。

TARE_OFF ID:CH

控制仪表清除皮重

开关量

只写

0

0/1[true/false]，当为true时故障复位；false时不动作。

COMMLINK ID:CH

总线线路通讯状况 模拟量 只读 无 0=通讯始终不成功；1=通讯正常；3=通讯出现故障

DEVICELINK ID:CH

各子设备线路通讯状况

模拟量 只读 0

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：WEIGHT 1:0
数据值类型：模拟量
描述 ：表示设置1号仪表重量值。

标签 ：TARE_PARM1:0
数据值类型：模拟量
描述 ：表示读取|设置1号仪表皮重值。

标签 ：TARE_ON1:0
数据值类型：模拟量
描述 ：表示控制 1号仪表除皮。

标签 ：TARE_OFF1:0
数据值类型：模拟量
描述 ：表示控制 1号清除皮重。