德力西DLP200系列智能仪表

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

开物2000支持以下型号的仪表：

DLP 211： 通用型(lx)保护测控装置。

DLP241 ：线路保护测控装置。

DLP261 ：高压电动机保护测控装置。

DLP281 ：电压互感器保护测控装置。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

硬件连接

通讯端口硬件的推荐设置：

德力西DLP200系列智能仪表采用通过CAN/RS232—MODBUS转换器连接 。

按照模块面板上的can和RS232的速率，通过拨码开关设定相应的can的通讯速率和串口的波特率，两者一一对应。然后将模块的输出端子canh，canl端和仪表的canh，canl端相连。

波特率可选范围：2400bps、4800bps、9600bps、14400bps、19200bps、28800bps、38400bps、57600bps。

对应的CAN通讯速率：5K、10K、20K、50K、125K、250K、500K、1000K。

波特率 | 9600bps
起始位 | 1
数据位 | 8
停止位 | 1
校验位 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数， 如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“天辰仪表向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘delixi’，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址,德力西DLP200智能仪表的站号为0～255。
项目符号 | Ch指通道号，范围因标签类型而异， 即是德力西仪表的偏移地址，十六进制表示。
项目符号 | Status指位号，为开关量， 指的是设备信息的中的开关量和设备信息字各位的状态，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址(基地址) | 含义 | 数据类型 | 读写类型 | 通道地址范围(偏移地址) | 标签值范围
P00_ID:CH | 设备信息访问 | 模拟量 | 只读(0~6可写） | 0～FF | 0～65535
P01_ID:CH | 模拟数据访问 | 模拟量 | 只读 | 0～FF | 0～65535
P02_ID:CH | 实时波形访问 | 模拟量 | 只读 | 0～1FF | 0～65535
P04_ID:CH | 事件记录访问 | 模拟量 | 只读 | 0～5FF | 0～65535
P0A_ID:CH | 控制输出访问 | 开关量 | 只写 | 0～FF | 0/1
P0B_ID:CH | 设备参数1访问 | 模拟量 | 可读可写 | 0～FF | 0～65535
P0C_ID:CH | 设备参数2访问 | 模拟量 | 可读可写 | 0～FF | 0～65535
P0D_ID:CH | 设备参数3访问 | 模拟量 | 可读可写 | 0～FF | 0～65535
P0F_ID:CH | 保护定值访问 | 模拟量 | 可读可写 | 0~1FF | 0～65535
P10_ID:CH | 接线图访问 | 模拟量 | 可读可写 | 0～FF | 0～65535
P12_ID:CH | 梯形图访问 | 模拟量 | 可读可写 | 0～1FF | 0～65535
P14_ID:CH | 扩充汉字点阵访问 | 模拟量 | 可读可写 | 0～1FF | 0～65535
P16_ID:CH | 内置汉字内码访问 | 模拟量 | 只读 | 0～1 FF | 0～65535
P18_ID:CH | 故障录波访问 | 模拟量 | 只读 | 0～FF | 0～65535

下面是对按位读写操作标签P00_ID:CH.Status的建立和处理：

例：仪表设备号为1开关量状态的偏移地址为8，要读取设备信息中开关量状态中的bit0时需建立标签P00_1:8.0，并且将其置为开关量，如下图：

注 ：在需要读取或者写某一位的时候可以用P00_ID:CH.Status标签，

标签举例

标签 ：P00_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0000H，偏移地址为0001H的数据值。

标签 ：P00_1:8.1
数据值类型：开关量
描述 ：表示设备号地址为1的德力西仪表，基地址为0000H，偏移地址为0008H的字的bit1的值

标签 ：P01_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0001H，偏移地址为0001H的数据值

标签 ：P02_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0002H，偏移地址为0001H的数据值

标签 ：P04_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0004H，偏移地址为0001H的数据值

标签 ：P0A_1:1
数据值类型：开关量
描述 ：表示设备号地址为1的德力西仪表，基地址为000AH，偏移地址为0001H的数据值。

标签 ：P0B_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为000BH，偏移地址为0001H的数据值。

标签 ：P0C_1:1
 数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为000CH，偏移地址为0001H的数据值。

标签 ：P0D_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为000DH，偏移地址为0001H的数据值。

标签 ：P0F_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为000FH，偏移地址为0001H的数据值。

标签 ：P10_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0010H，偏移地址为0001H的数据值。

标签 ：P12_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0012H，偏移地址为0001H的数据值。

标签 ：P14_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0014H，偏移地址为0001H的数据值。

标签 ：P16_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0016H，偏移地址为0001H的数据值。

标签 ：P18_1:1
数据值类型：模拟量
描述 ：表示设备号地址为1的德力西仪表，基地址为0018H，偏移地址为0001H的数据值。