开封仪表

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

开封仪表用于测量液面高度和水面高度。

硬件连接

通讯端口硬件的推荐设置：

波特率 | 4800bps
数据位 | 8
停止位 | 2
校验位 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块，以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导。

创建标签

使用“开封仪表向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘KF’，选择并填写‘主地址’，修改标签名。

2、根据 仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | ID指 仪表的地址，用于识别多个仪表， 仪表的地址以十六进制表示，地址设定范围为 0～3 。 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。
项目符号 | Ch指通道号，范围根据 标签类型不同，十进制表示。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 说明 | 变量类型 | 读写类型 | 地址范围 | 标签值范围
L ID:CH | 液面高度 | 模拟量 | 只读 | 0 | 0～20000
WID:CH | 水面高度 | 模拟量 | 只读 | 0 | 0～20000

标签举例

标签 ：L1:0
数据值类型：模拟量
描述 ：表示1号仪表的液面高度

标签 ：W1:8
数据值类型：模拟量
描述 ：表示1号仪表的水面高度