川仪 GREEN系列仪表

常见问题 概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 标签地址对照表 在线升级驱动

常见问题

注意：本驱动由于支持仪表的和数检查功能，所以一定将仪表的通讯参数P.SL(通讯协议选择) 设置成‘ 1 ’表示与
个人计算机通信（带和校数检查）。

概述

本驱动程序支持四川仪表厂GREEN SERIES仪表。

本驱动适用的机型：

项目符号 | UT750,UT350,UT320数字指示调节仪
项目符号 | UP750,UP350程序调节仪
项目符号 | UM350,UM330数字指示报警仪

硬件连接

计算机链接通讯的连接：

GREEN系列备有两种通信接口：

通信接口 | 4线式/2线式RS-485通信 | 2线式高速RS-485通信
对应的机种 | UT750/UP750；UT350/UT320；UP350；UM350/UM330 | UT750/UP750
端子 | 1接口：端子编号23，24，25，26，27 | 2接口：端子编号28，29，30
最大通信速度 | 9600bps | 38.4kbps

高速RS-485通信接口：

项目 | 规格
规格 | EA RS485标准
最大连接台数 | 31台
通信方式 | 2线式半双工
同步方式 | 起止同步式
通信顺序 | 无顺序
最大通信距离 | 1200m
通信速度 | 600，1200，2400，4800，9600，19.2k，38.4k
起始位 | 1位
数据位 | 7或8位
奇偶校验 | 无/偶校验/奇校验
停止位 | 1或2位

通常速度的RS-485通信接口：

项目 | 规格
规格 | EA RS485标准
最大连接台数 | 31台
通信方式 | 2线式半双工
同步方式 | 起止同步式
通信顺序 | 无顺序
最大通信距离 | 1200m
通信速度 | 600，1200，2400，4800，9600，19.2k，38.4k
起始位 | 1位
数据位 | 7或8位
奇偶校验 | 无/偶校验/奇校验
停止位 | 1或2位

通讯端口硬件的推荐设置：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验位 | 偶校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“川仪GREEN系列仪表向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘Green’，选择并填写‘主地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | ID指仪表的设备号地址，用于识别设备中的多个仪表， 仪表的设备号地址以十进制表示，地址设定范围为1～ 99 。 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。
项目符号 | Ch指通道号，范围根据板卡类型不同，十进制表示。
项目符号 | 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 说明 | 变量类型 | 读写类型 | 地址范围 | 标签值范围
DID:CH | 字寄存器 | 模拟量 | 读/写 | 1～1299 | 0～65535
IID:CH | 位寄存器 | 开关量 | 读/写 | 1～784 | 0～1
TYPEID: | 仪表类型寄存器 | 字符串 | 只读 | 无 | 仪表类型－版本号

标签举例

标签变量名称 | 标签类型 | 标签变量值举例 | 标签变量值说明
D2:3 | 模拟量 | 98 | 站号为2的仪表的PV值
D5:3 | 模拟量 | 120 | 站号为5的仪表的PV值
D3:301 | 模拟量 | 23 | 站号为3的仪表的第一目标设定值
D1:5 | 模拟量 | 450 | 站号为1的仪表的输出值
I10:97 | 开关量 | ON | 站号为10的仪表的第一报警状态值
I2:865 | 开关量 | OFF | 站号为2的仪表的用户定义的标志
I3:65 | 开关量 | OFF | 站号为3的仪表的自动/手动状态
TYPE1: | 字符串 | UT750-01V01.R00 | 站号为 1的仪表的类型为UT750，版本号为V01.R00，具体含义见说明书
TYPE8: | 字符串 | UM330-01V01.R00 | 站号为 8的仪表的类型

标签地址对照表(UT320)

仪表参数名称 | 说明 | 标签地址
ADERROR |  | D1
ERROR |  | D2
PV | 当前值 | D3
CSP |  | D4
OUT |  | D5
HOUT |  | D6
COUT |  | D7
MOD |  | D8
PIDNO | PID 参数编号 | D9
CSPNO |  | D10
ALM |  | D11
OR |  | D27
HBC1 |  | D28
HBC2 |  | D29
PARAERR |  | D35
A/M |  | D201
SPNO | 目标设定值编号选择 | D207
CRSP |  | D215
A1 | 报警1设定值 | D231
A2 | 报警2设定值 | D232
A3 | 报警3设定值 | D233
AT | 自动调整 | D241
SC | [SUPER]功能的 ON/OFF | D242
BS | 测定输入偏置 | D243
FL | 测定输入滤波器 | D244
UPR | 设定值上升斜度设定 | D245
DNR | 设定值下降斜度设定 | D246
ORB | ON/OFF 率检测幅度 | D250
ORH | ON/OFF 率上限 | D251
ORL | ON/OFF 率下限 | D252
OH | 输出极限上限值 | D254
OL | 输出极限下限值 | D255
HYS |  | D256
DR | 正/逆动作互换 | D257
HB1 | 加热器断线电流设定值 1 | D258
HB2 | 加热器断线电流设定值2 | D259
1.SP | 目标设定值1 | D301
1.P | 比例带1，加热/冷却控制时为加热侧比例带 | D306
1.I | 积分时间1，加热/冷却控制时为加热侧积分时间 | D307
1.D | 微分时间1，加热/冷却控制时为加热侧微分时间 | D308
1.MR | 手动复位1 | D311
1.Pc | 冷却侧比例带 1 | D314
1.Ic | 冷却侧积分时间 1 | D315
1.Dc | 冷却侧微分时间 1 | D316
1.DB | 不灵敏区1（加热/冷却控制） | D318
1.RP | 参考点 1 | D319
2.SP | 目标设定值 2 | D326
2.P | 比例带2，加热/冷却控制时为加热侧比例带 | D331
2.I | 积分时间2，加热/冷却控制时为加热侧积分时间 | D332
2.D | 微分时间2，加热/冷却控制时为加热侧微分时间 | D333
2.MR | 手动复位 2 | D336
2.Pc | 冷却侧比例带 2 | D339
2.Ic | 冷却侧积分时间 2 | D340
2.Dc | 冷却侧微分时间 2 | D341
2.DB | 不灵敏区2（加热/冷却控制） | D343
2.RP | 参考点 2 | D344
3.SP | 目标设定值 3 | D351
3.P | 比例带3，加热/冷却控制时为加热侧比例带 | D356
3.I | 积分时间3，加热/冷却控制时为加热侧积分时间 | D357
3.D | 微分时间3，加热/冷却控制时为加热侧微分时间 | D358
3.MR | 手动复位 3 | D361
3.Pc | 冷却侧比例带 3 | D364
3.Ic | 冷却侧积分时间 3 | D365
3.Dc | 冷却侧微分时间 3 | D366
3.DB | 不灵敏区3（加热/冷却控制） | D368
4.SP | 目标设定值 4 | D376
4.P | 比例带4，加热/冷却控制时为加热侧比例带 | D381
4.I | 积分时间4，加热/冷却控制时为加热侧积分时间 | D382
4.D | 微分时间4，加热/冷却控制时为加热侧微分时间 | D383
4.MR | 手动复位 4 | D386
4.Pc | 冷却侧比例带 4 | D389
4.Ic | 冷却侧积分时间 4 | D390
4.Dc | 冷却侧微分时间 4 | D391
4.DB | 不灵敏区4（加热/冷却控制） | D393
TMU |  | D904
AL1 | 参考点 1 | D915
AL2 | 报警2类别 | D916
AL3 | 报警3 类别 | D917
HY1 | 报警1延迟 | D919
HY2 | 报警2延迟 | D920
HY3 | 报警3延迟 | D921
PO | 预制输出 | D924
POc | 冷却侧预置输出 | D925
CMD | PID 控制模式 | D926
AR | 超调抑制控制 | D927
ZON | 区域PID选择 | D928
DIS | DI 选择 | D931
RET | 选择变送输出种类 | D1013
RTH | 变送输出最大值 | D1014
RTL | 变送输出最小值 | D1015
LOCK | 键锁定 | D1036
FRE |  | D1037
CS1 | 存储选择画面 1 | D1101
CS2 | 存储选择画面 2 | D1102
CS3 | 存储选择画面 3 | D1103
CS4 | 存储选择画面 4 | D1104
IN | 输入种类 | D1201
UNI | 指定输入单位 | D1202
RH | 仪表量程最大值 | D1204
RL | 仪表量程最小值 | D1205
SDP | 输入的小数点位置（电压输入时显示） | D1206
SH | 输入标尺最大值（电压输入时显示） | D1207
SL | 输入标尺最小值（电压输入时显示） | D1208
BSL | 输入断偶动作选择 | D1209
RJC | 输入 RJC ON/OFF | D1210
OT | 控制输出选择 | D1238
CT | 控制输出周期 | D1240
CTC | 冷却侧控制输出周期 | D1242
PSL | 通信协议选择 | D1247
BPS | 通信速度 | D1248
PRI | 奇偶 | D1249
STP | 停止位 | D1250
DLN | 数据长 | D1251
ADR | 地址 | D1252
RP.T | 最小响应时间 | D1253