研华ADAM5000系列模块

岛电智能单回路仪表(FP21)

概述 系统连接示意图 设备创建 标签创建 标签的地址配置规则 在线驱动升级

概述

岛电智能单回路仪表(FP21) 是岛电仪表系列的一种，主要用来测试温度等参数及其它功能的实现。

系统连接示意图：

仪表设备可以按下面方式进行连接，最多可以连接32个仪表，并且每个仪表地址不能相同。

☆RS-422A通讯口接线示意图

┌──────┐ ┌────────┐ ┌────────┐

│ SD 2├─→──┤3 口一 SDA(4) │──→│RDA (4)接受低(-)│

│ RD 3├──←─┤2 口二 SDB(6) │──→│RDB (6)接受高(+)│

│ PC机 RS 4├→┐ │ 口三 RDA(3) │←──│SDA (3)发送低(-)│

│ CS 5├←┘ │ 口四 RDB(9) │←──│SDB (9)发送高(+)│

│ 25 针 DS 6├←┐ │ SG(5) │───│SG (5)信号地 │

│RS-232C CD 8├←┤ │ 先锋232/422 │───│屏蔽线 (1) │

│ DR20├→┘ │ 隔离转换器 │ │ │

│ 信号地 7├────┤7 │ │仪表的422接口 │

└──────┘ └────────┘ └────────┘

说明:1.短距离时,可不使用信号地和屏蔽线.

2.转换器提供了4个RS422驱动口,在总线上都是并联的.使用数量,具体视现

场的通讯距离来分配.

设备创建向导及参数设置

1． 用户以RS232/RS422 与开物 2000连接：

  • 创建一个或多个子设备

  • 默认通讯参数：波特率4800、8位数据位、1位停止位、无校验

  • 设备可选地址范围：0-31

2． 运行创建向导创建设备

步骤1：选择设备

步骤2：新建设备

步骤3：选择创建方式

步骤4：创建设备

步骤5：设置串口参数

步骤6:创建结束

标签创建

使用设备创建向导创建完设备模块后就可以进行标签创建。

在开发环境中选‘标签’添加标签，见下图。选择主设备为创建的相应模块，选择并填写‘主设备地址’，修改标签名。

标签及地址配置规则

标签名 | 变量类型 | 标签说明 | 标签地址配置 | 读写 | 标签名 | 变量类型 | 标签说明 | 标签地址配置 | 读写
COM/EXT | 开关量 | 工作方式(1:COM,0:EXT) | TAGT: | 读/写 | C1PID | 模拟量 | PID控制号 | TAGT:N T:设备地址（0--31） N:控制号（1-9） | 读
PV | 模拟量 | 当前测量值 | TAGT: | 读 | C1P(F) |  | 比例带(实数) |  | 读/写
SV |  | 当前设定值 |  |  | C1P(I) |  | 比例带(整数)
CPTN |  | 当前曲线号 |  |  | C1I |  | 积分时间
CSTP |  | 当前步号 |  |  | C1D |  | 微分时间
RST | 开关量 | 复位 | TAGT: |  | C2PID | 模拟量 | PID控制号 |  | 读
GUA |  | 确保平台 |  |  | C2OH |  | 调节输出上限 |  | 读/写
ADV |  | 步进 |  |  | C2OL |  | 调节输出下限
HLD |  | 保持 |  |  | C3ALM | 模拟量 | 报警号 | TAG T:N（T:设备地址(0--31)；N:报警号（1--9）） | 读
RUN |  | 运行 |  |  | C3AL1 |  | 报警1设定值 |  | 读/写
FIX |  | 定值 |  |  | C3AL2 |  | 报警2设定值
MAN |  | 手动 |  |  | SVHL | 模拟量 | 设定值上限 | TAGT: | 读/写
AT |  | 自整定 |  |  | SVLL |  | 设定值下限
CFM |  | 编程检查 |  |  | 9/81 | 开关量 | 9组/81步选择（1：81，0：9） | TAGT: | 读/写
TS1 | 开关量 | 时间开关1 | TAGT: |  | 81LOOP |  | 81步循环允许
TS2 |  | 时间开关2 |  |  | CFMMODE | 模拟量 | 部分/全部(PTN/LINK)编程捡查方式(0:PTN,1:LINK) | TAGT: | 读/写
TS3 |  | 时间开关3 |  |  | CFMTIME |  | 编程捡查时间倍率
TS4 |  | 时间开关4 |  |  | PVFIL | 模拟量 | 测量值滤波常数 | TAGT: | 读
AL1 |  | 报警1 |  |  | PVBIAS |  | 测量值偏移
AL2 |  | 报警2 |  |  | RD | 字符串 | 调节反/正作用 | TAGT:
SO |  | 超量程 |  |  | CYCTIME | 模拟量 | SSR和继电器接点的比例周期 | TAGT:
OUT | 模拟量 | 调节输出 | TAGT: |  | TM1MODE | 字符串 | 模拟通讯1发送选择 |  | 读
DEV |  | 偏差 |  |  | TM2MODE |  | 模拟通讯2发送选择
TIME |  | 当前剩余时间 |  |  | TM1HL | 模拟量 | 模拟通讯1 上限 |  | 读
LINK_FAT |  | 链接格式 |  |  | TM1LL |  | 模拟通讯1 下限
LINK_PT |  | 链接指针 |  |  | TM2HL |  | 模拟通讯2 上限
LINK_EXE |  | 链接执行重复次数(实际值) |  |  | TM2LL |  | 模拟通讯2 下限
LINK_SET |  | 链接执行重复次数(设定值) |  |  | AL1MODE | 字符串 | 报警1 方式 | TAGT: | 读
PTN_REPT |  | 曲线重复次数(实际值) |  |  | AL2MODE |  | 报警2 方式
PTN_SET |  | 曲线重复次数(设定值) |  |  | AL1SNS | 模拟量 | 报警1 灵敏度
CPID |  | 当前PID号 |  | 读 | AL1STBY | 字符串 | 报警1 待机
CALM |  | 当前报警号 |  |  | AL2SNS | 模拟量 | 报警2 灵敏度
SV_SET | 模拟量 | 目标设定值 | TAGT: |  | AL2STBY | 字符串 | 报警2 待机
TIME_SET |  | 设定时间 |  |  | DI1 | 字符串 | 外部I/O DI_1 定义 | TAGT: | 读
K_RST | 开关量 | 键功能复位 | TAGT: | 读/写 | DI15 |  | 外部I/O DI_15 定义
K_GUA |  | 键功能确保平台 |  |  | DO21 |  | 外部 I/O OC门DO21
K_ADV |  | 键功能步进 |  |  | DO22 |  | 外部 I/O OC门DO22
K_HLD |  | 键功能保持 |  |  | DO23 |  | 外部 I/O OC门DO23
K_RUN |  | 键功能运行 |  |  | DO31 |  | 外部 I/O DO31
K_FIX |  | 键功能定值 |  |  | DO32 |  | 外部 I/O DO32
K_MAN |  | 键功能手动 |  |  | DO33 |  | 外部 I/O DO33
K_AT |  | 键功能自整定 |  |  | OUTTYPE | 字符串 | 调节输出类型 | TAGT: | 读
K_CFM |  | 键功能编程检查 |  |  | CM1TYPE |  | 模拟通讯形式1
STAT_PTN | 模拟量 | 起始曲线号 | TAGT: |  | CM2TYPE |  | 模拟通讯形式2
STAT_STEP |  | 起始步号 |  |  | DCMTYPE |  | 数字通讯接口类型
_LINK_FAT | 模拟量 | 链接格式 |  |  | C/F/N | 字符串 | 显示单位 |  | 读
_LINK_EXE |  | 链接执行次数 |  |  | PT/JPT |  | 铂电阻标准
_PV_START | 开关量 | 伺服起动 |  |  | INTYPE | 字符串 | 输入类型 |  | 读
_ADV_MODE | 开关量 | 跳步方式_ADV_MODE(STP/TIME) (1:STP,0:TIME) |  |  | SNSTYPE |  | 传感器类型
_ADV_TIME | 模拟量 | 跳步时间_ADV_TIME |  |  | 0VAL | 模拟量 | 0% 量程 | TAGT: | 读
FIXSV(F) | 模拟量 | 定值方式设定值(实数) |  | 读/写 | 100VAL |  | 100% 量程
FIXSV(I) |  | 定值方式设定值(整数) |  |  | SCALEL | 模拟量 | 直流数字量程下限 |  | 读
FIXPID |  | 定值方式PID号 |  |  | SCALEH |  | 直流数字量程上限
FIXALM |  | 定值方式报警号 |  |  | DOTADD |  | 小数点位置
PINNO | 模拟量 | 曲线号 | TAGT:N T:设备地址（0--31） N:曲线号（1--9） | 读 | SOMODE | 字符串 | 超量程对策 |  | 读
STATSV(I) |  | 起始设定值(整数) |  | 读/写 | SOOUT |  | 超量程保持输出值
STATSV(F) |  | 起始设定值(实数) |  |  | PWRTYPE | 模拟量 | 五种上电方式
GUAZN(F) |  | 确保的允许偏差(实数) |  |  | TMUNIT | 字符串 | 程序运行时间单位
GUAZN(I) |  | 确保的允许偏差(整数) |  |  | PID_ALG |  | 三种 PID 算法选择
GUATM(F) |  | 允许等待时间(实数) |  |  | PTNED | 模拟量 | 曲线结束步 | TAG T:N（T:设备地址（0--31）；N:曲线号（1--9）） | 读/写
GUATM(I) |  | 允许等待时间(整数) |  |  | PTNRPT |  | 曲线重复次数
S1PTN | 模拟量 | 曲线号 | TAG T:N.C T:设备地址（0--31） N:曲线号（1--9） C:步号（1--9） | 读 | S4PTN | 模拟量 | 曲线号 | TAG T:N.C T:设备地址（0--31） N:曲线号（1--9） C:步号（1--9） | 读
S1STEP |  | 步号 |  |  | S4STEP |  | 步号
S1SV(F) |  | 目标设定值(实数) |  | 读/写 | S4TS2 | 开关量 | 时间开关2允许 |  | 读/写
S1SV(I) |  | 目标设定值(整数) |  |  | S4ONT | 模拟量 | 开关2开时间
S1TIME |  | 目标执行时间 |  |  | S4OFFT |  | 开关2关时间
S2PTN | 模拟量 | 曲线号 |  | 读 | S5PTN | 模拟量 | 曲线号 |  | 读
S2STEP |  | 步号 |  |  | S5STEP |  | 步号
S2PID |  | PID号 |  | 读/写 | S5TS3 | 开关量 | 时间开关3允许 |  | 读/写
S2ALM |  | 报警号 |  |  | S5ONT | 模拟量 | 开关3开时间
S3PTN | 模拟量 | 曲线号 |  | 读 | S5OFFT |  | 开关3关时间
S3STEP |  | 步号 |  |  | S6PTN | 模拟量 | 曲线号 |  | 读
S3TS1 | 开关量 | 时间开关1允许 |  | 读/写 | S6STEP |  | 步号
S3ONT | 模拟量 | 开关1开时间 |  |  | S6TS4 | 开关量 | 时间开关4允许 |  | 读/写
S3OFFT |  | 开关1关时间 |  |  | S6ONT | 模拟量 | 开关4开时间
 |  |  |  |  | S6OFFT |  | 开关4关时间

说明：1.设备地址范围0--31;

2.对于类似 STATSV(F)，STATSV(I)中的F,I表示仪表当前是实数或整数，根据表面设定而确定选则相应标签；

3.对 TAGT: T表示仪表地址

4.对模拟量如果面板显示为‘--’的值显示为65535

设备支持的标签举例：

标签：PV1:

数据类型：模拟量

描 述：表示1站号仪表当前测量值值。

标签：SV1:

数据类型：模拟量

描 述：表示1站号仪表当前设定值。

标签：S1SV(F)1:1.2

数据类型：模拟量

描 述：表示1站号仪表曲线号1步号2的目标设定值