安东LU900系列仪表

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

默认通讯参数如下：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3： 显示单个、多个仪表或者自动创建，单击‘下一步’按钮。

步骤4：设备自动搜索完毕后，单击“下一步”。

步骤5：显示设备的设定参数，单击“完成”。。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

ID指仪表的仪表地址，用于识别设备中的仪表， 仪表地址以十进制表示，地址设定范围为00 ～ 31 。标签地址中省略ID时，开物2000系统默认为是所连接的最小仪表地址。

项目符号

Ch指通道号。范围根据标签类型所决定。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

PVID:

PV值

模拟量

只读

0～65535

SVID:

SV值

模拟量

只读

0～65535

MV ID:

MV值

模拟量

只读

0～65535

SS ID:Ch

通用参数

模拟量

可读可写

-65535～131070

AC ID:

自动切换

开关量

只写

0/1

MC ID:

手动切换

开关量

只写

0/1

EO ID:

结束指令

开关量

只写

0/1

标签举例

标签 ：PV 1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的PV值

标签 ：SV1:
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的SV值

标签 ：MV 1:
数据值类型：模拟量
描述 ：表示设备配置示例中1 号设备通道的MV值

标签 ：SS 1:5
数据值类型：模拟量
描述 ：表示设备配置示例中1号设备的通用参数的 代码为5的参数值

标签 ：AC 1:
数据值类型：模拟量
描述 ：表示设备配置示例中设置1号设备自动

标签 ：MC1:
数据值类型：模拟量
描述 ：表示设备配置示例中设置1号设备手动

标签 ：EO1:
数据值类型：模拟量
描述 ：表示设备配置示例中设置1号设备的控制指令

地址对应表：

代码

参数

代码

参数

代码

参数

代码

参数

0

MV

11

HiL

22

Addr

33

第3段给定值

1

SV

12

Hy

23

bAud

34

第4段时间

2

状态标志

13

tc

24

起始时间

35

第4段给定值

3

P1

14

Sn

25

起始给定值

36

第5段时间

4

P2

15

FiL

26

第0段时间

37

第5段给定值

5

rt

16

oPL

27

第0段给定值

38

第6段时间

6

HiAL

17

oPH

28

第1段时间

39

第6段给定值

7

LoAL

18

ctrL

29

第1段给定值

40

第7段时间

8

dAL

19

oP

30

第2段时间

41

第7段给定值

9

oSEt

20

LdiS

31

第2段给定值

42

第8段时间

10

LoL

21

DLP

32

第3段时间

43

第8段给定值

代码

参数

代码

参数

代码

参数

代码

参数

44

第9段时间

50

第12段时间

56

第15段时间

62

第18段时间

45

第9段给定值

51

第12段给定值

57

第15段给定值

63

第18段给定值

46

第10段时间

52

第13段时间

58

第16段时间

64

第19段时间

47

第10段给定值

53

第13段给定值

59

第16段给定值

65

第19段给定值

48

第11段时间

54

第14段时间

60

第17段时间

49

第11段给定值

55

第14段给定值

61

第17段给定值