宇光AI系列智能仪表

威胜电子式电能仪表综述

概述 硬件连接 硬件接线图 地址设置 创建设备 创建标签 标签的地址规则 标签举例 标签类型 华富惠通公司

威胜电子式电能仪表通信协议概述

威胜电子式电能仪表通信协议支持DTSD341（DSSD331）-5TK（V5.7）与PC机间的通讯。本协议采用串行通讯

RS485接口，使用您计算机中的串行口。

开物2000还支持其它多种仪表，详情请与 华富惠通公司联系。

威胜电子式电能仪表与系统的连接

上下位机硬件连接与设置

采用RS232/RS485转换器：

设置威胜电子式电能仪表

威胜电子式电能仪表的所有设定参数（即开物2000中的大部分标签）都可通过仪表面板上的按键进行设置，

重要设置如下：

设 置 项

设 置 方 式

仪表地址

范围：00H～FFH（除去系统保留字0DH、AAH、55H、BBH、BCH、BDH、B8H、6DH、C7H、9AH等）

通讯数据格式（固定）

8个数据位，1个停止位，偶校验

通讯波特率范围

300-9600Bit/S范围内任意设置，出厂缺省设置为1200Bit/S

威胜电子式电能仪表与系统的接线图

威胜电子式电能仪表采用RS-485通讯方式时，应用上位计算机RS-232C串口通讯时必须采用RS-232C/RS-485

转换装置。RS485接线图

计算机采用RS-485通讯方式时，最多能带256台宇光AI系列仪表，其地址号范围是0-255。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

选择设备类型。双击‘威胜电子式电能仪表’，或单击选中‘威胜电子式电能仪表’，更改设备名称，最后单击‘选择’按钮。

选择操作方式-新建设备(一个设备中可以包含多个仪表)。双击‘新建设备’(或选中‘新建设备’后单击‘下一步’按钮)。

选择创建设备的方式：双击‘多设备创建’。（如果仪表已经连接到本机，双击‘自动创建’）

显示多设备创建界面，选择好设备类型，输入仪表号后，点击‘添加设备’按钮。添加完所有的设备后，单击‘下一步’按钮。

下图示范的是开物2000系统通过RS485与10只DTSD341_5TK仪表相连。

显示计算机串行口通讯参数窗口，修改完串行口、波特率等参数后，单击‘下一步’按钮。

显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘威胜电子式电能表’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式等。单击‘添加’或‘完成’按钮。

下图演示建立威胜电子式电能表的“当前总电量”数据标签，由于工程值和实际的测量值比例关系为1：1，所它们的取值的范围一样。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型ID:[Chn]

说明：

  • ID指仪表的设备表号(开物2000设备向导中的表号) ，Chn指通道号。

  • 红色字表示格式中可变部分，十进制数表示，变化范围参见各种仪表的帮助文件。
  • 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
  • 标签地址配置成不存在类型或设备表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签使用举例:

连接设备同上：一只DTSD341_5TK(硬件设定表号0)、一只DTSD341_5TK(硬件设定表号1)、一只DTSD341_5TK(硬件设定表号7)、一只AI808(硬件设定表号9)

例1：

计算机欲访问表号为３的DTSD341_5TK表当前总电量，则在设备标签的定义中该标签的主地址应定义为‘Gross3:0’，其中‘Gross’指明访问的参数是当前总电量，‘3’对应开物2000中的设备表号，冒号是规则要求，以区分表号和段号，０是通道号（在此DTSD341_5TK仪表中恒为０）。

例2：

计算机欲访问表号为４的DTSD341_5TK表报警状态，则在设备标签的定义中该标签的主地址应定义为‘Alarm4:0’，其中‘ALarm’指明访问的参数是报警状态，‘４’对应开物2000中的设备表号，冒号是规则要求，以区分表号和段号，０是通道号（在此DTSD341_5TK仪表中恒为０），得到状态值后可通过开物脚本的位操作功能获得各位的值，从而可确定各参数的当前状态。

威胜电子式电能仪表标签类型

标签地址 | 对应的参数含义 | 通道范围 | 标签值类型 | 标签值范围
AlarmID:Chn | 报警状态 | 0（可省略） | 模拟量 | 0-255 ("=2"时为A相失压，"=4"时为B相失压，"=8"时为C相失压)
AvNoPowerID:Chn | 1分钟无功平均功率 | 0（可省略） | 模拟量 | -65535－65535
AvPowerID:Chn | 1分钟有功平均功率 | 0（可省略） | 模拟量 | -65535－65535
Gross ID:Chn | 当前总电量 | 0（可省略） | 模拟量 | -4294967296－4294967296
TLoseTime ID:Chn | 总失压时间 | 0（可省略） | 模拟量 | 0－16777216

概述 硬件连接 硬件接线图 地址设置 创建设备 创建标签 标签的地址规则 标签举例 标签类型 华富惠通公司

参见

开物2000支持的硬件设备


返回


北京华富惠通技术有限公司

欢迎使用开物2000的帮助系统

北京华富惠通技术有限公司

地址：北京市海淀区万泉河路68号紫金大厦10层
电话：（010）82657662/3/4/5/8
传真：（010）82657662/3/4/5/8转1016
邮政编码：100086
E-mail:office@huafugroup.com