天辰智能仪表

概述 标签说明 在线升级驱动

概述

通讯格式为：数据格式为 10 位：1 位启始位，8 位数据位，无奇偶校验位，1 位停止位。

波特率：可选范围为 2400bps、4800bps、9600bps、19200bps。出厂设定为 9600bps，当修改波特率时，必须将相连的所有仪表及计算机修改成同一波特率。

地址：可选范围为 00～99，十进制。

标签说明

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的表号)，取值范围是0-99。

项目符号

红色字表示格式中设备号，十进制数表示 ，蓝色部分表示命令号，十进制表示。

项目符号

根据协议，Parm标签可读可写，格式为ParmID:CH,其中ID代表该仪表的地址，CH代表该标签所对应的 参数地址号。

项目符号

注：此处仪表中的通道地址以10进制表示。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

位通道地址

PV ID:CH

普通仪表

主测量值

模拟量

只读

0～79

-9999999～99999999

－－

PV ID:CH.Bit

巡检仪类仪表（Bit代表各通道报警状态）

主测量值

模拟量

只读

0～79

-9999999～99999999

1～4

（开关量）

PVII ID:CH

其它测量值

模拟量

只读

0～7

0～99999999

－－

DI ID:CH

读取开关量状态

开关量

只读

1～8

0～1

－－

DO ID:CH

读取|设定开关输出状态

开关量

读写

1～8

0～1

－－

PARM ID:CH

普通仪表和与通道无关的巡检仪类仪表

读取|设定仪表参数

模拟量

读写

0～95

-99999～99999

0～79

PARM ID:CH.Bit

巡检仪类仪表与通道有关的参数（Bit代表通道）

读取|设定仪表参数

模拟量

读写

0～95

-99999～99999

0～79

AO ID:CH

读取|设定 模拟量输出

模拟量

读写

1～8

-65535～65535

－－
ALARM ID:CH 读取仪表报警状态 开关量 只读 0～79 0～1 －－

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：PV1:0
数据值类型：模拟量
描述 ：表示1号仪表的测量值。

标签 ：PV1:0.1
数据值类型：模拟量
描述 ：表示1号仪表的第1报警点的报警状态。

标签 ：PARM1:0
数据值类型：模拟量
描述 ：表示1号仪表（巡检仪）的第一个参数值，关于对应的参数地址请查阅相关的硬件说明书。

标签 ：PARM1:0.1
数据值类型：模拟 量
描述 ：表示1号仪表（巡检仪）第1报警点第2通道的测量值。

标签 ：PARM1:0.0
数据值类型：模拟 量
描述 ：表示1号仪表第1报警点第1通道的测量值。

标签 ：SV1:0
数据值类型：模拟量
描述 ：读取|设定1号仪表的设定值。

标签 ：AO1:3
数据值类型：模拟量
描述 ：读取|设定1号仪表的第3路模拟量输出值。数据范围从-6.3％到+106.3％，输出的绝对值由仪表决定。如设定值等于50，则本命令发出后仪表将输出12mA（4mA＋0.50×16mA＝12mA）。

标签 ：ALARM1:0
数据值类型：模拟量
描述 ：表示1号仪表的第1通道的报警状态。

标签 ：ALARM1:1
数据值类型：模拟量
描述 ：表示1号仪表的第2通道的报警状态。