宇光AI仪表

宇光AI系列 仪表

概述 硬件连接 硬件接线图 地址设置 创建设备 创建标签 标签的地址规则 标签举例 标签类型 常见问题 在线升级驱动

宇光AIBUS通信协议概述

宇光AIBUS通信协议支持与AI-708、AI-808、,AI-708P、AI708T、AI-808P、AI-708H、AI-708Y、AI-708M等AI系列的通讯。本协议采用串行通讯

RS485接口，使用您计算机中的串行口。

开物2000还支持其它多种仪表，详情请与 华富惠通公司联系。

宇光AI系列智能仪表与系统的连接

上下位机硬件连接与设置

采用RS232/RS485转换器：

设置宇光AI系列智能仪表

宇光AI系列智能仪表的所有设定参数（即开物2000中的大部分标签）都可通过仪表面板上的四个按键进行设置，

重要设置如下：

设 置 项

设 置 方 式

仪表地址

范围：0-199，（AI708M表占用连续的6个表号，AI708P表可占用连续的两个表号，建议使用设备向导的自动创建功能配置仪表）

通讯数据格式（固定）

8个数据位，2个停止位(无校验)

通讯波特率范围

300-9600Bit/S范围内任意设置，出厂缺省设置为9600Bit/S

注 1：通讯通道地址设置方法

以AI-708为例：

按设置键（右列第一个键）并保持 2 秒，待显示出参数后放开，再按此键，仪表将依次显示各参数，当显示 Addr 时，通过仪表面板上依次的数据移位键、数据减少键和数据增加键（左列第一个键-左列第三个键）设定通讯通道地址；

注 2：通讯波特率的设置

按同样方法，待显示 bAud 参数时，通过数据移位键、数据减少键和数据增加键设置通讯波特率。

宇光AI系列智能仪表与系统的接线图

当宇光AI系列仪表采用RS-485通讯方式时，应用上位计算机RS-232C串口通讯时必须采用RS-232C/RS-485

转换装置。RS485接线图

计算机采用RS-485通讯方式时，最多能带101台宇光AI系列仪表，其地址号范围是0-199。

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

选择设备类型。双击‘厦门宇电AI仪表’，或单击选中‘厦门宇电AI仪表’，更改设备名称，最后单击‘选择’按钮。

选择操作方式-新建设备(一个设备中可以包含多个仪表)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

选择创建设备的方式：选中‘多个仪表创建’后，单击‘下一步’按钮。（如果仪表已经连接到本机，双击‘自动创建’）

显示多设备创建界面，选择好仪表类型，输入表号后，点击‘添加仪表’按钮。添加完所有的仪表后，单击‘下一步’按钮。

下图示范的是开物2000系统通过RS485与一只AI-708(硬件设定表号0)连接。

显示计算机串行口通讯参数窗口，修改完串行口、波特率等参数后，单击‘下一步’按钮。

显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘宇光AI仪表’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式等。单击‘添加’或‘完成’按钮。

下图演示AI-708命令2的配置。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型ID:[Chn]

说明：

项目符号

ID指仪表的设备表号(开物2000设备向导中的表号) ，Ch指命令号。

项目符号 | 红色字表示格式中 设备号，十进制数表示，变化范围参见各种仪表的参数设置文件。
项目符号 | 蓝色括号 表示命令号，参见命令号列表。
项目符号 | 标签地址配置成不存在类型或设备表号错误或命令号超出有效范围时，标签将不被承认，读不上数据。

宇光AI系列智能仪表标签类型

各种仪表支持的标签-仪表参数各不相同，请参见帮助文件。

见问题

问题1：

为什么开物2000中标签的显示值比AI表上显示值大10倍或100倍？

答：由于在AI表在通讯时是以整数的形式将测量值等参数结果传递上来，小数点的位置不能自动获取，因此在开物2000中标签的测量值始终是一个整数。

解决方法：修改标签的工程值零点和工程值量程，缩小10倍或100倍。例如：把测量值标签的工程值零点由默认的-19990改为-199.90，把测量值标签的工程值零点由默认的119980改为1199.80。


宇电AI仪表参数说明

厦门宇电AI仪表 参数说明

宇光AI系列智能仪表 概述 标签使用举例 在线升级驱动

AI系列仪表概述

1、具备单显示，二位/三位/四位调节、报警、变送及通讯功能。
2、具备先进的AI人工智能调节及自整定、自学习功能，无超调及无欠调的优良控制特性。适合温度、压力、流量、液位、湿度......的精确控制。
3、可编程多种热电偶、热电阻、mV及标准信号的输入，还可以扩充输入信号。
4、模块化输出支持SSR电压、线性电流（电压）、继电器触点开关、可控硅无触点开关及可控硅过零触发输出。有上限、下限、正偏差及负偏差等多种报警模式及上电免除报警等功能。
5、可定义参数查看及修改的权限。
6、测量精度：0.2级（±0.2％FS）。
7、AI系列包括AI708、AI708H、AI708M、AI708Y、AI708T、AI808、AI808P、AI508T等一系列仪表，驱动程序根据该系列的通用协议开发，支持该系列的所有仪表。

 标签使用举例

一只AI-708(硬件设定表号0)、一只AI-708M(硬件设定表号1，实际占用表号1-6)在开物中需要建立6个地址连续的设备，其中首地址为真正的设备地址，其它的依次加1、一只AI-708P、AI-708Y(硬件设定表号7，实际占用表号7-8)、一只AI808(硬件设定表号9)

计算机欲访问AI-708M表第三个通道的测量值，则在设备标签的定义中该标签的主地址应定义为‘PV3:0’，其中‘PV’指明访问的参数是测量值，‘3’对应开物2000中的设备表号和通道号，冒号是规则要求，以区分表号和段号。

注：对AI-708M表，通道1占用第一个设备表号，通道2占用第二个设备表号，以此类推。本例中AI-708M表的第一个设备表号是1，因此通道3的设备表号是3。

说明：

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的表号)，取值范围是0-199。

项目符号

红色字表示格式中设备号，十进制数表示 ，蓝色部分表示命令号，十进制表示。

项目符号

根据协议，Parm标签可读可写，格式为ParmID:CH,其中ID代表该仪表的地址，CH代表该标签所对应的命令号，命令号列表见下表 。

计算机欲访问硬件表号为1的AI-708的的测量值，则在设备标签的定义中该标签的主地址应定义为‘PV1:0’，其中‘PV’指明访问的参数是测量值，‘1’对应开物2000中的表号。

假设708Y仪表的设备号为1，则应该在开物软件中建立1号和2号两块仪表。这是仪表本身规定的。当要读取708Y型号仪表的瞬时流量时标签为PV1：0；当要读取温度和压力时，标签分别为PV2：0和SVR2：0。

在使用过程中一定要注意标签的配置规则。

参数号

AI-708/808/708P/808P

AI-708H/Y

AI-708M

0

SV/STEP 给定值/程序段

SV

(空)

1

HIAL 上限报警

FHIA

HIA(X)

2

LoAL 下限报警

FIoA

LoA(X)

3

dHAL 正偏差报警

SPE

(空)

4

dLAL 负偏差报警

Act

(空)

5

dF 回差

Esn

dF(X)

6

CtrL 控制方式

FSc

(空)

7

M5 保持参数

PdIH

(空)

8

P 速率参数

CSc

(空)

9

t 滞后参数

CdIH

(空)

10

CtI控制周期

Cut

(空)

11

Sn 输入规格

FdIH

Sn(X)-34 (只读)

12

dIP 小数点位置

FdIP

Sn(X)-1 (只读)

13

dIL 下限显示值

PA

dIL(X)

14

dIH 上限显示值

Po

dIH(X)

15

ALP 报警输出选择

Co

ALP(X)

16

Sc 传感器修正

Frd

(空)

17

Op1 输出方式

CF

(空)

18

oPL 输出下限

bc

(空)

19

oPH 输出上限

IoL

(空)

20

CF 功能选择

FoH

Cn功能选择

21

波特率/808P运行状态控制字

仪表型号特征

仪表型号特征

22

ADDR通讯地址

ADDR通讯地址

ADDR通讯地址

23

dL 数字滤波

IoH

Sn(X)-2 (只读)

24

run 运行参数

dL

nonc 常开/常闭选择

25

Loc 参数封锁

Loc

Loc参数封锁

26-85

C01-t30 程序数据

无

无

27

T01

无

无

28

C02

无

无

29-85

T02-T30

无

无

报警值说明：可以用标签数据与相应位进行为运算得到报警状态。

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：PV1:0
数据值类型：模拟量
描述 ：表示1号仪表的测量值。

标签 ：PARM1:0
数据值类型：模拟量
描述 ：表示1号仪表的第一个参数值，对应不同的仪表为不同的含义。如AI-708H为SV值。

标签 ：ALARM1:0
数据值类型：模拟量
描述 ：表示1号仪表的报警值。

标签 ：Q_SUM1:0
数据值类型：模拟量
描述 ：表示1号流量累积仪表的流量累积值。