北大三金智能仪表

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

北大三金智能仪表通讯协议支持北大三金有线通讯、无线通讯仪表。本协议采用串行通讯（RS-232C或RS-485通讯协议），使用您计算机中的串行口。开物2000还支持其它多种仪表，详情请与华富惠通公司联系。

硬件连接

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的 仪表 。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘ 北大三金智能仪表’，或单击选中‘ 北大三金智能仪表’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示设备创建方式配置界面。在向导选择多传感器创建，单击‘下一步’按钮。

步骤4：显示设备 配置向导，在此向导中添加相应的设备，并确定其单元号，单击“下一步”按钮。

步骤5：显示串口参数配置向导，在向导中配置好各参数，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘ 北大三金智能仪表 ’，选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]ChID[.BitID[.ThirdSegID[.FourSegID[.FiveSegID]]]]

说明：

项目符号

ID指开物设备网络中的 硬件子设备地址，用于识别设备中的 某个硬件子设备。 一般情况下，ID可以是十进制或十六进制表示形式,位数不限。通常从0开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。

项目符号

ChID一般指通道号。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号

BitID指开关量标签的位序号。可以是八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号

ID,ChID,BitID,ThirdSegID,FourSegID,FiveSegID的含义可以自由定义。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 驱动的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个 子设备时可省略。
项目符号 | 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

ID(设备地址)范围 CH(通道)范围

标签值范围

FLOWID:CH | 读取流量 | 模拟量 | 只读 | 0-63 | 0 | -1147483648--3294967295
FLOWSUMID:CH | 读取流量累积量 | 模拟量 | 只读 | 0-63 | 0 | -1147483648--3294967295
PRESID:CH | 读取压力值 | 模拟量 | 只读 | 0-63 | 0 | -1147483648--3294967295
TEMPID:CH | 读取温度值 | 模拟量 | 只读 | 0-63 | 0 | -1147483648--3294967295
TRANS_MODEID:CH | 设置通讯方式 | 模拟量 | 只写 | 0-63 | 0 | 0--65535（例：2---为无线方式，1---为有线方式）
PARMETERID:CH | 设置内部参数 | 模拟量 | 只写 | 0-63 | 0 | 0--65535

注：

1、在使用“设置通讯方式TRANS_MODE”标签时，其初始值应赋成相应的通讯参数值，假若使用“设置内部参数标签PARAMETER”时，其初始值也得赋成相应的值，这两标签只在通讯初始化时起作用，因此在工程执行其间对它的修改将不起任何作用。

标签举例

标签 ：FLOW1:0
数据值类型：模拟量
描述 ：表示读取设备配置示例中1号北大三金智能仪表的流量值FLOW

标签 ：FLOWSUM1:0
数据值类型：模拟量
描述 ：表示读取设备配置示例中1号北大三金智能仪表的读取流量累积量值FLOWSUM

标签 ：PRES1:0
数据值类型：模拟量
描述 ：表示读取1设备配置示例中号 北大三金智能仪表的压力值PRES

标签 ：TEMP1:0
数据值类型：模拟量
描述 ：表示读取设备配置示例中1号 北大三金智能仪表的温度值TEMP

标签 ：TRANS_MODE1:0
数据值类型：模拟量
描述 ：表示设置设备配置示例中1号北大三金智能仪表的通讯传输方式TRANS_MODE

标签 ：PATAMETER1:0:
数据值类型：模拟量
描述 ：表示设置设备配置示例中1号北大三金智能仪表的内部参数PARAMETER


用户常见问题

设备向导首页的“调试设置”按钮有什么用处 设备向导首页的“版本信息”按钮有什么用处
RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

  • 检查标签设计是否有错误

  • 查看设备通讯效率，提供设计优化参考

  • 检查线路连接情况，是否有强干扰源

  • 检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。

  • 检查系统资源，尤其是内存是否够用。

  • 将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。

  • 查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

  • 提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。

  • 提示驱动程序提供的功能，支持的硬件型号等重要信息。

  • 显示最新的驱动程序帮助文件。

RS485 网络应用提示

  • 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。

  • 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。

  • RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。

  • RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。

  • RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。