保定通用智能仪表

概述 标签说明 标签举例 在线升级驱动

概述

保定市通用电器厂是集科研开发、生产经营、技术服务为一体的高新技术企业，专业从事直流互感器、比较仪、整流柜监测设备及其配套仪表模块的开发、生产、销售，并承接特殊产品的设计和定制业务，具备完全独立的开发和生产能力。

仪表通讯参数

通讯格式为：1 位启始位，8 位数据位，1 位停止位，无校验 。

波特率：9600bps。

地址：可选范围为1～247，十进制。

标签说明

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的表号)，取值范围是1-247。

项目符号

红色字表示格式中设备号，十进制数表示 ，蓝色部分表示地址号，十进制表示。

项目符号

注:此处仪表中的通信地址以10进制表示。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

PV ID:CH

读取测量值

模拟量

只读

0

-99999999--99999999

Hi ID:CH

读取|设定上限报警值

模拟量

读写

0

-99999999--99999999

Lo ID:CH

读取|设定下限报警值

模拟量

读写

0

-99999999--99999999

MODE ID:CH

读取工作方式

模拟量

只读

0

0--255

STS ID:CH

读取报警状态

模拟量

只读

0

0--255

PARM ID:CH

读取|设定仪表参数

模拟量

读写

0—255（预留）

-99999999--99999999

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：PV1:0
数据值类型：模拟量
描述 ：表示1号仪表的测量值。

标签 ：Hi2:0
数据值类型：模拟量
描述 ：读取2设定1号仪表的上限报警值。

标签 ：Lo3:0
数据值类型：模拟量
描述 ：读取|设定3号仪表的下限报警值。

标签 ：MODE1:0
数据值类型：模拟量
描述 ：读取|设定1号仪表的工作方式。

标签 ：STS1:0
数据值类型：模拟量
描述 ：读取1号仪表的报警状态。

标签 ：PARM1:0
数据值类型：模拟量
描述 ：表示1号仪表的第一个参数值，关于对应的参数地址请查阅相关的硬件说明书。 对于PARM标签是为了留作扩展用，其地址号为仪表对应的参数号，数据格式为4个字节浮点数，读写分别对应的指令码为03H、10H。