中控R2000无纸记录仪

浙大中控R无纸记录仪

浙大中控R无纸记录仪 概述 创建设备 标签类型 在线升级驱动

浙大中控R无纸记录仪概述

1、驱动程序根据〈R2000与上位机通讯协议（公开版）〉开发。
2、驱动程序实现的主要是38H、48H、A8H、A1H、A5H五个命令。涉及到的功能读取数据。

在开物2000开发环境中创建设备

第一步、运行开物2000，进入开发环境，双击工程中的硬件系统，选择（或创建计算机节点）。

第二步、点击右键弹 出菜单选择“新建”，弹出窗体如下：

第三步、在目录树中展开节点“智能仪表”，选择“R2000无纸记录仪”，在左边设备名一栏中输入设备名称（自己定义即可），定义后如下图所示：

第四步、点击“选择”按钮，进入设备操作方式选择界面，如下图所示： （在下面的界面中点击“调试设置”按钮，进入报文设置的界面，选择里面三个选项，删除下面文本框中的数据，点击”保存修改“按钮，退出即可。在测试结束后在到该界面把报文保存出来即可）

第五步、选择“新建设备”，点击“下一步”按钮进入设备连接方式选择界面，如下图所示。

第六步、在设备的连接方式上根据需要进行选择，这里我们选择232方式连接，点击“下一步”按钮，进入设备类型选择界面，如下图所示。

第七步、根据需要选择无纸记录仪的型号，这里我们选择“R2000”，设备号设置为仪表的地址号，点击"下一步"按钮进入仪表参数设置界面，如下所示。

第八步、在这里根据实际连接情况设置串行口、波特率、数据位、停止位、校验方式(校验方式选择空校验)等几个参数，然后点击按钮“下一步”进入设备创建确认界面，如下图所示。

第九步、点击”完成“按钮，创建设备结束。

浙大中控无纸记录仪支持的标签类型

说明：NameID:CH
项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的表号)，取值范围是6-255。

项目符号

下表中CH表示仪表的通道号，即无纸记录仪的通道号。

项目符号

兰色、红色字表示格式中可变部分，十进制数表示。

例1：

计算机欲访问硬件表号为6、2号回路的无纸记录仪的的给定值，则在设备标签的定义中该标签的主地址应定义为‘Data6:2’，其中‘Data’指明访问的参数是给定值，‘6’对应开物2000中的设备表号，‘2’表示的是回路号(从1开始）)，冒号是规则要求，以区分表号和段号。

标签地址

对应的参数含义

         CH通道

标签值类型

标签值范围
DataID:CH | 实时数据 | R2000为多通道无纸记录仪，CH号即代表该无纸记录仪的通道号，通道号从1开始，取值范围视用户设定的通道数量而定。 | 模拟量 | -65535---65535
VSUMID：CH | 累积数据 | 模拟量 | -99999999999---4294967295

Spac ID:CH

记录间隔

模拟量

1---48

LLimit ID:CH | 量程下限 | 模拟量 | -65535---65535

HLimit ID:CH

量程上限

模拟量

-65535---65535

Pos ID:CH

小数点位置

模拟量

1---4

Now ID:CH

当前记录时间

文本量

PStart ID:CH

通道起始指针

模拟量

0---16777215

PEnd ID:CH

通道终止指针

模拟量

0----16777215

PNowID:CH

通道当前指针

模拟量

0---16777215

说明：回路号从1开始，如：Data表示实时数据，要读取表号为6，1号通道的实时数据，则标签的建立方式为Data6：1。