东辉DY2000系列仪表综述

仪表概述 硬件 设置 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

东辉DY2000系列仪表概述

福建东辉智能仪器有限公司专门从事工业过程自动化领域仪器仪表的研发和生产，是全国最早研发和批量生产智能仪表的企业之一。

开物2000系统支持以下类型的东辉DY2000系列仪表：

项目符号

DY2000-G：智能光柱显示仪表

项目符号

DY2000-T：智能位式控制数字/光柱显示仪表

项目符号

DY2000-B：智能变送控制数字/光柱显示仪表

项目符号

DY2000-A：智能自整定PID调节数字/光柱显示仪表

项目符号

DY2000-C：智能时间程序PID调节数字/光柱显示仪表

项目符号

DY2000-E：智能双输入控制数字/光柱显示仪表

项目符号

DY2000-D：智能多路巡检控制数字显示仪表

项目符号

DY2000-J：智能流量积算控制数字显示仪表

项目符号

DY2000-L：智能补偿式流量积算控制数字显示仪表

项目符号

DY2000-H：智能流量批量控制数字显示仪表

项目符号

DY2000-S：智能蒸汽热量控制数字显示仪表

项目符号

DY2000-P：智能脉冲输入变送控制数字/光柱显示仪表

项目符号

DY2000-W：智能热水热量积算数字显示仪表

项目符号

DY2000-X：智能阀门定位器

关于各种型号仪表的参数信息请参见 东辉仪表参数配置。

关于东辉DY2000系列仪表的更详细信息请访问 东辉公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

东辉DY2000系列仪表的硬件设置

东辉DY2000系列仪表有多种型号，在使用过程中请按照使用说明书设定好各个参数。

东辉DY2000系列仪表多采用RS485连接，多块仪表时清按下图连接终端电阻，约120欧姆。

波特率可选范围：1200baud，2400baud，4800baud和9600baud。

波特率

9600bps
起始位 | 1
数据位 | 8
停止位 | 1
校验位 | 无校验

在开物2000开发环境中创建设备

在开发环境的“硬件系统”中按照“新节点和设备向导”的指示配置所连接的 仪表。以便于开物2000识别和使用。

步骤1：选择”智能仪表“设备类型。双击“东辉智能仪表”，或单击选中“东辉智能仪表”，这里可以查看“驱动版本号”，更改设备名称， 如“DY2000” ，然后单击“选择”按钮。

步骤2：在”东辉智能仪表向导“中选择执行的操作方式——“新建设备”。选中“新建设备”后单击”下一步”按钮(或双击“新建设备”)，您也可以选择“修改设备”，对 仪表的配置进行修改或者选择“察看设备”浏览已经设置好的仪表配置情况。

其中下面的按钮的含义分别为：

下载最新驱动：可以帮助您进入开物技术支持网站的下载专区中；

帮助信息：可以查看驱动的版本等信息；

调试设置：通常情况下“调试开关”打开，这时可以记录开物的基本信息，主要包括启动和退出的时间，标签情况，通讯情况等信息；如果把“输出错误信息”和“输出跟踪信息”也选中的话，这时将记录开物运行过程中的全部通讯信息，对于记录通讯过程中的错误信息很有帮助，如果您在使用开物过程中，硬件连接有问题时，请打开所有调试开关，将通讯信息记录下来，待正常后，请您把“输出错误信息”和“输出跟踪信息”关闭。

注意：整个信息将存成LOG文件，在相应工程目录下面的“DEBUG”子目录下，文件名以驱动DLL文件加上日期时间的方式命名，如DY20002004-02-04-13-33-54.LOG。

步骤3：在"东辉IO仪表向导"中选择创建设备的方式——包括“单个 仪表创建”和“多个仪表创建”。其中：

单个仪表创建：指在一个设备中创建一块仪表；

多个仪表创建：指在一个设备中创建多个子仪表，当然您也可以建立多个设备从而实现多块 仪表的连接。

步骤4：在”东辉智能仪表向导“中选择仪表类型， 设置仪表设备号，若连接多块仪表可以选择“添加智能仪表”，若需要修改仪表的参数，可以先选中“设备配置图”中的设备，然后更改仪表类型和设备号，最后点击“修改智能仪表”；若需要删除多余的或错误的智能仪表，可以选择“删除智能仪表”。 其中：

仪表号：在RS485网络中仪表的站号，不允许重复。

仪表类型：指用户使用的仪表型号，通过下拉菜单选择；

步骤5：设置计算机的串口参数，主要包括串口、波特率、数据位、停止位、校验方式等。其中波特率、数据位、停止位、校验方式等参数一定与下位机完全相同。

步骤6：察看您建立的设备，没有问题，请点击“完成”按钮，如果有问题，可以点击“上一步”进行必要的修改。至此，整个设备建立完成。

标签的创建

使用“东辉智能仪表向导”完成仪表的创建后，可以进行标签设计。

1、在开发环境的“标签”击鼠标右键，选择“添加标签“，显示见下图，选择主设备为上面的‘DY2000，选择并填写‘主设备地址’，修改标签名。

东辉智能仪表驱动程序可以实现以下功能：读取仪表参数(双字节)、读取仪表参数(四字节)、读取仪表参数(六字节)、设置仪表参数(双字节)、设置仪表参数(四字节)、设置仪表参数(六字节)等功能。各部分功能在开物中对应的标签为：

RD1：读取仪表参数(双字节)

RD2：读取仪表参数(四字节)

RD3：读取仪表参数(六字节)

WR1：设置仪表参数(双字节)

WR2：设置仪表参数(四字节)

WR3：设置仪表参数(六字节)

在仪表类设备中，标签的配置规则为：标签+仪表号+“:”+通道号，如RD13:0、RD33:1、WR13:5；

2、根据您的特定使用需求，修改测量值和工程值的最大值、最小值、扫描周期等属性。单击‘添加’或‘完成’按钮。其中：

测量值最大值：设定为仪表当前量程的上限值；

测量值最小值：设定为仪表当前量程的下限值；

工程值最大值：设定为实际物理参数的上限值；

工程值最小值：设定为实际物理参数的下限值；

如：仪表的量程选择为：0 ～ 10V，对应现场的力信号为0 ～ 1000N，则测量值最大值设为 10；最小值设为 0；工程值最大值设为 1000；最小值设为 0。

请注意：假如只测量外界的电压信号则不需要更改测量值和工程值的最大值、 最小值，保持默认值就可以。

标签地址配置规则

标签地址可以按照下面的规则配置填写：

标签类型[ID:]Ch 或者 标签类型[ID:]Ch.BitAddr，其中BitAddr范围为0-15。

说明：

项目符号

ID指仪表号，用于识别 同一设备中的不同子仪表， 仪表号设定范围为0 ～ 127，十进制表示。

项目符号

Ch指通道号，范围根据 仪表类型不同，十进制表示。

项目符号 | 红色字表示格式中的可变部分，变化范围参见各种 仪表的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在“单个 仪表创建”时可省略。
项目符号 | 标签地址配置成不存在类型或仪表地址错误或通道号超出有效范围时，标签将不被承认， 不能读/写数据。

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

取决于仪表类型，请参阅相关帮助文件。

RD1ID:Ch.BitAddr

读取仪表参数(双字节)中的某一位 模拟量

只读

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

RD3D:Ch

读取仪表参数(六字节)

模拟量

只读

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

WR2ID:Ch

设置仪表参数(四字节)

模拟量

只写

WR3ID:Ch

设置仪表参数(六字节)

模拟量 只写

标签举例：(以多个 仪表创建为例，标签中包括仪表号)

标签 ：RD13:0
数据值类型：模拟量
描述 ：表示3号仪表的第0通道的参数输入值（双字节）

标签 ：RD23:6
数据值类型：模拟量
描述 ：表示3号仪表的第6通道的参数输入值（四字节）

标签 ：RD33:1
数据值类型：模拟量
描述 ：表示3号仪表的第1通道的参数输入值（六字节），主要指流量和热量。

标签 ：WR13:1
数据值类型：开关量
描述 ：设置3号仪表的第1通道的参数值（双字节）

其它标签如WR2、WR3留作扩展用，现在不支持。


东辉智能仪表参数配置

开物2000系统支持以下类型的东辉DY2000系列仪表：

项目符号 | DY2000-G：智能光柱显示仪表
项目符号 | DY2000-T：智能位式控制数字/光柱显示仪表
项目符号 | DY2000-B：智能变送控制数字/光柱显示仪表
项目符号 | DY2000-A：智能自整定PID调节数字/光柱显示仪表
项目符号 | DY2000-C：智能时间程序PID调节数字/光柱显示仪表
项目符号 | DY2000-E：智能双输入控制数字/光柱显示仪表
项目符号 | DY2000-D：智能多路巡检控制数字显示仪表
项目符号 | DY2000-J：智能流量积算控制数字显示仪表
项目符号 | DY2000-L：智能补偿式流量积算控制数字显示仪表
项目符号 | DY2000-H：智能流量批量控制数字显示仪表
项目符号 | DY2000-S：智能蒸汽热量控制数字显示仪表
项目符号 | DY2000-P：智能脉冲输入变送控制数字/光柱显示仪表
项目符号 | DY2000-W：智能热水热量积算数字显示仪表
项目符号 | DY2000-X：智能阀门定位器

详细信息请参见 东辉DY2000系列仪表综述

请注意：

对于读写属性为“只读”的标签应选用RD1、RD2、RD3标签，一般的参数是通过两个字节读上来的，需配置RD1标签；有极少数是通过四个字节读上来的，需配置RD2标签；对于一些流量和热量的参数会用到六个字节来读取，需配置RD3标签。需要说明的是，在配置标签时应该按照仪表的使用说明或者本帮助文件来配置，如果配置错误，由于不同标签数据格式的处理不相同，可能会导致读取的数据为错误数据。

对于读写属性为“只写”的标签应选用WR1标签，其它的写标签暂时不支持，只留作扩展。

1. DY2000-G：智能光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 8

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 5

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

各位的含义分别为：bit15 …bit7、bit6、bit5、bit4、 bit3、bit2、 bit1、 bit0

0、1： 小数点位置： 00 个位；01 十位；10 百位；11 千位

2：下限报警状态 ：0 无报警

3：上限报警状态：0 无报警

5：下溢状态 ：1 溢出

6：上溢状态 ：1 溢出

7：传感器断线：1断线

1

PV 过程值

只读

2

da 变送值

只读

3

Su-h 上限报警值

只读

4

Su-l 下限报警值

只读

5

Su-d 回差

只读

6

SCF 测量量程高端

只读

7

SCO 测量量程低端

只读

8

CLOCK 密码

只读

0

SU-h 上限报警值

只写

1

Su-l 下限报警值

只写

2

Su-d 回差

只写

3

SCF 测量量程高端

只写

4

SCO 测量量程低端

只写

5

CLOCK 密码

只写

2. DY2000-T：智能位式控制数字/光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 8

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 5

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

各位的含义分别为：bit15 …bit7、bit6、bit5、bit4、 bit3、bit2、 bit1、 bit0

0、1： 小数点位置： 00 个位；01 十位；10 百位；11 千位

2：下限报警状态 ：0 无报警

3：上限报警状态：0 无报警

5：下溢状态 ：1 溢出

6：上溢状态 ：1 溢出

7：传感器断线：1断线

1

PV 过程值

只读

2

da 变送值

只读

3

Su-h 上限报警值

只读

4

Su-l 下限报警值

只读

5

Su-d 回差

只读

6

SCF 测量量程高端

只读

7

SCO 测量量程低端

只读

8

CLOCK 密码

只读

0

SU-h 上限报警值

只写

1

Su-l 下限报警值

只写

2

Su-d 回差

只写

3

SCF 测量量程高端

只写

4

SCO 测量量程低端

只写

5

CLOCK 密码

只写

3. DY2000-B：智能变送控制数字/光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 8

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 5

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

各位的含义分别为：bit15 …bit7、bit6、bit5、bit4、 bit3、bit2、 bit1、 bit0

0、1： 小数点位置： 00 个位；01 十位；10 百位；11 千位

2：下限报警状态 ：0 无报警

3：上限报警状态：0 无报警

5：下溢状态 ：1 溢出

6：上溢状态 ：1 溢出

7：传感器断线：1断线

1

PV 过程值

只读

2

da 变送值

只读

3

Su-h 上限报警值

只读

4

Su-l 下限报警值

只读

5

Su-d 回差

只读

6

SCF 测量量程高端

只读

7

SCO 测量量程低端

只读

8

CLOCK 密码

只读

0

SU-h 上限报警值

只写

1

Su-l 下限报警值

只写

2

Su-d 回差

只写

3

SCF 测量量程高端

只写

4

SCO 测量量程低端

只写

5

CLOCK 密码

只写

4. DY2000-A：智能自整定PID调节数字/光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 16

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 14

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

各位的含义分别为：

bit15… bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位数： 00个位；01十位；10百位；11千位

2：下限报警状态：0无报警

3：上限报警状态：0无报警

4：手动/自动：1/手动；0/自动

5：下溢状态：1溢出

6：上溢状态：1溢出

7：传感器断线：1断线

8：上位机控制输出状态：1上位机控制输出；0由下位机控制输出

9：开始自整定状态：1开始自整定；0无自整定

10： 自整定结束状态： 1自整定结束；0无自整定

11：自整定结果：1自整定失败；0自整定成功

1

PV 过程值

只读

2

MV 阀位输出值

只读

3

SU

目标值

只读

4

Su-h 上限报警值

只读

5

Su-l

下限报警值

只读

6

Su-d 回差

只读

7

Pr 比例带

只读

8

ti

积分时间

只读

9

td

微分时间

只读

10

outb

传感器断线输出

只读

11

outh

输出上限值

只读

12

outl

输出下限值

只读

13

cdao

输出0时PV值

只读

14

SCF

测量量程高端

只读

15

SCO

测量量程低端

只读

16

CLOCK 密码

只读

0

MV 阀位输出值

只写

MV输入0-1000，表示PID输出1-100.0%。取消上位机控制值输入小于0数。

1

SU 目标值

只写

2

Su-h 上限报警值

只写

3

Su-l 下限报警值

只写

4

Su-d 回差

只写

5

Pr 比例带

只写

6

ti 积分时间

只写

7

td 微分时间

只写

8

outb 传感器断线输出值

只写

9

outh 输出上限值

只写

10

outl 输出下限值

只写

11

cdao 输出0时PV值

只写

12

SCF 测量量程高端

只写

13

SCO 测量量程低端

只写

14

CLOCK 密码

只写

5. DY2000-C智能时间程序PID调节数字/光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 33

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 31

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00 个位；01 十位；10 百位；11 千位

2：下限报警状态：0 无报警

3：上限报警状态： 0 无报警

4：手动/自动：1 手动；0 自动

5：下溢状态：1 溢出

6：上溢状态：1 溢出

7：传感器断线：1 断线

8：上位机控制输出状态：1 上位机控制输出；0 下位机控制输出

9：开始自整定状态：1 开始自整定；0 无自整定

10：自整定结束状态：1 自整定结束；0 无自整定

11：自整定结果：1 自整定失败；0 自整定成功

12：时间曲线运行状态：1 运行；0 暂停

13：自动延时跟踪状态： 1 自动延时跟踪状态：0 非跟踪状态

14：是否停止：1 停止；0 暂停

1

PV 过程值

只读

2

MV 阀位输出值

只读

3

SU

目标值

只读

4

(A,B........,H)

正在运行的区域(0,1,.......,7)

只读

5

N

正在运行的的段

只读

6

T

目前正在运行在该段的时间

只读

7

Pr 比例带

只读

8

ti

积分时间

只读

9

td

微分时间

只读

10

outb

传感器断线输出

只读

11

outh

输出上限值

只读

12

outl

输出下限值

只读

13

cdao

输出0时PV值

只读

14

SCF

测量量程高端

只读

15

SCO

测量量程低端

只读

16

CLOCK 密码

只读

17

(A,B........,H)

正在读写的区域(0,1,.......7)

只读

18

SU0

第一点目标值

只读

19

ST0 第一点时间值

只读

20

SU1

第二点目标值

只读

21

ST1 第二点时间值

只读

22

SU2

第三点目标值

只读

23

ST2 第三点时间值

只读

24

SU3

第四点目标值

只读

25

ST3 第四点时间值

只读

26

SU4

第五点目标值

只读

27

ST4 第五点时间值

只读

28

SU5

第六点目标值

只读

29

ST5 第六点时间值

只读

30

SU6

第七点目标值

只读

31

ST6 第七点时间值

只读

32

SU7

第八点目标值

只读

33

ST7 第八点时间值

只读

0

MV 调节输出值

只写

MV输入0-1000，表示PID输出1-100.0%。

1

运行状态

0x5353停止； 0x5352 运行； 0x5350 暂停

只写

10进制为21331停止；21330运行；21328暂停

2

(A,B........,H)

修改正在运行的区域(0,1,.......,7)

只写

3

N 修改正在运行区域的段

只写

4

T 修改正在运行的时间

只写

5

Pr 比例带

只写

6

ti 积分时间

只写

7

td 微分时间

只写

8

outb 传感器断线输出值

只写

9

outh 输出上限值

只写

10

outl 输出下限值

只写

11

cdao 输出0时PV值

只写

12

SCF 测量量程高端

只写

13

SCO 测量量程低端

只写

14

CLOCK 密码

只写

15

(A,B........,H)

修改读写运行的区域(0,1,.......,7)

只写

16

SU0

修改第一点目标值

只写

17

ST0 修改第一点时间值

只写

18

SU1

修改第二点目标值

只写

19

ST1 修改第二点时间值

只写

20

SU2

修改第三点目标值

只写

21

ST2 修改第三点时间值

只写

22

SU3

修改第四点目标值

只写

23

ST3 修改第四点时间值

只写

24

SU4

修改第五点目标值

只写

25

ST4 修改第五点时间值

只写

26

SU5

修改第六点目标值

只写

27

ST5 修改第六点时间值

只写

28

SU6

修改第七点目标值

只写

29

ST6 修改第七点时间值

只写

30

SU7

修改第八点目标值

只写

31

ST7 修改第八点时间值

只写

注意：用户如需修改某个区域中的段的目标值，必须先向仪表发送写指令（参数地址15），指定需修改的区域后，才能修改该区域的不同段目标目标值，以及时间值。用户如果需要查看不同区域的段的目标值和时间值时，也须先向仪表发送写指令（参数地址15）指定需要查看区域后，在发送读指令，才能查看该区域的8个目标值和时间值。区域中段的时间单位为分钟。用户向仪表发送“运行”指令（参数地址2），仪表将按照设定的曲线运行，如果用户在运行状态发送“暂停”指令，仪表将暂停曲线的运行，在向仪表发送“运行”指令，仪表将继续按照设定的曲线运行；如果用户发送“停止”指令，仪表将停止曲线的运行，直到用户发送“暂停”指令后，在发送“运行”指令后，仪表才能重新按照设定的曲线从头开始运行。

6. DY2000-E智能双输入控制数光柱数字/显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 16

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

1 ～ 10

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

1、0：B 路小数点位置：00个位；01十位；10百位；11千位

2：B 路第一报警状态：0无报警

3：B 路第二报警状态：0无报警

5：B 路下限溢出：1溢出

6：B 路上限溢出：1溢出

7：B 路断线“1断线

8、9：A 路小数点位置：00个位；01十位；10百位；11千位

10：A 路第一报警状态：0无报警

11：A 路第二报警状态：0无报警

13：A 路下限溢出：1溢出

14：A 路上限溢出：1溢出

15：A 路断线：1断线

1

PVA A路测量值

只读

2

PVB

B路测量值

只读

3

PVA-PVB

A路与 B路的差值

只读

4

daA

A路变送值

只读

5

daB

B路变送值

只读

6

ALA1

A路第一报警值

只读

7

ALA2 A路第二报警值

只读

8

ALAd

A路报警回差值

只读

9

ALB1

B路第一报警值

只读

10

ALB2

B路第二报警值

只读

11

ALBd

B路报警回差值

只读

12

SCA0

A路显示值低端

只读

13

SCAF

A路显示值高端

只读

14

SCB0

B路显示值低端

只读

15

SCBF

B 路显示值高端

只读

16

Key

密码

只读

1

ALA1

A路第一报警值

只写

2

ALA2 A路第二报警值

只写

3

ALAd

A路报警回差值

只写

4

ALB1

B路第一报警值

只写

5

ALB2

B路第二报警值

只写

6

ALBd

B路报警回差值

只写

7

SCA0

A路显示值低端

只写

8

SCAF

A路显示值高端

只写

9

SCB0

B路显示值低端

只写

10

SCBF

B 路显示值高端

只写

11

Key

密码

只写

7. DY2000-D：智能多路巡检控制数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 31

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

不存在

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PV1 第1路过程值

只读

1

PV2 第2路过程值

只读

2

PV3 第3路过程值

只读

3

PV4 第4路过程值

只读

4

PV5 第5路过程值

只读

5

PV6 第6路过程值

只读

6

PV7 第7路过程值

只读

7

PV8 第8路过程值

只读

8

PV9 第9路过程值

只读

9

PV10 第10路过程值

只读

10

PV11 第11路过程值

只读

11

PV12 第12路过程值

只读

12

PV13 第13路过程值

只读

13

PV14 第14路过程值

只读

14

PV15 第15路过程值

只读

15

PV16 第16路过程值

只读

16

PSW1 第1路状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00个位；01十位；10百位；11千位

2：下限报警状态：0无报警

3：上限报警状态：0无报警

4：测量方式：1定点；0巡回

5：下溢状态：1溢出

6：上溢状态：1溢出

7：是否断偶：1：断偶（阻型、偶型）

（8-15）：通道屏蔽位 0：未屏蔽

17

PSW2 第2路状态字

只读

18

PSW3 第3路状态字

只读

19

PSW4 第4路状态字

只读

20

PSW5 第5路状态字

只读

21

PSW6 第6路状态字

只读

22

PSW7 第7路状态字

只读

23

PSW8 第8路状态字

只读

24

PSW9 第9路状态字

只读

25

PSW10 第10路状态字

只读

26

PSW1 1 第11路状态字

只读

27

PSW1 2 第12路状态字

只读

28

PSW1 3 第13路状态字

只读

29

PSW14 第14路状态字

只读

30

PSW15 第15路状态字

只读

31

PSW16 第16路状态字

只读

8. DY2000-J智能流量积算控制数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 12

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

1

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 7

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00个位；01十位；10百位；11千位

2：下限报警状态：0无报警

3：上限报警状态：0无报警

7：传感器断线：1断线

1

To-H

积算值高字节(BCD)

只读

可以通过 RD3来读取，通道数为1

2

To-M 积算值中字节(BCD)

只读

3

To-l 积算值低字节(BCD)

只读

4

PV

瞬时流量

只读

5

da

变送值

只读

6

SU-h

上限设定

只读

7

SU-l

下限设定

只读

8

SU-d

回差

只读

9

qs

开方小信号切除值

只读

10

SCF

测量量程高端

只读

11

SCO

测量量程低端

只读

12

Key

密码

只读

0 CLr 清零 只写 Clr输入清零码十六进制43HEX（10进制67）积算值清零。

1

SU-H

上限设定

只写

2

SU-L

下限设定

只写

3

SU-d

回差

只写

4

sq

开方小信号切除值

只写

5

SCF

测量量程高端

只写

6

SCO

测量量程低端

只写

7

Password

密码

只写

9. DY2000-L智能补偿式流量积算控制数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 11

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

1

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

8 ～ 12

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00个位；01十位；10百位；11千位

2：Out2

3：Out1

4：溢出标志：1溢出

7：流量传感器断线：1断线

8：压力传感器断线：1断线

9：温度传感器断线：1断线

1

To-H

积算值高字节(BCD)

只读

可以通过 RD3来读取，通道数为1

2

To-M 积算值中字节(BCD)

只读

3

To-l 积算值低字节(BCD)

只读

4

PV

瞬时流量

只读

5

da

变送值

只读

6

P 压力

只读

7

T 温度

只读

8

SU-h

上限设定

只读

9

SU-l

下限设定

只读

10

SU-d

回差

只读

11

Key

密码

只读

8

SU-h

上限设定

只写

9

SU-l

下限设定

只写

10

SU-d

回差

只写

11

Key

密码

只写

12 Clr 积算值信号 只写

Clr输入清零码十六进制43HEX（10进制67）积算值清零。

10. DY2000-H：智能流量批量控制数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 16

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

6、8

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

1

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 12

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00个位；01十位；10百位；11千位

2：Out2

3：Out1

4：溢出标志：1溢出

7：流量传感器断线：1断线

1

To-H

积算值高字节(BCD)

只读

可以通过 RD3来读取，通道数为1

2

To-M 积算值中字节(BCD)

只读

3

To-l 积算值低字节(BCD)

只读

4

PV

瞬时流量

只读

5

da

变送值

只读

6

SU-1H

高字节

只读

可以通过 RD2来读取，通道数为6

7

SU-1L

中字节、低字节

只读

8

SU-2H

高字节

只读

可以通过 RD2来读取，通道数为8

9

SU-2L

中字节、低字节

只读

10

SU-d

回差

只读

11

sp

小信号切除

只读

12

SCF

测量量程高端

只读

13

SC0

测量量程低端

只读

14

K

K系数

只读

15

Point

K系数小数点位置

只读

16

Key

密码

只读

0 CLr1 总积算值清零 只写 Clr输入清零码十六进制43HEX（10进制67）积算值清零。

1

SU-1H

高字节

只写

2

SU-1L

中字节、低字节

只写

3

SU-2H

高字节

只写

4

SU-2L

中字节、低字节

只写

5

SU-d

回差

只写

6

sp

小信号切除

只写

7

SCF

测量量程高端

只写

8

SC0

测量量程低端

只写

9

K

K系数

只写

10

Point

K系数小数点位置

只写

11

Key

密码

只写

12

CLr2

批量清零

只写

输入清零码十六进制"4350"HEX （10进制为17232）批量清零

11. DY2000-S智能蒸汽热量控制数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 18

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

1、5

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 7

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置 00个位；01十位；10百位；11千位

2：Out2

3：Out1

4：溢出标志：1：溢出

7：流量传感器断线：1断线

8：压力传感器断线：1断线

9：温度传感器断线：1断线

1

To-H

质量累积值高字节(BCD)

只读

可以通过 RD3来读取，通道数为1

2

To-M 质量累积值中字节(BCD)

只读

3

To-L 质量累积值低字节(BCD)

只读

4

PV

瞬时质量流量

只读

5

hTO-H

热量累积值高2位(BCD)

只读

可以通过 RD3来读取，通道数为5

6

hTO-M

热量累积值中2位(BCD)

只读

7

hTO-L

热量累积值低2位(BCD)

只读

8

hPV

热量瞬时流量

只读

9

P

压力

只读

10

T

温度

只读

11

da

变送值

只读

12

SU-H

上限报警值

只读

13

SU-L

下限报警值

只读

14

SU-d

回差

只读

15

sq

小信号切除

只读

16

Poin

K系数小数点位置

只读

17

K

K系数

只读

18

Password

密码

只读

0 CLr 清零 只写 Clr输入清零码十六进制43HEX（10进制67）积算值清零。

1

SU-H

上限报警值

只写

2

SU-L

下限报警值

只写

3

SU-d

回差

只写

4

sq

小信号切除

只写

5

Poin

K系数小数点位置

只写

6

K

K系数

只写

7

Key

密码

只写

12. DY2000-P智能脉冲输入变送控制数字/光柱显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 8

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 5

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置：00 个位；01 十位；10 百位；11 千位

2：下限报警状态：0 无报警

3：上限报警状态：0 无报警

1

PV 过程值

只读

2

da 变送值

只读

3

Su-h 上限报警值

只读

4

Su-l 下限报警值

只读

5

Su-d 回差

只读

6

SCF 测量量程高端

只读

7

SCO 测量量程低端

只读

8

CLOCK 密码

只读

0

SU-h 上限报警值

只写

1

Su-l 下限报警值

只写

2

Su-d 回差

只写

3

SCF 测量量程高端

只写

4

SCO 测量量程低端

只写

5

CLOCK 密码

只写

13. DY2000-W智能热水热量积算数字显示仪表 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 18

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

1、5

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 7

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

bit15…bit7、bit6、bit5、bit4、bit3、bit2、bit1、bit0

0、1：小数点位置 00个位；01十位；10百位；11千位

2：下限报警状态：0无报警

3：上限报警状态：0无报警

8：出水温度断线：1断线

9：进水温度断线：1断线

7：流量信号：1断线

1

To-H

热水流量积算值高字节(BCD)

只读

可以通过 RD3来读取，通道数为1

2

To-M 热水流量积算值中字节(BCD)

只读

3

To-L 热水流量积算值低字节(BCD)

只读

4

PV

热水流量瞬时流量

只读

5

hTO-H

热水热量积算值高2位(BCD)

只读

可以通过 RD3来读取，通道数为5

6

hTO-M

热水热量积算值中2位(BCD)

只读

7

hTO-L

热水热量积算值低2位(BCD)

只读

8

hPV

热水热量瞬时流量

只读

9

T1

进水温度

只读

10

T2

出水温度

只读

11

da

变送值

只读

12

AL1

第一报警值

只读

13

AL2

第二报警值

只读

14

AL-d

报警回差值

只读

15

sq

小信号切除

只读

16

K

K系数

只读

17

Poin

k系数小数点位置

只读

18

Password

密码

只读

0 CLr 清零 只写 Clr输入清零码十六进制43HEX（10进制67）积算值清零。

1

AL1

第一报警值

只写

2

AL2

第二报警值

只写

3

AL-d

报警回差值

只写

4

sq

小信号切除

只写

5

K

K系数

只写

6

Poin

k系数小数点位置

只写

7

Password

密码

只写

14. DY2000-X智能阀门定位器 返回

其参数配置分别为：

标签信息表

标签地址

含义

数据类型

读写类型

标签值范围

RD1ID:Ch

读取仪表参数(双字节)

模拟量

只读

0 ～ 6

RD2ID:Ch

读取仪表参数(四字节)

模拟量

只读

不存在

RD3ID:Ch

读取仪表参数(六字节)

模拟量

只读

不存在

WR1ID:Ch

设置仪表参数(双字节)

模拟量

只写

0 ～ 4

WR 2ID:Ch

设置仪表参数(四字节)

模拟量

只写

不存在

WR3ID:Ch

设置仪表参数(六字节)

模拟量

只写

不存在

参数信息表

参数号

参数名

参数含义

读写类型

备注

0

PSW

状态字

只读

各位的含义分别为：bit15 …bit7、bit6、bit5、bit4、 bit3、bit2、 bit1、 bit0

0、1： 小数点位置： 00个位；01十位；10百位；11千位

4：1 手动；0自动

5：上位机控制：1上位机控制

6：反馈信号断线：1 断线

7：信号断线：1断线

1

PV 1 控制信号

只读

2

PV 2 阀位反馈信号

只读

3

SD

不灵敏区

只读

4

SU-H

上限报警值

只读

5

SU-L

下限报警值

只读

6

Password

密码

只读

0

PV 1 上位机直接输入控制信号

只写

1

SD

不灵敏区

只写

2

SU-H

上限报警值

只写

3

SU-L

下限报警值

只写

4

Password

密码

只写