三一重工CAN配料仪表

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供对三一重工CAN配料仪表的支持，CAN总线选用周立功CAN卡，在使用前请确认 已经安装了周立功CAN卡的驱动程序，并通过测试程序测试。

仪表通讯参数

通讯采用CAN标准；

波特率： 请根据具体情况选择 ；

地址：可选范围为0～32，十进制；

标签说明

项目符号 | 下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。
项目符号 | 红色字表示格式中设备号，十进制数表示。
项目符号 | 注:此处仪表中的通信地址以10进制表示。
标签地址 | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
POWER ID:CH | 启动|暂停|停止控制 | 模拟量 | 只写 | CH=0 | 1：启动；2：暂停；3：停止。
RECEIPE ID:CH1.CH2 | 读取|设置配方信息 | 模拟量 | 读写 | CH1对应0-3种物料.CH2对应该物料的三个参数[0为目标重量；1为慢加料重量；2：提前量]，如读写物料0的提前量，则配置为 RECEIPE ID:0.2。 | -99999999-99999999
SAVE ID:CH | 存储设置 | 开关量 | 只写 | CH=0 | 为TRUE时，进行数据存储操作
STS ID:CH1.CH2 | 读取系统状态信息 | 模拟量 | 只读 | 对于CH1等于1-6或8-11的标签没有CH2项，对于CH1等于7的，则CH2对应1-4[分别对应DT1-DT4]。详细信息见相关文档，如STSID：9代表当前物料2的实际配料值。 | -99999999-99999999
PARMID:CH1.CH2 | 读取|设置仪表参数 | 模拟量 | 读写 | CH1.CH2对应X.Y，如参数3.2，则配置为PARMID:3.2。 | -99999999-99999999

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：POWER 1:0
数据值类型：模拟量
描述 ：表示控制1号设备启停。

标签 ：RECEIPE 1:0.2
数据值类型：模拟量
描述 ：表示读写1号设备物料0的提前量。

标签 ：SAVE1:0
数据值类型：开关量
描述 ：当标签值为TRUE时表示将设备修改过的参数、信息等写入EEPROM。

标签 ：PARM1:3.2
数据值类型：模拟量
描述 ：读写参数F3.2。

标签 ：STS 1:9
数据值类型：模拟量
描述 ：代表当前物料2的实际配料值。