艾默生TD_EV系列变频器

艾默生变频器参数设置说明

艾默生变频器 概述 设备 说明 标签使用举例 在线升级驱动

EV1000采用独特的控制方式实现了高转矩、高精度、宽调速驱动，满足通用变频器高性能化的需求：具有超出同类产品的防跳闸性能和适应恶劣电网\温度、湿度、和粉尘的能力 ，极大提高产品可靠性。通过优化PWM控制技术和电磁兼容性整体设计，满足用户对应用场所的低噪音、低电磁干扰的环保要求。

标签使用举例

计算机欲访问设备地址为1的艾默生变频器，且设备的虚拟地址也设为1的情况下，则在设备标签的定义中该标签的主地址应定义为‘SF1:0’，其中‘SF’指明访问的参数是“读取功能码参数”，‘1’对应开物2000中的设备表号(即虚拟地址)，0对应通道号，冒号是规则要求，以区分设备号和通道号。

说明：
项目符号

下表中ID指变频器的设备号(开物2000设备向导中的表号)，取值范围是1-127。

项目符号

根据协议，DO标签可读可写，格式为DO[ID]:CH，其中ID代表该变频器的地址，CH代表该标签所对应的命令号，命令号列表见下表 。

艾默生变频器在使用过程中一定要注意标签的配置规则。

在建立标签过程中，设备号和通道号统一采用十进制 ，如果说明书中使用的是十六进制，应该进行进制转换。

表1

参数 | 参数含义 | 通道设备范围 | 备注
POWER | 控制从机开/关机 | 0 | 常用设置，输入0为开机，7为停机。需更多设置参考POWER具体说明
RS | 查询从机状态 | 0 | 返回状态为一数值，具体含义见表2
MR | 查询从机参数 | 0--13，20 | 存在返回值比所需值大100倍的问题，解决方案请查阅“常见问题”
CR | 运行控制与调节功能 | 0--14，19--23 | 存在设置值比所需值小100倍的问题，解决方案请查阅"常见问题"
RF | 读取功能码参数(过渡性支持) | 1，3，9，10，102，108 | 存在返回值比所需值大100倍的问题，解决方案请查阅"常见问题"
SF | 设置功能码参数(过渡性支持) | 1，3，9，10，102，108 | 存在设置值比所需值小100倍的问题，解决方案请查阅"常见问题"
CQ | 配置从机响应类型 | 0 | 输入范围0--7
CommErr | 显示设备错误代码 | 0 | 具体错误信息参见表3
Ver | 查询从机设备系列号和软件版本号 | 1 | 返回值说明请参见具体说明书
F0_..Fp_ | 设置从机功能码参数 | 可读/可写(注1) | 具体设置方式见(注2)

注1：

F0_..Fp_的ID值设定请参见设备用户手册上附录里“功能参数简表”，F0_对应“F0组”，F1_对应“F1组”依此类推。

如F0_[ID]:00，即表示F0组里的功能码F0.00，即为“频给定通道选择”。

注2：

功能码设定给出了两种方式，第一次就是将设写的值写入EP2ROM，EP2ROM读写十万次后会坏掉 ，掉电后不会丢失数据；另一种方式是不写入EP2ROM，掉电后会丢失数据。

如果需要写入EP2ROM时，标签配置只需按普通配置，即F0_[ID]:CH，如果不需要把值写入EP2ROM时，需要在配置标签时加入一个.E，即F0_[ID]:CH.E。例： 标签设制为：F0_0:0.E 即在设定“频率给定通道选择”时不将设定的值写入EP2ROM中 ，掉电后数据就不会保存。

表2：RS标签返回值所代表的从机状态：

表3：CommErr标签返回值所代表的从机状态 ：

具体实例

ID值即为设备地址，具体情况跟硬件的设制有关。

标签 ：POWERID:0
数据值类型：模拟量
描述 ：表示设备号为1的变频器的控制开关，可读/可写。通道(CH)只能设为0，通过写入的数值来控制不同的状态。

具体输入值的含义：

输入值 | 含义
0 | 从机开机
3 | 从机正转开机
4 | 从机反转开机
7 | 从机停机
8 | 从机点动运行
9 | 从机正转点动运行
10 | 从机反转点动运行
11 | 从机停止点动运行
12 | 从机故障复位
13 | 从机自由停车
14 | 从机紧急停车

注：如果输入的值不在以上范围内，系统将会默认为7，即从机停机。

具体功能同CR标签，但只支持CR里面的开关量，对模拟量无效。见注1

标签 ：RSID:0
数据值类型：模拟量
描述 ：返回设备的当前状态 ，通道(CH)只能设为0。返回值所对应的状态见表2。

标签 ：MRID:CH
数据值类型：模拟量
描述 ：返回从机参数，并可对从机参数进行调节。 具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
0 | 当前运行频率 | 无
1 | 当前设定频率 | 无
2 | 输出电压 | 无
3 | 输出电流 | 无
4 | 无单位显示量 | 无
5 | 设定转速 | 无
6 | 运行线速度 | 无
7 | 设定线速度 | 无
8 | 模拟闭环控制功能的闭环反馈 | 无
9 | 模拟闭环控制功能的闭环设定 | 无
10 | 外部计数值 | 无
11 | 输出矩阵 | 无
12 | I/O状态 | 无
13 | 当前状态 | 无
20 | 补偿后运行频率 | 无

标签 ：CRID:CH
数据值类型：模拟量
描述 ：控制运行状态，并可对运行状态进行调节与控制。 具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
0 | 从机开机 | 无
1 | 设置从机当前运行频率给定 | 0Hz～上限频率
2 | 从机开机带运行频率给定 | 0Hz～上限频率
3 | 从机正转开机 | 无
4 | 从机反转开机 | 无
5 | 从机正转开机带运行频率给定 | 0Hz～上限频率
6 | 从机反转开机带支行频率给定 | 0Hz～上限频率
7 | 从机停机 | 无
8 | 从机点动运行 | 无
9 | 从机正转点动运行 | 无
10 | 从机反转点动运行 | 无
11 | 从机停止点动运行 | 无
12 | 从机故障复位 | 无
13 | 从机自由停机 | 无
14 | 从机紧急停机 | 无
19 | 设置模拟输出AO1的比例值 | 0～FFFF
20 | 设置模拟输出AO2的比例值 | 0～FFFF
21 | 设置数字输出Y2的比例值 | 0～FFFF
22 | 频率的比例值(保留) | 0～7D0
23 | 设置虚拟控制端子状态 | 0～FFFF

标签 ：RFID:CH
数据值类型：模拟量
描述 ：读取功能码参数(过渡性支持)。 具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
1 | 运行频率数字设定 F0.02 | 无
3 | 运转方向设定 F0.04 | 无
9 | 加速时间1 F0.10 | 无
10 | 减速时间1 F0.11 | 无
102 | 给定量数字设定 F5.05 | 无
108 | 速度闭环给定 F5.06 | 无

标签 ：SFID:CH
数据值类型：模拟量
描述 ：设置功能码参数(过渡性支持)。 具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
1 | 运行频率数字设定 F0.02 | 0～上限频率
3 | 运转方向设定 F0.04 | 0、1
9 | 加速时间1 F0.10 | 0～8CA0
10 | 减速时间1 F0.11 | 0～8CA0
102 | 给定量数字设定 F5.05 | 0～03E8
108 | 速度闭环给定 F5.06 | 0～03E8

标签 ：CQID:0
数据值类型：模拟量
描述 ：配置从机响应类型，通道号只能设为0。 具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
0 | 配置从机响应类型 | 0～7

标签 ：VerID:1
数据值类型：模拟量
描述 ：查询从机设备系列和软件版本号 ，通道号只能设为1。具体通道(CH)含义见下表。

标签所设通道号 | 含义 | 运行数据设定范围
1 | 查询从机设备系列和软件版本号 | 无

标签 ：CommErrID:0
数据值类型：模拟量
描述 ：返回设备错误状态。通道(CH)只能设置为0，根据不同设备的设备号(ID)返回不同设备的错误状态。 具体返回值见 表3

标签 ：F0_ID:CH～Fp_ID:CH
数据值类型：模拟量
描述 ：设置功能码参数 。具体通道设制（CH）请查阅硬件说明书上的附表1里面的内容。查询格式为F0_[ID]:00对应附表中的F0.00，F5_[ID]:01对应附表中的F5.01。