日立变频器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 常见问题 在线升级驱动

概述

硬件连接

通讯接线使用RS485连接方式。 具体接线如下图所示：

DATA+ | SP
DATA- | SN

注 ：通过RS485方式通讯，最后一台变频器的TN与TP端子需短接，如果连接一台变频器，两端子同样需要短接。

默认通讯参数设置如下：

波特率 | 4800bps
数据位 | 7
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的变频器。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置变频器类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成变频器的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据变频器的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]

说明：

  • ID指变频器的站号地址，用于识别设备中的变频器， 变频器的站号地址以十进制表示，地址设定范围为1～32。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

  • Ch指的是 变频器的参数地址。 地址范围见参数对照表。十进制表示。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

FreqID:

频率显示(HZ)

模拟量

只读

0------999999

SetFreqID:

频率设定(HZ)

模拟量

只写

0------999999

SetRunModeID:

设定运行模式

模拟量

只写

0：停止

1：正转

2：反转

ResetID:

复位

模拟量

只写

True

StatusAID:

变频器状态A

模拟量

只读

见附图一

StatusBID:

变频器状态B

模拟量

只读

见附图一

StatusCID:

变频器状态C

模拟量

只读

见附图一

OutCur ID:

输出电流(A)

模拟量

只读

0～99999999

OutVolt ID:

输出电压(V)

模拟量

只读

0～99999999

OutP ID:

输出功率(KW)

模拟量

只读

0～99999999

OutM ID:

输出转矩

模拟量

只读

0～99999999

RunMode ID:

变频器模式设定

模拟量

可读可写

0：停止

1：正转

2：反转

RunTime ID:

运行时间(小时)

模拟量

只读

0～99999999

OnTime ID:

上电时间(小时)

模拟量

只读

0～99999999

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

标签举例

标签 ：Freq 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只读）

标签 ：SetFreq 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 ：SetRunMode 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 ：Reset 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 ：StatusA 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态A

标签 ：StatusB 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态B

标签 ：StatusC 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态C

标签 ：OutCur 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出电流

标签 ：OutVolt 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出电压

标签 ：OutP 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出功率

标签 ：OutM 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出转矩

标签 ：RunMode 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的模式设定

标签 ：RunTime 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的运行时间

标签 ：OnTime 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的上电时间

标签 ：DeviceLink 1:
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器与开物2000通讯的连接状态

常见问题

1、与开物2000进行连接，变频器需要设置的一些参数？

答：与开物通讯之前需要对变频器进行初始化，设定A002=03,C070=2,A001=03,然后在设置相应串口参数，以上设定后便可与开物2000进行通

讯。（注：与开物通讯的时候，PRG指示灯亮）

附图一

变频器状态A

变频器状态B 变频器状态C

0

初始状态

0

停止中

0

--------------

1

VDC确立中

1

运行中

1

停止

2

停止中

2

跳闸中

2

减速

3

运行中

3

恒速

4

在FRS中

4

加速

5

在JG中

5

正转

6

在DB中

6

反转

7

匹配频率中

7

从正转到反转

8

重试中

8

从反转到正转

9

在UV中

9

正转起动

10

跳闸中

10

反转起动

11

等待复位中