惠丰变频器

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供对惠丰变频器的支持， 在使用前请先确认各种型号变频器的通讯支持情况，如对于自由停车来说F1000变频器是不支持的。

仪表通讯参数

通讯格式为：1 位启始位，8位数据位，1 位停止位， 校验方式请参照说明书；

通讯采用RS485标准；

波特率：1200,2400,4800,9600,19200可选 ；

地址：可选范围为1～255，十进制；255为广播地址。

标签说明

项目符号

下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。

项目符号

红色字表示格式中设备号，十进制数表示 ，蓝色部分表示地址号，十进制表示。

项目符号

注:此处仪表中的通信地址以10进制表示。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

POWER_PARM_DIR ID:CH

设置带参数运行中的运转方向

模拟量

只写

0 0：正转；1：反转

POWER_PARM_ACC ID:CH

设置带参数运行中的加速时间

模拟量

只写

0

0-65535

POWER_PARM_RUN_DEC ID:CH

设置带参数运行中的减速时间

模拟量

只写

0

0-65535

POWER_PARM_STOP_DEC ID:CH

设置带参数停机中的减速时间

模拟量

只写

0

0-65535

POWER_PARM_FRE ID:CH

设置带参数运行中的运行频率

模拟量

只写

0

0-65535

POWER_PARMID:CH

带参数运行|停止控制

开关量

只写

0

0/1[true/false]，在控制带参数运行时，请设定相关参数，包括 POWER_PARM_DIR、POWER_PARM_ACC、POWER_PARM_DEC和POWER_PARM_FRE。

MOTER_PARMID:CH

读取电机参数

模拟量

只写

0：输出电压；
1：输出电流；
2：输出频率；
3：当前转速；
4：当前线速度；
5：运行方向[0：正1：反]

0-65535

FUNC_PARMID:CH

读取|设置功能码参数

模拟量

读写

参照说明书

0-65535

POWER_JOG_DIR ID:CH

设置点动运行方向

模拟量

只写

0 0：正转；1：反转

POWER_JOG ID:CH

设置点动运行

开关量

只写

0

0/1[true/false]，在控制点动运行时，请设定相关参数，包括POWER_JOG_DIR。

POWER ID:CH

无参数运行|停止

开关量

只写

0

0/1[true/false]

STOP_FREE ID:CH

自由停车

开关量

只写

0

0/1[true/false]，当为true时故障复位；false时不动作。

RESET ID:CH

故障复位

开关量

只写

0

0/1[true/false]，当为true时故障复位；false时不动作。

ERR ID:CH

读取故障信息

模拟量

只读

0

见说明1

COMMLINK ID:CH

总线线路通讯状况 模拟量 只读 无 0=通讯始终不成功；1=通讯正常；3=通讯出现故障

DEVICELINK ID:CH

各子设备线路通讯状况

模拟量 只读 0

说明1：对于ERR标签的数据和故障对应关系为：0 为无故障；1： /* OC */ ；2： /* OE */ ；3： /* OH */ ；4： /* PF */ ；5： /* OL */ ；6： /* PO */ ；7： /* HH */ ；11： 加速过流OC1；12： 减速过流OC2；13： 恒速过流OC3；14： 加速过压OE1；15： 减速过压OE2；16： 恒速过压OE3；17： 欠压 LU；19：变频器过载OL1；20：电机过载 OL2；21： 过温 OH；23： 缺相 PEr；25：紧急停机ESP；29： 电流检测故障AdEr；31： 用户外部故障；其他值为不可预测的故障类型。

注意：对于各种标签的工程值和测量值的设定，请参阅相关说明书，如对于频率需要将测量值设定为相应工程值的100倍，加速时间和减速时间需要将测量值设定为相应工程值的10倍，等等。

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：POWER_PARM_DIR 1:0
数据值类型：模拟量
描述 ：表示设置1号变频器带参数运行中的运转方向。

标签 ：POWER_PARM_FRE1:0
数据值类型：模拟量
描述 ：表示设置1号变频器带参数运行中的运转频率。

标签 ：MOTER_PARM1:2
数据值类型：模拟量
描述 ：表示读取1号变频器电机参数中的输出频率。