康沃变频器

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供对康沃变频器的支持，在使用前请先确认各种型号变频器的通讯支持情况。

仪表通讯参数

通讯格式为：1 位启始位，8位数据位，1 位停止位， 校验方式可选，请参照说明书；

通讯采用RS485标准；

波特率：1200,2400,4800,9600,19200可选 ；

地址：可选范围为1～30，十进制；31为广播地址。

标签说明

项目符号 | 下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。
项目符号 | 红色字表示格式中设备号，十进制数表示。
项目符号 | 注:此处仪表中的通信地址以10进制表示。
标签地址 | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
POWER_FRE ID:CH | 启停控制中相关频率，在进行启动控制时，请设定此频率。 | 模拟量 | 只写 | 0 | 0-65535
POWER ID:CH | 启停控制 | 模拟量 | 只写 | 0 | 见说明1
FRE_OUTPUT ID:CH | 读取输出频率 | 模拟量 | 只读 | 0 | 0-65535
STS ID:CH | 读取变频器状态 | 开关量 | 只读 | 0-15 | TRUE/FALSE
PARMID:CH | 读取|设置功能码参数 | 模拟量 | 读写 | 0-255，即功能参数一览表中的编码地址，10进制。 | 0-65535
COMMLINK ID:CH | 总线线路通讯状况 | 模拟量 | 只读 | 无 | 0=通讯始终不成功；1=通讯正常；3=通讯出现故障
DEVICELINK ID:CH | 各子设备线路通讯状况 | 模拟量 | 只读 | 0 |

说明1： 对于这个标签需要通过设定不同的数据来实现其启停的控制，标签数值的对应关系见下表：如正转运行为12（16进制），即18，（BIT1=1，BIT4=1，其他为0）；反转运行14（16进制），即20。自由停机为272；正转点动为16400；反转点动为32784；故障复位为24。

数据位 | 含义 | 数据说明
0 | 保留 |
1 | 正转运行 | 1：向从机(变频器)下达正转运行指令 0：无效
2 | 反转运行 | 1：向从机(变频器)下达反转运行指令 0：无效
3 | 故障复位 | 1：进行故障复位0：无效
4 | 主站控制有效 | 1：当前数据帧中的控制字与设定值更新旧数据，若要完成本次控制任务必须置此位。 0：当前数据帧中的控制字与设定值无效，变频器保持前一次的控制字和设定值。
5 | 保留 |
6 | 保留 |
7 | 保留 |
8 | 自由停机 | 1：向从机(变频器)下达自由停机指令 0：无效
9 | 保留 |
10 | 保留 |
11 | 保留 |
12 | 保留 |
13 | 保留 |
14 | 正转点动 | 1：向从机(变频器)下达正转点动指令 0：无效
15 | 反转点动 | 1：向从机(变频器)下达反转点动指令 0：无效

说明2：

通道号 | 含 义 | 标签数值
0 | 直流电压状态 | 1：直流电压正常；0：直流电压异常
1 | 电机转向 | 1：电机反转；0：电机正转
2 | 输出相序 | 1：反相序； 0：正相序
3 | 系统故障 | 1：变频器故障；0：变频器正常
4 | 工作状态 | 1：变频器运行过程中；0：变频器停机
5 | 故障试恢复等待 | 1：变频器正在故障试恢复等待中 0：变频器不在故障试恢复等待中
6 | 保留 |
7 | 直流制动 | 1：变频器正在进行直流制动 0：变频器不在直流制动状态
8 | 自由停机 | 1：变频器在自由停机状态 0：变频器不在自由停机状态
9 | 检速再启动 | 1：变频器正在进行检速再启动 0：变频器不在进行检速再启动
10 | 加速过程中 | 1：变频器正在加速过程中 0：变频器不在加速过程中
11 | 减速过程中 | 1：变频器正在减速过程中 0：变频器不在减速过程中
12 | 电流限制动作 | 1：变频器限制电流功能动作 0：变频器限制电流功能不动作
13 | 电压限制动作 | 1：变频器限制电压功能动作 0：变频器限制电压功能不动作
14 | 点动运行 | 1：变频器在点动运行状态 0：变频器不在点动运行状态
15 | 瞬时停机再启动等待 | 1：变频器在瞬时停机再启动等待状态 0：变频器不在瞬时停机再启动等待状态

注意：对于各种标签的工程值和测量值的设定，请参阅相关说明书，如对于频率需要将测量值设定为相应工程值的100倍，等等。

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：POWER_FRE 1:0
数据值类型：模拟量
描述 ：表示配合POWER标签使用时需要设定的频率数据。

标签 ：POWER 1:0
数据值类型：模拟量
描述 ：表示控制1号变频器启停。

标签 ：FRE_OUTPUT1:0
数据值类型：模拟量
描述 ：表示读取1号变频器输出频率。

标签 ：STS 1:2
数据值类型：开关量
描述 ：表示读取1号变频器的状态2，即输出相序。