富士变频器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 常见问题 在线升级驱动

概述

硬件连接

通讯接线使用RS485连接方式。 具体接线如下图所示：

DXA | RS485信号正
DXB | RS485信号负
SD | 屏蔽线

注 ：如果连接多台设备，最后一台设备需要接终端电阻100欧姆

默认通讯参数设置如下：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的变频器。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘富士变频器’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置变频器类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：选择参数，单击‘下一步’。

步骤7：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成变频器的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据变频器的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]CC

说明：

项目符号

ID指变频器的站号地址，用于识别设备中的变频器， 变频器的站号地址以十进制表示，地址设定范围为1～32。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号

CC指的是 变频器的参数地址。 地址范围见参数对照表。十进制表示。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

通道地址范围

标签值范围

H ID:CH

基本功能

模拟量

读/写

0～42

-65535～65535

E ID:CH

端子功能

模拟量

读/写

1～47

-65535～65535

C ID:CH

控制功能

模拟量

读/写

1～33

-65535～65535

P ID:CH

电动机1

模拟量

读/写

1～9

-65535～65535

H ID:CH

高级功能

模拟量

读/写

3～39

-65535～65535

A ID:CH

电动机2

模拟量

读/写

1～18

-65535～65535

O ID:CH

选件功能

模拟量

读/写

1～29

-65535～65535

S ID:CH

设定数据

模拟量

读/写

1～12

-65535～65535

M ID:CH

监测数据

模拟量

只读

1～48

-65535～65535

CommErr ID:CH

通讯错误

模拟量

只读

-----

-65535～65535

标签举例

标签 ：H 1:1
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只读）

标签 ：E1:2
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 ：C 1:5
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 : P 1:3
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的频率的设定值（只写）

标签 ：H 1:4
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态A

标签 ：A 1:12
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态B

标签 ：O 1:12
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的状态C

标签 ：S 1:12
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出电流

标签 ：M 1:23
 数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的输出电压

常见问题

1、与开物2000进行连接，变频器需要设置的一些参数？

答：与开物通讯之前需要对变频器进行初始化，开物软件中的默认设定H30=3,H34=1,H35=0,H36=0,H37=1,以上的参数设定串口通讯的波特率、数据位、校验方式、停止位，用户可以根据自己的使用人为修改。

注：变频器的参数必须与开物中定义设备时的参数对应正确

讯。

附图一

标签类型

含义

分辨率

标签类型

含义

分辨率

F 00

数据保护

1

F 01

频率设定1

1

E 01

X1端子功能

1

F 02

运行操作

1

E 02

X2端子功能

1

F 03

最高输出频率

1

E 03

X3端子功能

1

F 04

基本频率1

1

E04

X4端子功能

1

F 05

额定电压

1

E 05

X5端子功能

1

F 06

最高输出电压1

1

E 06

X6端子功能

1

F 07

加速时间

1

E 07

X7端子功能

1

F 08

减速时间

1

E08

X8端子功能

1

F 09

转矩提升

1

E 09

X9端子功能

1

F 10

电子热继电器

1

E 10

加速时间2

1

F 11

电子热继电器

1

E 11

加速时间2

1

F 12

电子热继电器

O.1

E 12

加速时间3

1

F 13

电子热继电器

1

E 13

加速时间3

1

F14

电子热继电器

1

E14

加速时间4

1

F 15

频率值上限

1

E 15

加速时间4

1

F 16

频率值下限

1

E16

转矩限制2驱动

1

F 17

增益

O.1

E 17

转矩限制2制动

1

F 18

频率偏置

O.1

E 18

1

F 19

O.1

E 19

1

F 20

直流制动开始频率

O.1

E 20

Y1端子功能

1

F 21

直流制动（动作值

1

E21

Y2端子功能

1

F 22

直流制动（时间

O.1

E22

Y3端子功能

1

F 23

启动频率

O.1

E 23

Y4端子功能

1

F 24

启动频率保持时间

O.1

E 24

Y5端子功能

1

F 25

停止频率

O.1

E 25

Y5端子功能

1

F 26

电动机运行载波频率

1

E 26

1

F 27

电动机运行声音

1

E 27

1

F 28

1

E 28

1

F 29

1

E 29

1

F 30

FMA电压调整

1

E30

频率值到达幅值

O.1

F 31

FMA功能选择

1

E 31

频率值到达检测

1

F 32

1

E 32

频率值到达检测

O.1

F 33

脉冲率

1

E 33

动作选择过载预报

1

F 34

FMP电压调整

1

E 34

动作值过载预报

1

F 35

FMP功能选择

1

E 35

动作时间过载预报

1

F 36

动作模式

1

E 36

频率值检测

1

F 37

1

E37

频率值到达幅值

1

F 38

1

E 38

频率值到达检测

1

F 39

1

E 39

频率值到达检测

1

F 40

转矩限制1驱动

1

E 40

动作选择过载预报

1

F 41

转矩限制1制动

1

E 42

动作值过载预报

O.1

F 42

转矩矢量控制1

1

E 43

动作时间过载预报

1

E 44

频率值检测

1

E 45

动作选择过载预报

1

E 46

动作值过载预报

1

E 47

动作时间过载预报

1

标签类型

含义

分辨率

标签类型

含义

分辨率

M 01

频率命令

1

M 02

H 03

数据初始化

1

M 03

H 04

自动复位次数

1

M 04

H 05

自动复位间隔时间

1

M 05

频率命令

O.O1

H 06

冷却风扇ON/OFF控制

1

M 06

输出频率1

1

H 07

加减速方式

1

M 07

转矩计算值

O.O1

H 08

反向旋转禁止

1

M 08

转矩电流

O.O1

H 09

起动特性

1

M 09

输出频率1

O.O1

H10

自动节能运行

1

M 10

输入功率

O.O1

H 11

减速模式

1

M 11

输出电流有效值

O.O1

H 12

瞬时过电流限制

1

M 12

输出电压有效值

O.1

H 13

等待时间

1

M 13

运行操作命令

H14

频率下降率

1

M14

运行状态

H 15

继续运行值

1

M 15

通用输出端子信息

H 16

运行命令自保时间

1

M 16

最新报警内容

H 17

1

M 17

前1次报警内容

H 18

转矩控制

1

M 18

前2次报警内容

H 19

主动驱动

1

M 19

前3次报警内容

H 20

PID控制动作选择

1

M 20

运行累计时间

1

H 21

PID控反馈信号选择

O.1

M 21

直流中间电压

1

H 22

PID控制增益

O.O1

M 22

H 23

PID控制积分时间

O.1

M 23

机种代码

H 24

PID控制微分时间

O.O1

M 24

容量代码

H 25

PID控制反馈滤波器

O.1

M 25

ROM版本

O.1

H 26

PTC热敏电阻动作选择

O.1

M 26

传送异常处理代码

O.1

H 27

PTC热敏电阻动作值

O.1

M 27

报警时频率命令

O.1

H 28

下垂控制

O.1

M 28

O.1

H 29

链接功能动作选择

O.1

M 29

O.1

H 3 0

RS485设定站地址

1

M 3 0

O.1

H 31

RS485设定出错动作选择

1

M 31

报警时频率命令

O.O1

H 32

RS485设定定时时间

1

M 32

报警时输出频率值

1

H 33

RS485设定波特率

1

M 33

报警时转矩计算值

O.O1

H 34

RS485设定数据长度选择

1

M 34

报警时转矩电流

O.O1

H 35

RS485设定奇偶校验

1

M 35

报警时输出频率值

O.O1

H 36

RS485设定停止位

1

M 36

报警时输入功率

O.O1

H 37

RS485设定通信断检出时间

1

M 37

报警时输出电流有效值

O.O1

H 38

RS485设定应答间隔时间

1

M 38

报警时输出电压有效值

O.O1

H 39

RS485设定站地址

1

M 39

报警时运行命令

O.1

H 40

通讯错误

1

M 40

报警时通用输出端子信息

O.1

H 42

通讯错误

1

M 42

报警时运行累计时间

O.1

H 43

通讯错误

1

M 43

报警时直流中间电压

O.1

H 44

通讯错误

1

M 44

报警时变频器内温度

O.1

H 45

通讯错误

1

M 45

报警时散热板温度

O.1

H 46

通讯错误

1

M 46

主电路电容器寿命

O.1

H 47

通讯错误

1

M 47

电路板上电容寿命

O.1

H 48

通讯错误

1

M 48

冷却风扇寿命

O.1

标签类型

含义

分辨率

标签类型

含义

分辨率

C 01

跳越频率值1

O.1

O 01

频率设定1

O.1

C 02

跳越频率值2

O.1

O 02

运行操作

O.1

C 03

跳越频率值3

O.1

O 03

电动机1

O.1

C 04

跳越频率值

O.1

O 04

高级功能

O.1

C 05

多步频率1

O.1

O 05

电动机2

O.1

C 06

多步频率2

O.1

O 06

选件功能

O.1

C 07

多步频率3

O.1

O 07

设定数据

O.1

C 08

多步频率4

O.1

O 08

监测数据

O.1

C 09

多步频率5

O.1

O 09

通讯错误

O.1

C10

多步频率6

O.1

O 10

通讯错误

O.1

C 11

多步频率7

O.1

O 11

通讯错误

O.1

C 12

多步频率8

O.1

O 12

通讯错误

O.1

C 13

多步频率9

O.1

O 13

通讯错误

O.1

C14

多步频率1O

O.1

O14

通讯错误

O.1

C 15

多步频率11

O.1

O 15

通讯错误

O.1

C 16

多步频率12

O.1

O 16

通讯错误

O.1

C 17

多步频率13

O.1

O 17

通讯错误

O.1

C 18

多步频率14

O.1

O 18

通讯错误

O.1

C 19

多步频率15

O.1

O 19

通讯错误

O.1

C 20

点动频率值

O.1

O 20

通讯错误

O.1

C 21

程序运行

O.1

O 21

通讯错误

O.1

C 22

程序步1

O.1

O 22

通讯错误

O.1

C 23

程序步2

O.1

O 23

通讯错误

O.1

C 24

程序步3

O.1

O 24

通讯错误

O.1

C 25

程序步4

O.1

O 25

通讯错误

O.1

C 26

程序步5

O.1

O 26

通讯错误

O.1

C 27

程序步6

O.1

O 27

通讯错误

O.1

C 28

程序步7

O.1

O 28

通讯错误

O.1

C 29

O.1

O 29

通讯错误

O.1

C 3 0

频率设定2

O.1

C 31

模拟输入偏移

O.1

C 32

模拟输入偏移

O.1

C 33

模拟输入滤波器

O.1

标签类型

含义

分辨率

标签类型

含义

分辨率\

P 01

电动机1级数

O.1

S 01

频率命令1

O.1

P 02

电动机1容量

O.1

S 05

频率命令

O.1

P 03

电动机1额定电流

O.1

S 06

运行操作命令

O.1

P 04

电动机1自整定

O.1

S 07

万能DO

O.1

P 05

电动机1在线整定

O.1

S 08

加速时间

O.1

P 06

电动机1空载电流

O.1

S 09

减速时间

O.1

P 07

电动机1R1

O.1

S 10

转矩限制1

O.1

P 08

电动机1X

O.1

S 11

转矩限制1

O.1

P 09

电动机1转差补偿值

O.1

S 12

万能AO

O.1

标签类型

含义

分辨率

标签类型

含义

分辨率\

A 01

最高输出频率2

O.1

A10

电动机2级数

O.1

A 02

基本频率2

O.1

A 11

电动机2容量

O.1

A 03

额定电压2

O.1

A 12

电动机2额定电流

O.1

A 04

最高输出电压2

O.1

A 13

电动机2自整定

O.1

A 05

转矩提升2

O.1

A14

电动机2在线整定

O.1

A 06

电子热继电器2动作选择

O.1

A 15

电动机2空载电流

O.1

A 07

电子热继电器2动作值

O.1

A 16

电动机2R1

O.1

A 08

电子热继电器2热时间常数

O.1

A 17

电动机2X

O.1

A 09

转矩矢量控制2

O.1

A 18

电动机2转差补偿值

O.1

其中各个寄存器的详细含义请参看富士变频器的说明手册