大恒变频器

概述 标签说明 标签举例 在线升级驱动

概述

本驱动程序提供对大恒变频器的支持，在使用前请先确认各种型号变频器的通讯支持情况。

仪表通讯参数

通讯格式为：请参照说明书，默认设置情况为8个数据位，一个停止位，偶校验，波特率9600BPS；

通讯采用RS485标准；

地址：可选范围为1～30，十进制；31为广播地址。

标签说明

项目符号 | 下表中ID指仪表的设备表号(开物2000设备向导中的设备号)。
项目符号 | 红色字表示格式中设备号，十进制数表示。
项目符号 | 注:此处仪表中的通信地址以10进制表示。
项目符号 | 注：有些参数可能需要进行量纲转换，请在标签的测量值最大、最小值和工程值最大最小值中进行设置。如一些频率相关参数中需要将驱动采集到的数据缩小100倍，这时需要保证工程值最大最小是测量值最大最小的0.01倍，即将数据线性缩小100倍。对于功能码参数中有很多这样的参数，请参照说明书中参数说明中的最小单位进行设置。
标签地址 | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
POWER_FRE ID:CH | 启停控制中相关频率，在进行启动控制时，请设定此频率。 | 模拟量 | 只写 | 0 | 0-65535
POWER ID:CH | 启停控制 | 模拟量 | 只写 | 0 | 见说明1
FRE_SET ID:CH | 设定频率 | 模拟量 | 只写 | 0 | 0-65535
STS ID:CH | 读取变频器状态 | 开关量 | 只读 | 0-99 | 见说明书中的[状态监控一览表]，如CH=0，则为当前输出频率等。
PARMID:CH1.CH2 | 读取|设置功能码参数 | 模拟量 | 读写 | 见说明2 | 0-65535
ERRID:CH | 读取变频器状态 | 模拟量 | 只读 | 0 | 请参见说明书中的[状态反馈]，如1对应从机正转运行中，2对应从机反转运行中；3对应从机停机。
COMMLINK ID:CH | 总线线路通讯状况 | 模拟量 | 只读 | 无 | 0=通讯始终不成功；1=通讯正常；3=通讯出现故障
DEVICELINK ID:CH | 各子设备线路通讯状况 | 模拟量 | 只读 | 0 | 0=通讯始终不成功；1=通讯正常；3=通讯出现故障

说明1： 对于这个标签需要通过设定不同的数据来实现其启停的控制，标签数值的对应关系见下表。

标签值 | 含义 | 备注
1 | 正转运行开机 | 与POWER_FRE值无关
2 | 反转运行开机 | 与POWER_FRE值无关
3 | 停机 | 与POWER_FRE值无关
17 | 正转运行开机并带频率设定 | 与POWER_FRE值有关，请保证POWER_FRE数值为需要设定的数值。
18 | 反转运行开机并带频率设定 | 与POWER_FRE值有关，请保证POWER_FRE数值为需要设定的数值。
19 | 停机机并带频率设定 | 与POWER_FRE值有关，请保证POWER_FRE数值为需要设定的数值。

说明2：

CH1对应功能码分类参数，即0-9对应P0-P9，10对应PC，11对应PE，12对应PF，13对应PH，14对应PL，15对应PP；CH2对应这个组的某一个参数，如‘上限频率’P1.8，则标签中CH1=1，CH2=8，则3号变频器标签配置为PARM3:1.8。

注意：对于各种标签的工程值和测量值的设定，请参阅相关说明书，如对于频率需要将工程值设定为相应测量值的0.01倍，等等。

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：POWER_FRE 1:0
数据值类型：模拟量
描述 ：表示配合POWER标签使用时需要设定的频率数据。

标签 ：POWER 1:0
数据值类型：模拟量
描述 ：表示控制1号变频器启停，如将标签值设为1则为正转开机，3则为停机。

标签 ：FRE_SET1:0
数据值类型：模拟量
描述 ：表示设置1号变频器频率。

标签 ：PARM 1:2.3
数据值类型：模拟量
描述 ：表示读取1号变频器的F2.3参数。

标签 ：STS 1:2
数据值类型：模拟量
描述 ：表示读取1号变频器的从机运行参数 2，即输出电压[有效值]。

标签 ：ERR 1:0
数据值类型：模拟量
描述 ：表示读取1号变频器的状态。