台达VFD-B系列变频器

概述 连接及设置 I/O设备地址 数据类型 标签举例 在线升级驱动

台达-B、台达-S系列变频器协议概述

台达变频器通讯协议支持与台达变频器之间的通讯，本协议采用串行通讯，使用您计算机中的串行口。

开物2000还支持其他多种变频器，详情请与北京华富惠通技术有限责任公司联系。

台达-B、台达-S系列变频器与系统的连接及设置

您可以通过串行口将开物2000与一个或多个台达变频器相连。

利用串行口进行连接时，可以通过RS232/485适配器与台达变频器RS485端子相连。

设置台达变频器：

当使用RS485与上位机相连时，台达变频器的缺省与推荐设置如下

设置项

缺省值

推荐值

波特率：

9600

9600

当使用RS232与上位机相连时，台达变频器的通讯参数配置请参照的使用手册。

其中台达变频器的通讯参数推荐设置为9600 BAUD。

当使用RS485与上位机相连时，上位机的RS232推荐设置如下

设置项

推荐值

波特率：

9600

数据位长度

7

停止位长度

2

奇偶校验位

无

台达变频器的I/O设备地址

当使用RS485与上位机相连时，台达变频器的地址在开物2000中的设置范围从1到254。台达变频器的地址由台达变频器的参数P0900设置。

台达变频器数据类型

寄存器使用说明

寄存器名称 | 标签地址格式 | 数据类型 | 读写类型 | 标签类型 | 取值范围 | 与下位机对应实际应用意义
STOP | STOP | INT | 读写 | 模拟量 | 无 | 控制命令：停止
FWD | FWD | INT | 读写 | 模拟量 | 无 | 控制命令：按给定频率正转
REV | REV | INT | 读写 | 模拟量 | 无 | 控制命令：按给定频率反转
JOGFWD | JOGFWD | INT | 读写 | 模拟量 | 无 | 控制命令：步进正转
JOGREV | JOGREV | INT | 读写 | 模拟量 | 无 | 控制命令：步进反转
CHANGEDES | CHANGEDES | INT | 读写 | 模拟量 | 无 | 改变方向
RESET | RESET | INT | 读写 | 模拟量 | 无 | 系统复位
P | Pdddd | INT | 读写 | 模拟量 | 0-9999 | Pdddd与变频器的参数Pdd-dd相对应, Pdddd的内容与变频器的参数Pdd-dd的参数值相对应。其实际使用意义与使用方法与变频器的要求相同，可以参考变频器的使用手册。对于在变频器中没有的参数号，虽然在开物2000中可以定义该寄存器，但无实际应用意义。
FREQ | FREQ | INT | 读写 | 模拟量 | 0-4000 | 给定的频率

用户如有疑问，请参照台达变频器的使用手册中的串行通讯部分。

标签举例

在上位机中定义一变量P0900，该参数连接到寄存器P900，与之相对应的下位机单元是变频器的参数项P09-00。当向P0900中写入值时（比如2），变频器的参数项P09-00（通讯地址）也改成相应的值（2）。