用户帮助文件

佳灵变频器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

通讯接线在用户给出的资料当中没有体现出来，有待于进一步考证。（应该是通用的串口连接）

通讯参数设置如下：

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置变频器类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]

说明：

项目符号

ID指变频器的站号地址，用于识别设备中的变频器， 变频器的站号地址以十进制表示，地址设定范围为0～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号

Ch指的是 变频器的参数地址。 地址范围见参数对照表。十进制表示。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

RunID:

运行/停止

模拟量

只写

128/0

FreqID:

频率设定

模拟量

可读可写

0------65535

ResetID:

复位

模拟量

只写

64

RunFreq ID:

运行频率

模拟量

只读

0～65535

EndFreq ID:

目标频率

模拟量

只读

0～65535

Voltage ID:

电压

模拟量

只读

0～65535

Current ID:

电流

模拟量

只读

0～65535

Trouble ID:

故障

模拟量

只读

0～65535

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功

1=通讯正常
2=通讯出现干扰
3=通讯出现故障
4=通讯线路断路
5=暂停通讯

标签举例

标签 ：Run1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的变频器的运行/停止状态（只 写）

标签 ：Freq 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的频率的设定值（可读可写）

标签 ：Reset 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的复位

标签 ：RunFreq 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的运行频率值

标签 ：EndFreq 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的频率的目标值

标签 ：Voltage 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的电压值

标签 ：Current 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的电流值

标签 ：Trouble 1:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的 变频器的故障状态

故障码：

15

14 13 12 11 10 9 8 7 6 5 4

3

2

1

0

OL(故障保护)

OCP(过流保护)

LU(欠压保护)

FL(主器件自保护)

OUd(过压保护)

标签 ：DeviceLink3:
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为3的PLC的最新通讯状态