SY-903智能侧温仪

概述 硬件连接 硬件接线图 地址设置 创建设备 创建标签 标签的地址规则 标签举例 标签类型 常见问题

SY-903智能侧温仪通信协议概述

波特率:2400 数据位:8 停止位:1 起始位:1 偶校验

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的设备。以便于开物2000识别和使用。

选择设备类型(其它设备)。双击‘单片机’，或单击选中‘SY-903智能测温仪'，更改设备名称，最后单击‘选择’按钮。

选择操作方式-新建设备。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

选择创建设备的方式：选中‘单个设备创建’后，单击‘下一步’按钮。

显示设备创建界面，选择好设备类型，输入设备号后，单击‘下一步’按钮。注:对于该设备默认设备号便可；

显示计算机串行口通讯参数窗口，修改完串行口、波特率等参数后，单击‘下一步’按钮。注:该驱动中默认的参数是设定状态的参数；

显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成仪表的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘SY-903智能测温仪’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[Chn]

说明：

项目符号

ID指仪表的设备表号(开物2000设备向导中的表号)

项目符号 | 红色字表示格式中可变部分，十进制数表示，变化范围参见各种仪表的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容通常可省略。
项目符号 | 标签地址配置成不存在类型或设备表号错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签格式

标签含义

         变量类型 读写类型 通道范围 标签范围
PVID: 温度 模拟量 只读 0--------65535

标签使用举例:

标签：PV1:
数据类型：模拟量
描述：表示读取站号为1的温度值