ModBus RTU兼容设备

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

开物2000 ModBus RTU兼容设备采用Modbus RTU协议进行通讯。它只支持0级和1级命令，即支持00、10、30、40、90五种参数的读操作，00、40、90参数的写操作，00、10、30、40、90五种参数的实际含义需要查阅 兼容设备的技术手册和通讯手册 。该设备与开物2000进行通讯前，设备的通讯端口要与计算机的空闲串口连接。

硬件连接

通过查阅此硬件设备的技术手册和通讯手册，可以找到设备与计算机串口的连接线定义。RS485/RS422和串口之间需要增加485/232转换器。

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的设备。以便于开物2000识别和使用。

步骤1： 单击［其它设备］组前的‘+’号，展开［其它设备］组。双击［Modbus RTU兼容设备］，单击‘选择’按钮。

步骤2：选择操作方式-新建设备。选中［新建设备］后单击［下一步］按钮 （或双击［新建设备］）。

步骤3：选择创建设备方式。根据网络连接方式进行选择，对于RS232方式，选中 ［单个设备创建］后单击［下一步］按钮（或双击［单个设备创建］）。

步骤4：显示创建单个设备界面。在界面上选择完设备类型，修改完设备号后（设备号的含义和取值范围请参考硬件设备的产品手册），单击［下一步］按钮。

步骤5：显示串口参数配置窗口， 根据设备和实际通讯连接情况，选择串口，修改其它参数。单击［下一步］按钮。

步骤6：显示设备及参数汇总窗口，单击［完成 ］按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、选择并填写［主设备地址］，修改标签名称。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch

说明：

项目符号

标签类型指的是ModBus RTU兼容设备所识别的参数类型（注：不是设备中的实际参数类型），一般包括00、10、30、40、90五种类型同时还兼容以前版本中的30、40、DW、Float类型的标签.

项目符号

ID指设备地址，用于识别 开物工程设备中的某个PLC。ID是十进制表示形式 ，位数不限。从0开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的设备地址是开物工程设备中的最小的设备地址。

项目符号

Ch指参数地址号。是十进制表示。从1开始编址。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种PLC的技术手册。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在 工程设备中只包含一个子设备时可省略。
项目符号 | 标签地址配置成不存在类型或设备地址错误或 参数地址超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

00ID:Ch | 输出线圈(读01写05) | 开关量 | 读写 | true / false
10ID:Ch | 输入节点(读02) | 开关量 | 只读 | true / false
30 SW ID:Ch | 输入寄存器(有符号字格式，读04) | 模拟量 | 只读 | -32768～32767
30 W ID:Ch | 输入寄存器(无符号字格式，读04) | 模拟量 | 只读 | 0～65535
30 RSDW ID:Ch | 输入寄存器(有符号双字格式，低位在前，读04) | 模拟量 | 只读 | -2147483647～2147483647
30 RDW ID:Ch | 输入寄存器(无符号双字格式，低位在前，读04) | 模拟量 | 只读 | 0～429496729
30 SDW ID:Ch | 输入寄存器(有符号双字格式，高位在前，读04) | 模拟量 | 只读 | -2147483647～2147483647
30 DW ID:Ch | 输入寄存器(无符号双字格式，高位在前，读04) | 模拟量 | 只读 | 0～429496729
30 RF ID:Ch | 输入寄存器(四字节浮点数格式，低位在前，读04) | 模拟量 | 只读 | -9999999999～9999999999
30 F ID:Ch | 输入寄存器(四字节浮点数格式，高位在前，读04) | 模拟量 | 只读 | -9999999999～9999999999
4 0 SW ID:Ch | 保持寄存器(有符号字格式，读03写06) | 模拟量 | 读写 | -32768～32767
4 0 W ID:Ch | 保持寄存器(无符号字格式，读03写06) | 模拟量 | 读写 | 0～65535
4 0 RSDW ID:Ch | 保持寄存器(有符号双字格式，低位在前，读03) | 模拟量 | 只读 | -2147483647～2147483647
4 0 RDW ID:Ch | 保持寄存器(无符号双字格式，低位在前，读03) | 模拟量 | 只读 | 0～429496729
4 0 SDW ID:Ch | 保持寄存器(有符号双字格式，高位在前，读03) | 模拟量 | 只读 | -2147483647～2147483647
4 0 DW ID:Ch | 保持寄存器(无符号双字格式，高位在前，读03) | 模拟量 | 只读 | 0～429496729
4 0 RF ID:Ch | 保持寄存器(四字节浮点数格式，低位在前，读03) | 模拟量 | 只读 | -9999999999～9999999999
4 0 F ID:Ch | 保持寄存器(四字节浮点数格式，高位在前，读03) | 模拟量 | 只读 | -9999999999～9999999999
9 0 SW ID:Ch | 保持寄存器(有符号字格式，读03写10) | 模拟量 | 读写 | -32768～32767
9 0 W ID:Ch | 保持寄存器(无符号字格式，读03写 10) | 模拟量 | 读写 | 0～65535
9 0 RSDW ID:Ch | 保持寄存器(有符号双字格式，低位在前，读03写10) | 模拟量 | 读写 | -2147483647～2147483647
9 0 RDW ID:Ch | 保持寄存器(无符号双字格式，低位在前，读03写 10) | 模拟量 | 读写 | 0～429496729
9 0 SDW ID:Ch | 保持寄存器(有符号双字格式，高位在前，读03写10) | 模拟量 | 读写 | -2147483647～2147483647
9 0 DW ID:Ch | 保持寄存器(无符号双字格式，高位在前，读03写10) | 模拟量 | 读写 | 0～429496729
9 0 RF ID:Ch | 保持寄存器(四字节浮点数格式，低位在前，读03写 10) | 模拟量 | 读写 | -9999999999～9999999999
9 0 F ID:Ch | 保持寄存器(四字节浮点数格式，高位在前，读03写10) | 模拟量 | 读写 | -9999999999～9999999999
CommLink 通信线路状态(-系统标签-) 模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
3=通讯出现故障

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
3=通讯出现故障

标签举例

标签 ：40W1:7
数据值类型：模拟量
描述 ：表示1号 设备的第7个保持寄存器，用无符号字格式表示。

标签 ：40SW1:2
数据值类型：模拟量
描述 ：表示 1号 设备的第2个保持寄存器，用有符号字格式表示。

标签 ：40DW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个无符号双字数据且高字在前。

标签 ：40SDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个有符号双字数据且高字在前。

标签 ：40RDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个无符号双字数据且低字在前。

标签 ：40RSDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个有符号双字数据且低字在前。

标签 ：40F:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个四字节浮点数据且高字在前。

标签 ：40RF1:2
数据值类型：开关量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个四字节浮点数据且低字在前。

标签 ：DeviceLink1:
数据值类型：模拟量
描述 ：表示1号设备的通讯状况，上面的表格中给出了各种数值对应的通讯状况。

标签 ：CommLink
数据值类型：模拟量
描述 ：表示整条综线上的通讯状况，上面的表格中给出了各种数值对应的通讯状况。