ModBus ASCII兼容设备

概述 标签说明 标签举例 在线升级驱动

概述

开物2000 ModBus ASCII兼容设备采用Modbus ASCII协议进行通讯。支持0级和1级命令，即支持00、10、30、40、90五种参数的读操作，00、40、90参数的写操作，00、10、30、40、90五种参数的实际含义需要查阅兼容设备的技术手册和通讯手册。该设备与开物2000进行通讯前，设备的通讯端口要与计算机的空闲串口连接。

仪表通讯参数

通讯格式为：请参考仪表通讯说明设定。

波特率：请参考仪表通讯说明设定。

地址：可选范围为0～31，十进制，请参照具体设备说明书。

标签说明

项目符号

标签类型指的是ModBus ASCII兼容设备所识别的参数类型，一般包括00、10、30、40、90五种类型同时还兼容以前版本中的30、40、DW、Float类型的标签.

项目符号

ID指设备地址，用于识别开物工程中的某个设备。标签地址中省略ID时，开物2000系统默认为是所连接的设备地址是开物工程设备中的最小的设备地址。

项目符号

Ch指参数地址号。是十进制表示。从1开始编址。

项目符号 | 红色字表示格式中可变部分，变化范围参见技术手册。
项目符号 | 标签地址配置成不存在类型或设备地址错误或 参数地址超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

00ID:Ch | 输出线圈(读01写05) | 开关量 | 读写 | true / false
JOG ID:Ch 点动控制(写05) 开关量 只写

当给标签赋TRUE说，发生从FALSE到TRUE的跳变；当给标签赋FALSE说，发生从TRUE到FALSE的跳变，用于实现可靠的点动控制

10ID:Ch | 输入节点(读02) | 开关量 | 只读 | true / false
30 SW ID:Ch | 输入寄存器(有符号字格式，读04) | 模拟量 | 只读 | -32768～32767
30 W ID:Ch | 输入寄存器(无符号字格式，读04) | 模拟量 | 只读 | 0～65535
30 RSDW ID:Ch | 输入寄存器(有符号双字格式，低位在前，读04) | 模拟量 | 只读 | -2147483647～2147483647
30 RDW ID:Ch | 输入寄存器(无符号双字格式，低位在前，读04) | 模拟量 | 只读 | 0～429496729
30 SDW ID:Ch | 输入寄存器(有符号双字格式，高位在前，读04) | 模拟量 | 只读 | -2147483647～2147483647
30 DW ID:Ch | 输入寄存器(无符号双字格式，高位在前，读04) | 模拟量 | 只读 | 0～429496729
30 RF ID:Ch | 输入寄存器(四字节浮点数格式，低位在前，读04) | 模拟量 | 只读 | -9999999999～9999999999
30 F ID:Ch | 输入寄存器(四字节浮点数格式，高位在前，读04) | 模拟量 | 只读 | -9999999999～9999999999
4 0 SW ID:Ch | 保持寄存器(有符号字格式，读03写06) | 模拟量 | 读写 | -32768～32767
4 0 W ID:Ch | 保持寄存器(无符号字格式，读03写06) | 模拟量 | 读写 | 0～65535
4 0 RSDW ID:Ch | 保持寄存器(有符号双字格式，低位在前，读03) | 模拟量 | 只读 | -2147483647～2147483647
4 0 RDW ID:Ch | 保持寄存器(无符号双字格式，低位在前，读03) | 模拟量 | 只读 | 0～429496729
4 0 SDW ID:Ch | 保持寄存器(有符号双字格式，高位在前，读03) | 模拟量 | 只读 | -2147483647～2147483647
4 0 DW ID:Ch | 保持寄存器(无符号双字格式，高位在前，读03) | 模拟量 | 只读 | 0～429496729
4 0 RF ID:Ch | 保持寄存器(四字节浮点数格式，低位在前，读03) | 模拟量 | 只读 | -9999999999～9999999999
4 0 F ID:Ch | 保持寄存器(四字节浮点数格式，高位在前，读03) | 模拟量 | 只读 | -9999999999～9999999999
9 0 SW ID:Ch | 保持寄存器(有符号字格式，读03写10) | 模拟量 | 读写 | -32768～32767
9 0 W ID:Ch | 保持寄存器(无符号字格式，读03写 10) | 模拟量 | 读写 | 0～65535
9 0 RSDW ID:Ch | 保持寄存器(有符号双字格式，低位在前，读03写10) | 模拟量 | 读写 | -2147483647～2147483647
9 0 RDW ID:Ch | 保持寄存器(无符号双字格式，低位在前，读03写 10) | 模拟量 | 读写 | 0～429496729
9 0 SDW ID:Ch | 保持寄存器(有符号双字格式，高位在前，读03写10) | 模拟量 | 读写 | -2147483647～2147483647
9 0 DW ID:Ch | 保持寄存器(无符号双字格式，高位在前，读03写10) | 模拟量 | 读写 | 0～429496729
9 0 RF ID:Ch | 保持寄存器(四字节浮点数格式，低位在前，读03写 10) | 模拟量 | 读写 | -9999999999～9999999999
9 0 F ID:Ch | 保持寄存器(四字节浮点数格式，高位在前，读03写10) | 模拟量 | 读写 | -9999999999～9999999999
CommLink 通信线路状态(-系统标签-) 模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
3=通讯出现故障

DeviceLink ID:

设备通讯连接状态(-系统标签-)

模拟量/字符串量

只读

0=通讯始终不成功
1=通讯正常
3=通讯出现故障

标签举例：(以多个仪表创建为例，标签中包括仪表号)

标签 ：JOG1:1
数据值类型：开关量
描述 ：表示使用1号设备的第1个 输出线圈寄存器用于点动控制，当给标签赋TRUE说，发生从FALSE到TRUE的跳变；当给标签赋FALSE说，发生从TRUE到FALSE的跳变，用于实现可靠的点动控制。

标签 ：40W1:7
数据值类型：模拟量
描述 ：表示1号 设备的第7个保持寄存器，用无符号字格式表示。

标签 ：40SW1:2
数据值类型：模拟量
描述 ：表示 1号 设备的第2个保持寄存器，用有符号字格式表示。

标签 ：40DW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个无符号双字数据且高字在前。

标签 ：40SDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个有符号双字数据且高字在前。

标签 ：40RDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个无符号双字数据且低字在前。

标签 ：40RSDW1:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个有符号双字数据且低字在前。

标签 ：40F:2
数据值类型：模拟量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个四字节浮点数据且高字在前。

标签 ：40RF1:2
数据值类型：开关量
描述 ：表示1号设备的第2个保持寄存器和第3个保持寄存器，组合成的一个四字节浮点数据且低字在前。

标签 ：DeviceLink1:
数据值类型：模拟量
描述 ：表示1号设备的通讯状况，上面的表格中给出了各种数值对应的通讯状况。

标签 ：CommLink
数据值类型：模拟量
描述 ：表示整条综线上的通讯状况，上面的表格中给出了各种数值对应的通讯状况。