赛多利斯电子秤

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

l 电缆连接图：

电子秤 25PIN -----------------COMPUTER 9PIN

2-----------------------2

3-----------------------3

5-----------------------4

7-----------------------5

20-----------------------6

20-----------------------8

默认通讯参数如下所示：

波特率 | 9600bps
数据位 | 7
停止位 | 1
校验方式 | 偶校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的 设备。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]

说明：

项目符号

ID指该设备的站号地址，用于识别设备中的设备， 设备的站号地址以十进制表示，地址设定范围为0～ 31 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

项目符号 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

SIGNID:

值符号

字符量

只读

WEIGHTID:

秤量值

模拟量

只读

-65535～131070

STATUSID:

PLC运行状态

模拟量

可读可写

0～65535

SID:

初始化电子秤

开关量

只写

0/1

TID:

去皮重

开关量

只写

0/1

UNITID:

更改单位

字符量

只写

EID:

校准电子秤

开关量

只写

0/1

标签举例

标签 ：WEIGHT0:
数据值类型：模拟量
描述 ：表示设备配置示例中地址为0的 设备的具体秤量值

注：1、电子秤数据主动上报，直接使用WEIGHT标签，无需标签地址，WEIGHT标签数据即为电子秤的具体秤量值

2、其他标签因为电子秤的型号较老，暂未支持