西姆宏数据采集器

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

该驱动使用标准MODBUS协议通讯，包含XMHI，XMHF 两种子协议，分别对应两种类型的数据采集器。

默认通讯参数如下所示：

波特率 | 9600bps
数据位 | 7
停止位 | 2
校验方式 | 偶校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的 设备。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置PLC类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

  • ID指该PLC的站号地址，用于识别设备中的PLC， PLC的站号地址以十进制表示，地址设定范围为0～ 255 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

  • Ch指的是PLC的参数地址。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

XMID:CH

数据区寄存器

模拟量

可读可写

-65535～131070

ERRORID:CH

错误状态

模拟量

可读可写

0～65535

STATUSID:CH

PLC运行状态

开关量

可读可写

0/1

ENLOG ID:CH

日志文件输出控制

开关量

可读可写

0/1

标签举例

标签 ：XM0:5
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为0的PLC的 通道地址为5的数据区寄存器的值

标签 ：ERROR1:5
数据值类型：模拟量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的辅助继电器的状态

标签 ：STATUS1:5
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2F的连接继电器的状态

标签 ：ENLOG1:2A
数据值类型：开关量
描述 ：表示设备配置示例中站号地址为1的PLC的 通道地址为2A的保持继电器的状态