盛联检测设备（TCP）

盛联检测设备(TCP)

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

盛联检测设备与开物2000的通讯方式是采用的以太网通讯的，将盛联检测设备NCU的EtherNet端口通过网线连接到HUB,同时将计算机连接到HUB.

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘’，或单击选中‘’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式-单个创建或者多个创建。 选择创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置设备类型及TCP参数选项，单击‘下一步’按钮。

步骤5：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据PLC的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型Ch

说明：

  • Ch指的是参数地址。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

DCVCh

蓄电池电压

模拟量

只读

-100000～200000

ACVCh

交流电压

模拟量

只读

-100000～200000

ACSEQCh

交流相序

模拟量

只读

-100000～200000

ACACh

交流电流

模拟量

只读

-100000～200000

ISIMCh

模拟量输入

模拟量

只读

-100000～200000

ISWICh

开关量输入

开关量

只读

true/false

DEVSCh

设备开关状态

开关量

只读

true/false

SETCCh

设备开关控制

模拟量

只写

0～100

注：标签地址范围由实际硬件配置决定,,标签地址都从0开始,标签地址自动排序,如第一个DCU_A的DCV标签为DCV0,DCV1,DCV2,DCV3,第二个DCU_A模块为

DCV4,DCV5,DCV6,DCV7.其他标签地址处理方法相同.用户只需按上一同类标签的地址直接递增即可.蓄电池参数由DCU_A模块采集得到，每个DCU_A

模块采集4个电池电压， 交流电参数由DCU_B/D模块采集得到，它包含3个电压值，3个电流值和一个相序状态值 .控制参数由DCU_C模块采集得到.

它包含5个模拟量输入和一个开关量输入和5个设备开关状态.

标签举例

标签 ：DCV 0
数据值类型：模拟量
描述 ：表示设备配置示例中 设备的第1个DCU_A模块的#1蓄电池电压值

标签 ：ACV3
数据值类型：模拟量
描述 ：表示设备配置示例中设备的第1个DCU_B模块的#4的交流电压值

标签 ：ACSEQ5
数据值类型：模拟量
描述 ：表示设备配置示例中设备的第1个DCU_B模块的交流相序

标签 ：ACA 8
数据值类型：模拟量
描述 ：表示设备配置示例中设备的第2个DCU_B模块的#4交流电流值

标签 ：ISIM 1
数据值类型：模拟量
描述 ：表示设备配置示例中设备的第1个DCU_B模块的#2模拟量输入值

标签 ：ISWI 0
数据值类型：开关量
描述 ：表示设备配置示例中设备的第1个DCU_B模块的#1开关量输入值

标签 ：DEVS0
数据值类型：开关量
描述 ：表示设备配置示例中设备的第1个DCU_B模块的#1个设备状态