UPS

爱克赛UPS

概述 硬件连接 创建设备 创建标签 标签地址及范围 标签举例 在线升级驱动

概述

美国爱克赛公司（INVENSYS集团成员）成立于1888年，百多年来始终引领不间断电源行业的科技发展。作为全球最大的UPS专业提供商之一，主要致力于电源保护系统的设计、开发及制造，为世界各地的企业及机构提供全方位的电源管理方案。产品已广泛应用于金融、邮电、通讯、航空航天、能源、交通、军事、医疗、教育、商业、工矿、安全等各个领域。
开物2000支持以下型号的UPS9315。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

硬件连接

通讯端口硬件的推荐设置：

爱克赛UPS采用RS232连接。

波特率可选范围：2400bps、4800bps、9600bps、19200bps。

通讯参数可以通过UPS设置。例如：

波特率 | 9600bps
起始位 | 1
数据位 | 8
停止位 | 1
校验位 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的UPS。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中包含一个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

步骤4：设置UPS类型，单击‘下一步’按钮。

步骤5：设备串口通讯参数， 如下图所设，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用“天辰UPS向导“完成设备的创建后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择上述主设备‘ups9315’，选择并填写‘主地址’，修改标签名。

2、根据UPS的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。
单击‘添加’或‘完成’按钮。

标签地址及范围

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

项目符号 | 标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址,天辰UPS的站号为0～99。
项目符号 | Ch指通道号，范围因标签类型而异，十进制表示。
项目符号 | 标签地址配置成不存在类型或 UPS地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 含义 | 数据类型 | 读写类型 | 通道地址范围 | 标签值范围
PV ID:CH | UPS监测参数 | 模拟量 | 只读 | 1～41 | -65535～65535
ALARM ID:CH | UPS报警参数 | 开关量 | 只读 | 1～48 | 0/1
CommLink | 通信线路状态(-系统标签-) | 模拟量/字符串量 | 只读 | ---- | 0=通讯始终不成功
 |  |  |  |  | 1=通讯正常
 |  |  |  |  | 2=通讯出现干扰
 |  |  |  |  | 3=通讯出现故障
 |  |  |  |  | 4=通讯线路断路
 |  |  |  |  | 5=暂停通讯
DeviceLink ID: | 设备通讯连接状态(-系统标签-) | 模拟量/字符串量 | 只读 | ---- | 0=通讯始终不成功
 |  |  |  |  | 1=通讯正常
 |  |  |  |  | 2=通讯出现干扰
 |  |  |  |  | 3=通讯出现故障
 |  |  |  |  | 4=通讯线路断路
 |  |  |  |  | 5=暂停通讯

下面是标签对应的t通道参数地址：

PV通道地址 | 参数含义 | PV通道地址 | 参数含义
1 | OUTPUT VOLTS AB | 23 | BATTERY CURRENT
2 | OUTPUT VOLTS BC | 24 | BATTERY VOLTAGE
3 | OUTPUT VOLTS CA | 25 | %BATTERY LEFT
4 | INPUT VOLT AB | 26 | BATTERY TIME REMAINING (S)
5 | INPUT VOLT BC | 27 | INVERTER VOLTS PHASE A
6 | INPUT VOLT CA | 28 | INVERTER VOLTS PHASE B
7 | BYPASS VOLT AB | 29 | INVERTER VOLTS PHASE C
8 | BYPASS VOLT BC | 30 | LOAD CURRENT PHASE A
9 | BYPASS VOLT CA | 31 | LOAD CURRENT PHASE B
10 | INPUT CURRENT PHASE A | 32 | LOAD CURRENT PHASE C
11 | INPUT CURRENT PHASE B | 33 | LOAD CURRENT PHASE A BAR CHART
12 | INPUT CURRENT PHASE C | 34 | LOAD CURRENT PHASE B BAR CHART
13 | OUTPUT WATTS | 35 | LOAD CURRENT PHASE C BAR CHART
14 | INPUT WATTS | 36 | OUTPUT VA BAR CHART
15 | OUTPUT VA | 37 | DATA
16 | INPUT VA | 38 | TIME
17 | OUTPUT POWER FACTOR | 39 | OUTPUT VOLTS A
18 | INPUT POWER FACTOR | 40 | OUTPUT VOLTS B
19 | OUTPUT FREQUENCY | 41 | OUTPUT VOLTS C
20 | INPUT FREQUENCY |  |
21 | INVERTER FREQUENCY |  |
22 | BYPASS FREQUENCY |  |

ALARM通道地址 | 参数含义 | ALARM通道地址 | 参数含义
1 | INVERTER AC OVER VOLTAGE | 25 | RECTIFIER UNCALIBRATED
2 | INVERTER AC UNDER VOLTAGE | 26 | OUTPUT UNCALIBRATED
3 | INVERTER UNDER OR OVER FREQUENCY | 27 | INVERTER UNCALIBRATED
4 | BYPASS AC OVER VOLTAGE | 28 | BATTERY CURRENT LIMIT
5 | BYPASS AC UNDER VOLTAGE | 29 | INVERTER FAILUER
6 | BYPASS UNDER OR OVER FREQUENCY | 30 | OUTPUT CURRENT OVER 100%
7 | INPUT AC OVER VOLTAGE | 31 | SHUTDOWN IMMINENT
8 | INPUT AC UNDER VOLTAGE | 32 | BATTRY LOW
9 | INPUT UNDER OR OVER FREQUENVY | 33 | BATTERY DC OVER VOLTAGE
10 | OUTPUT AC OVER VOLTAGE | 34 | POWER SUPPLY FAILURE
11 | OUTPUT AC UNDER VOLTAGE | 35 | HEATSINK OVER TEMPERATURE
12 | OUTPUT UNDER OR OVER FREQUENCY | 36 | HEATSINK OVER TEMPERATURE SENSOR FAILED
13 | BUILDING ALARM6 | 37 | NETWORK NOT RESPONDING
14 | BUILDING ALARM5 | 38 | INPUT PHASE ROTATION ERROR
15 | BUILDING ALARM4 | 39 | EMERGENCY SHUTDOWN COMMAND
16 | BUILDING ALARM3 | 40 | BYPASS NOT AVAILABLE
17 | BUILDING ALARM2 | 41 | BATTERY CONCACTOR OPEN
18 | BUILDING ALARM1 | 42 | INVERTER CONCACTOR OPEN
19 | OUTPUT OVERLOAD | 43 | BATTERY TOTALLY DISCHARGED
20 | DC LINK OVER VOLTAGE | 44 | BATTERY NOT CHARGED
21 | DC LINK UNDER VOLTAGE | 45 | UPS ON BATTERY
22 | RECTIFIER FAILED | 46 | UPS ON BYPASS
23 | BATTERY CONTACTOR FAIL | 47 | LOAD DUMPED(LOAD POWER OFF)
24 | BYPASS BREAKER FAIL | 48 | FAN FAILURE

标签举例

标签 ：PV1
数据值类型：模拟量
描述 ：表示UPS第1通道测量参数值(OUTPUT VOLT AB)

标签 ：ALARM1
数据值类型：开关量
描述 ：表示UPS第1通道报警状态(INVERTER AC OVER VOLTAGE)

标签 ：DeviceLink0:
数据值类型：模拟量
描述 ：表示设备配置示例中0号设备的最新通讯状态