湿度传感器HydroProbe II

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

志美HydroProbe II湿度传感器 概述

HydroProbe II是志美公司的一种智能型湿度传感器，多个该类型传感器通过网线可组成网络结构。本驱动仅提供对该类型传感器瞬时湿度和平均湿度的读取功能，其他功能可通过厂家提供的Hydrolink3.exe软件来实现。

关于 HydroProbe II 的更详细信息请访问www.hydronix.com。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

志美HydroProbe II湿度传感器与计算机的连接

下面是志美HydroProbe II湿度传感器配置接线图示意图：

在开物2000开发环境中创建设备

传感器在网络结点中的地址可由厂家提供的 Hydrolink3.exe软件来设置，串口通讯参数可由本驱动程序进行设置。

开物系统的标签地址中需要配置传感器的序号信息，详见下面的标签的地址配置规则。上图中共有 一个传感器，传感器的序号为1。

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘温度传感器HydroProbe II’，或单击选中‘温度传感器HydroProbe II’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个模块)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示设备创建方式配置界面。在向导选择多传感器创建，单击‘下一步’按钮。

步骤4：显示设备 配置向导，在此向导中添加相应的设备，并确定其单元号，单击“下一步”按钮。

步骤5：显示串口参数配置向导，在向导中配置好各参数，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

标签的创建

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘温度传感器HydroProbe II’，选择并填写‘主设备地址’，修改标签名。

2、根据模块的工作模式和标签所监控的参数物理意义，修改测量值零点、测量值量程、工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]Ch.SensorNum.BitNum

说明：

项目符号

ID指模块的模块地址，用于识别设备中的模块， 模块地址以十六进制表示，地址设定范围为00 ～ FF 。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。

项目符号

Ch指通道号。范围通常为 0～7。十进制表示。

项目符号

SensorNum指传感器的序号。范围通常为 0～63。十进制表示。

项目符号

ITUNum指ITU的序号。十进制表示。

项目符号

BitNum指开关量标签在ITU中的位序号。范围通常为 0～7。十进制表示。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种模块的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个模块时可省略。
项目符号 | 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

寄存器名称

寄存器

读写类型

数据类型

         st（传感器号）的取值范围 ch（通道号）的取值范围

实时湿度值

R_RAWst:ch

只读

模拟量

         1--16 0

平均湿度值

R_AVERAGEst:ch

只读

模拟量

         1--16 0

平滑湿度值

R_SMOOTHst:ch

只读

模拟量

         1--16 0

标签举例：

寄存器： R_RAW2:0
数据类型： 模拟量
注释： 读取2号传感器所采集到的实时湿度。

寄存器： R_SMOOTH2:0
数据类型： 模拟量
注释： 读取2号传感器所采集到的平滑湿度。

寄存器： R_AVERAGE2:0
数据类型：模拟量
注释： 读取2号传感器所采集到的平均湿度值。


用户常见问题

设备向导首页的“调试设置”按钮有什么用处 设备向导首页的“版本信息”按钮有什么用处
RS485网络应用提示

3.10.0.0版及更高版本中，设备向导首页的“调试设置”按钮有什么用处?

请注意“调试设置”按钮功能只有在开发和调试阶段才能使用，在现场运行时一定要关闭所有调试选项，否则可能会产生不可预见的错误。

点击“调试设置”按钮，打开调试窗口。根据需要打开调试选项，退出保存工程后运行一段时间。开物会记录这段时间发生的一些重要信息。通过这些信息可以达到下面目的：

项目符号

检查标签设计是否有错误
项目符号

查看设备通讯效率，提供设计优化参考
项目符号

检查线路连接情况，是否有强干扰源
项目符号

检查运行计算机的硬件配置，操作系统，运行的开物版本，运行的驱动程序版本。
项目符号

检查系统资源，尤其是内存是否够用。
项目符号

将工程文件夹压缩成一个文件Email给开物2000的技术人员，为技术人员远程离线诊断错误提供原始资料。
项目符号

查找诊断其他与通讯相关的未明错误的原因。

3.10.0.0版及更高版本中，设备向导首页的“版本信息”按钮有什么用处?

通过点击“版本信息”按钮，可以达到下面目的：

项目符号

提示当前所用驱动程序的版本号，方便开物2000的技术服务人员提供更细致的服务。
项目符号

提示驱动程序提供的功能，支持的硬件型号等重要信息。
项目符号

显示最新的驱动程序帮助文件。

我编写了一个M寄存器控制Q寄存器的移位程序，从程序上来讲，应该是Q寄存器的状态变化比M寄存器滞后，（注：两者的扫描周期相同），为什么出现M寄存器的状态变化比Q寄存器滞后？

RS485 网络应用提示

项目符号 | 在RS485 网络中， 当通讯距离增长（<1200m），或波特率提高时，应在网络的 两端最后一个节点处的 com+，com-间并接一只 120 Ω左右的线路匹配电阻，以保障网络的可靠运行。
项目符号 | 当 RS485 网络节点数量增加，（>32）或通讯距离超过 1200m 时，应在网络中适当地加入 RS485 中继器。（最好是隔离型的），以保证网络的通讯顺畅。
项目符号 | RS485网络结构应尽量保证为一条干线，各节点引入的支线段应越短越好，以免引起杂波干扰，影响通讯。
项目符号 | RS485 网络的通讯线最好使用屏蔽双绞线。com+与 com-为一个线对，并且屏蔽层应在网络的源端单点接地，可有效地防止外界干扰。
项目符号 | RS485网络干线在布线时， 应避免与动力线系统电源线靠近或平行布置，尽量与其距离远一些。