沃尔士WS10位移传感器

沃尔士位移传感器（WS10）综述

概述 硬件 连接 创建设备 标签的 创建 标签举例 在线升级驱动

沃尔士位移传感器概述

沃尔士环控系统工程（深圳）公司是一家生产、代理多种位移测量产品的公司。WS10为德国ASM系列产品，测量范围：0-500mm。

关于沃尔士位移传感器的更详细信息请访问 沃尔士公司网站。

开物2000还支持其它多种设备，详情请与 华富惠通公司联系。

沃尔士位移传感器与上位机的连接

WS10 传感器：通过专用插头，经配套的ISA卡和上位机通信

1）WS10 传感器的管脚排列图： 其中管脚1：电源正；管脚2：电源负。电源：DC11-27V

2）WS10 传感器与ISA卡管脚的对应关系：

WS10传感器管脚 | ISA卡连接器管脚 | 备注
3 | 9 | CLOCK
4 | 4 | /CLOCK
5 | 3 | DATA
6 | 7 | /DATA

在开物2000开发环境中创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择‘智能模块’设备类型。双击‘沃尔士WS10模块’，或单击选中‘沃尔士WS10模块’，更改设备名称， 然后单击‘选择’按钮。

步骤2：选中‘新建设备’后单击‘下一步’按钮。

步骤3：显示沃尔士位移传感器配置向导界面。各项均取默认值。单击‘完成’按钮，结束设备配置向导 ，完成硬件设备的创建。

标签的创建

使用设备向导创建完成板卡的配置后，可以进行标签设计。

1、在开发环境的‘标签’项中新建标签，显示下图，选择主设备为上面的‘新建设备’，选择‘主地址’中的‘Distance’，标签名 可改为容易记忆的名字。

单击‘添加’或‘完成’按钮。

标签的地址配置规则

标签的主地址可以按照下面的规则配置填写：

标签类型

说明：

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

标签值范围

Distance

位移距离

模拟量

只读

0-500

标签举例：

标签 ：Distance
数据值类型：模拟量
描述 ：表示位移传感器模拟量输入值

概述 硬件 连接 创建设备 标签的 创建 标签举例 在线升级驱动