京天威电子显示屏

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

本驱动为北京京天威电子有限公司开发的专用电子显示屏驱动程序，它支持文本输出的控制，包括对行、列、文字字体、文本颜色、文本低色的控制。

硬件连接

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的模块。以便于开物2000识别和使用。

步骤1：选择设备类型。双击‘ 京天威电子显示屏’，或单击选中‘ 京天威电子显示屏’，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：显示设备创建方式配置界面。在向导选择 单设备创建，单击‘下一步’按钮。

步骤4：显示设备 配置向导，在此向导中添加相应的设备，并确定其单元号，单击“下一步”按钮。

步骤5：显示串口参数配置向导，在向导中配置好各参数，单击‘下一步’按钮。

步骤6：显示设备及参数汇总窗口，单击‘完成’按钮，结束设备配置向导。

创建标签

使用设备向导创建完成模块的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘ ’，选择并填写‘主设备地址’，修改标签名。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:]ChID[.BitID[.ThirdSegID[.FourSegID[.FiveSegID]]]]

说明：

项目符号

ID指开物设备网络中的 硬件子设备地址，用于识别设备中的 某个硬件子设备。 一般情况下，ID可以是十进制或十六进制表示形式,位数不限。通常从0开始编址。标签地址中省略ID时，开物2000系统默认为是所连接的最小模块地址。

项目符号

ChID一般指通道号。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号

BitID指开关量标签的位序号。可以是八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号

ID,ChID,BitID,ThirdSegID,FourSegID,FiveSegID的含义可以自由定义。可以是十进制或八进制或十六进制表示形式,位数不限。通常从0开始编址。

项目符号 | 红色字表示格式中可变部分，变化范围参见各种 驱动的帮助文件。
项目符号 | 蓝色括号不出现在标签地址中，蓝色括号内的内容在设备中只包含一个 子设备时可省略。
项目符号 | 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址

含义

数据类型

读写类型

ID(设备地址)范围 CH(通道)范围

标签值范围

BGColorID:CH | 文本的底色 | 模拟量 | 只写 | 0-255 | 0 | 依据显示屏支持的颜色而定
ClearID:CH | 清屏 | 模拟量 | 只写 | 0-255 | 0 | True,flase
FontID:CH | 文本字体 | 模拟量 | 只写 | 0-255 | 0 | 0--65535
LineID:CH | 显示文本的行号 | 模拟量 | 只写 | 0-255 | 0 | 0--65535
ROWID:CH | 显示文本的列号 | 模拟量 | 只写 | 0-255 | 0 | 0--65535
TextID:CH | 显示的文本 | 模拟量 | 只写 | 0-255 | 0 | 任一字符，字符的长度跟据屏幕的大小而定

标签举例

标签 ：BGColor 1:0
数据值类型：模拟量
描述 ：表示设置设备配置示例中1号 电子显示屏的底色

标签 ：Clear 1:0
数据值类型：模拟量
描述 ：表示清除设备配置示例中1号电子显示屏上的文本

标签 ：Font1:0
数据值类型：模拟量
描述 ：表示设置1设备配置示例中1号电子显示屏的字体

标签 ：Line 1:0
数据值类型：模拟量
描述 ：表示设置设备配置示例中1号 电子显示屏将要显示文本的行号

标签 ：Row 1:0
数据值类型：模拟量
描述 ：表示设置设备配置示例中1号电子显示屏的列号

标签 ：Text 1:0:
数据值类型：模拟量
描述 ：表示往设备配置示例中1号电子显示屏中送出文本显示