盘古MC100系列记录仪

概述 硬件连接 创建设备 创建标签 标签的地址规则 标签举例 在线升级驱动

概述

硬件连接

该版本驱动是通过盘古MC100系列记录仪通讯口与开物2000进行通讯，具体接线详见仪表使用说明书，

通讯参数设置如下：(建议使用9600bps的波特率)

波特率 | 9600bps
数据位 | 8
停止位 | 1
校验方式 | 无校验

创建设备

在开发环境的‘硬件系统’中按照‘新节点和设备向导’的指示配置所连接的仪表。以便于开物2000识别和使用。

步骤1：选择设备类型，更改设备名称，最后单击‘选择’按钮。

步骤2：选择操作方式-新建设备(一个设备中可以包含多个)。选中‘新建设备’后单击‘下一步’按钮(或双击‘新建设备’)。

步骤3：选择创建方式(一个设备中可以包含多个)。选中 创建方式后单击‘下一步’按钮(或双击‘标准创建’)。

注意：此驱动不支持“自动创建”。

步骤4：设置仪表类型和设备号，单击‘下一步’按钮。

步骤5：设备串口通讯参数，单击‘下一步’。

步骤6：显示设备及参数配置图，点击‘完成’按钮，完成设备配置向导.

创建标签

使用设备向导创建完成PLC设备的配置后，可以进行标签设计。

1、在开发环境的‘标签’中添加标签，显示下图，选择主设备为上面的‘’，选择并填写‘主设备地址’，修改标签名。

2、根据仪表的工作模式和标签所监控的参数物理意义，修改工程值零点、工程值量程、扫描周期、转换方式、记录属性等。单击‘添加’或‘完成’按钮。

注意：仪表通道标签CH、MV、SV等在仪表上有量程设定时，标签的工程值量程要和仪表设置一致，显示数据才能统一起来。目前，P、I、D标签暂不支持，SV、MV、MODE标签没经过测试。

标签的地址规则

标签的主地址可以按照下面的规则配置填写：

标签类型[ID:][CH]

说明：

  • ID指仪表的设备号地址，用于识别设备中的多个仪表， 仪表的设备号地址以十进制表示，地址设定范围为6～ 99 。标签地址中省略ID时，开物2000系统默认为是所连接设备的最小的站号地址。

  • Ch指的是仪表的参数地址。地址范围 和表示形式见参数对照表。

  • 标签地址配置成不存在类型或模块地址错误或通道号超出有效范围时，标签将不被承认，读不上数据。

标签地址 | 含义 | 数据类型 | 读写类型 | 标签值范围
CH ID:Ch | 模拟量输入 | 模拟量 | 只读 | 0～65535
Q ID:Ch | 流量累计 | 模拟量 | 只读 | 0～42949672095
P ID:Ch | PID调节P参数 | 模拟量 | 可读可写 | 0～65535
I ID:Ch | PID调节I参数 | 模拟量 | 可读可写 | 0～65535
D ID:Ch | PID调节D参数 | 模拟量 | 可读可写 | 0～65535
SV ID:Ch | PID调节设定值 | 模拟量 | 可读可写 | 0～65535
MV ID:Ch | PID调节输出值 | 模拟量 | 可读可写 | 0～65535
MODE ID:Ch | PID调节手自动切换 | 开关量 | 可读可写 | FALSE(手动)～TRUE（自动）
标签/仪表型号 | MC100R的Ch范围 | MC100F的Ch范围 | MC100C的Ch范围
CH ID:Ch | 0～2 | 0～2 | 0～2
Q ID:Ch | 无 | 0～2 | 0～2
P ID:Ch | 无 | 无 | 0
I ID:Ch | 无 | 无 | 0
D ID:Ch | 无 | 无 | 0
SV ID:Ch | 无 | 无 | 0
MV ID:Ch | 无 | 无 | 0
MODE ID:Ch | 无 | 无 | 0

标签举例

标签 ：CH 6:0
 数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的1通道的模拟量输入的值

标签 ：CH6:1
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的2通道的模拟量输入的值

标签 ：CH6:2
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的3通道的模拟量输入的值

标签 ：Q6:0
 数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的1通道的累计量的值

标签 ：Q6:1
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的2通道的累计量的值

标签 ：Q6:2
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的仪表的3通道的累计量的值

标签 ：P6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的P参数值

标签 ：I6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的I参数值

标签 ：D 6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的D参数值

标签 ：SV 6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的给定参数值

标签 ：MV 6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的输出参数值

标签 ： MODE6:0
数据值类型：模拟量
描述 ：表示设备配置示例中设备号地址为6的PID仪表的手自动切换参数值